aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnokii/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2011-07-14 22:38:22 +0800
committerarved <arved@FreeBSD.org>2011-07-14 22:38:22 +0800
commit698edba423bf902abc7198b7c67c6b97f5d2902c (patch)
treef86c48fd3b97979281ade77dc1c8b40a4d4a52ab /comms/gnokii/Makefile
parent54536be569e0db32c4efa47edd842c94cf768d6f (diff)
downloadfreebsd-ports-gnome-698edba423bf902abc7198b7c67c6b97f5d2902c.tar.gz
freebsd-ports-gnome-698edba423bf902abc7198b7c67c6b97f5d2902c.tar.zst
freebsd-ports-gnome-698edba423bf902abc7198b7c67c6b97f5d2902c.zip
Fix build with clang
PR: 158660 Submitted by: maintainer
Diffstat (limited to 'comms/gnokii/Makefile')
-rw-r--r--comms/gnokii/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 67493442a876..062b75cb4f98 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -26,15 +26,16 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
+USE_CSTD= gnu89
MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
USE_GNOME= intltool
GNU_CONFIGURE= yes
+CPPFLAGS= ${CFLAGS} -I${LOCALBASE}/include -fPIC
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE} --enable-security \
--with-xgnokiidir=${PREFIX}/share
CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
XGETTEXT="${LOCALBASE}/bin/xgettext" \
- CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -fPIC" \
LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="-L${WRKSRC}/common -L${LOCALBASE}/lib" \
PKG_CONFIG="${LOCALBASE}/bin/pkg-config"