aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnokii
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-06-07 03:27:00 +0800
committerrene <rene@FreeBSD.org>2011-06-07 03:27:00 +0800
commitf0daa69e30f94c1ff070cee511b5678c17f95bbc (patch)
tree43759e01f0a0336b8eaca6d85a57965d2e5c82f9 /comms/gnokii
parent0d6bfb5edca494ea43c71806dc204f6962eccc50 (diff)
downloadfreebsd-ports-gnome-f0daa69e30f94c1ff070cee511b5678c17f95bbc.tar.gz
freebsd-ports-gnome-f0daa69e30f94c1ff070cee511b5678c17f95bbc.tar.zst
freebsd-ports-gnome-f0daa69e30f94c1ff070cee511b5678c17f95bbc.zip
Change this port to use the GROUPS variable
PR: ports/157545 Submitted by: Chris Rees [utisoft gmail com] Approved by: maintainer
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile5
-rw-r--r--comms/gnokii/pkg-install22
2 files changed, 1 insertions, 26 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index b13380459c02..67493442a876 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -21,6 +21,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+GROUPS= ${PORTNAME}
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
@@ -38,7 +39,6 @@ CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
LIBS="-L${WRKSRC}/common -L${LOCALBASE}/lib" \
PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
-PKGDEINSTALL= ${PKGINSTALL}
SUB_FILES+= pkg-message
PORTDOCS= *
MAN1= gnokii.1 sendsms.1 xgnokii.1
@@ -126,9 +126,6 @@ post-patch:
${WRKSRC}/${CONFIGURE_SCRIPT}
@${MV} ${WRKSRC}/Docs/man/xgnokii.1x ${WRKSRC}/Docs/man/xgnokii.1
-pre-install:
- @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
${INSTALL_DATA} ${WRKSRC}/xgnokii/xgnokii.pc ${PREFIX}/libdata/pkgconfig
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/comms/gnokii/pkg-install b/comms/gnokii/pkg-install
index de143b544a51..5764819d8882 100644
--- a/comms/gnokii/pkg-install
+++ b/comms/gnokii/pkg-install
@@ -2,8 +2,6 @@
PATH=/bin:/usr/bin:/usr/sbin
-GROUP=gnokii
-
SUIDBINS="${PKG_PREFIX}/sbin/gnokiid ${PKG_PREFIX}/sbin/mgnokiidev"
BINS="${PKG_PREFIX}/bin/gnokii ${SUIDBINS}"
@@ -12,30 +10,10 @@ if [ -e ${PKG_PREFIX}/bin/xgnokii ]; then
fi
case "$2" in
-"PRE-INSTALL")
- if pw group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if pw groupadd ${GROUP}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
- ;;
-
"POST-INSTALL")
chgrp $GROUP $BINS
chmod 750 ${BINS}
chmod u+s ${SUIDBINS}
;;
-"DEINSTALL")
- if [ -z "`pw groupshow $GROUP 2>&1 | sed -E -e 's/^([^:]+:){3}(.*)$/\2/'`" ]; then
- echo "Removing empty group \"$GROUP\"."
- pw groupdel $GROUP
- fi
- ;;
-
esac