aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnokii
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-06-09 19:02:27 +0800
committermadpilot <madpilot@FreeBSD.org>2012-06-09 19:02:27 +0800
commit53b47cc99f45ec635ed3f1bfed39474bc6931845 (patch)
tree46c1bb13f4e75527940958533deea61c7d2c978c /comms/gnokii
parent694da0b63194e6488f307d7bf69573788cc7237a (diff)
downloadfreebsd-ports-gnome-53b47cc99f45ec635ed3f1bfed39474bc6931845.tar.gz
freebsd-ports-gnome-53b47cc99f45ec635ed3f1bfed39474bc6931845.tar.zst
freebsd-ports-gnome-53b47cc99f45ec635ed3f1bfed39474bc6931845.zip
- Use new options framework "MULTI" feature.
Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 5a292a67da63..2d8310bda37b 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -47,16 +47,16 @@ MAN8= gnokiid.8 mgnokiidev.8
CONFLICTS= smstools-[0-9]* sendsms-[0-9]*
-OPTIONS_DEFINE= DOCS ICAL MYSQL PCSC PGSQL SMSD SQLITE USB X11
+OPTIONS_DEFINE= DOCS ICAL PCSC SMSD SMSDDB USB X11
+OPTIONS_MULTI= SMSDDB
+OPTIONS_MULTI_SMSDDB= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= X11
ICAL_DESC= Build with IETF iCal support
USB_DESC= Build with libusb support
PCSC_DESC= Build with PC/SC-Lite support
-SMSD_DESC= Enable smsd daemon
-MYSQL_DESC= Enable MySQL backend for smsd
-PGSQL_DESC= Enable PostgreSQL backend for smsd
-SQLITE_DESC= Enable SQLite backend in smsd
+SMSD_DESC= Enable smsd daemon (includes "file" backend)
+SMSDDB_DESC= Enable database support in smsd (select one or more)
X11_DESC= Build graphical version (xgnokii)
.include <bsd.port.options.mk>
@@ -81,7 +81,7 @@ LIB_DEPENDS+= pcsclite:${PORTSDIR}/devel/pcsc-lite
CONFIGURE_ARGS+= --disable-libpcsclite
.endif
-.if !${PORT_OPTIONS:MSMSD}
+.if empty(PORT_OPTIONS:MSMSD)
PLIST_SUB+= SMSD='@comment ' MSM='@comment ' PGM='@comment ' SQLT='@comment '
CONFIGURE_ARGS+= --disable-smsd
.else