aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnuradio
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-08-19 21:29:59 +0800
committermat <mat@FreeBSD.org>2015-08-19 21:29:59 +0800
commit9d30f78a00bed11384c7259f662e9352754275db (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /comms/gnuradio
parent996088dedaf9d22bcd7c90caa96d33c0f68b08e7 (diff)
downloadfreebsd-ports-gnome-9d30f78a00bed11384c7259f662e9352754275db.tar.gz
freebsd-ports-gnome-9d30f78a00bed11384c7259f662e9352754275db.tar.zst
freebsd-ports-gnome-9d30f78a00bed11384c7259f662e9352754275db.zip
Convert ports to use the options helpers in categories [abc]*, and minor fixes.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3412?
Diffstat (limited to 'comms/gnuradio')
-rw-r--r--comms/gnuradio/Makefile49
1 files changed, 18 insertions, 31 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index a54c3fc7e42b..d9978cb93b1d 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -66,39 +66,26 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION}
VP= ${GCC_DEFAULT:S/.//}
GCC_LIBS= ${LOCALBASE}/lib/gcc${VP}
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
- ${LOCALBASE}/bin/sphinx-apidoc:${PORTSDIR}/textproc/py-sphinx \
- dot:${PORTSDIR}/graphics/graphviz \
- xmlto:${PORTSDIR}/textproc/xmlto \
- freefont-ttf>0:${PORTSDIR}/x11-fonts/freefont-ttf
-CMAKE_ARGS+= -DENABLE_DOXYGEN:STRING="ON"
-CMAKE_ARGS+= -DENABLE_DOCS:STRING="ON"
-CMAKE_ARGS+= -DENABLE_BAD_BOOST="ON"
+DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen \
+ ${LOCALBASE}/bin/sphinx-apidoc:${PORTSDIR}/textproc/py-sphinx \
+ dot:${PORTSDIR}/graphics/graphviz \
+ xmlto:${PORTSDIR}/textproc/xmlto \
+ freefont-ttf>0:${PORTSDIR}/x11-fonts/freefont-ttf
+DOCS_CMAKE_ON= -DENABLE_DOXYGEN:STRING="ON" \
+ -DENABLE_DOCS:STRING="ON" \
+ -DENABLE_BAD_BOOST="ON"
+DOCS_CMAKE_OFF= -DENABLE_DOXYGEN:STRING="OFF" \
+ -DENABLE_DOCS:STRING="OFF" \
+ -DENABLE_BAD_BOOST="ON"
HAVE_PORTDOCS= YES
-.else
-CMAKE_ARGS+= -DENABLE_DOXYGEN:STRING="OFF"
-CMAKE_ARGS+= -DENABLE_DOCS:STRING="OFF"
-CMAKE_ARGS+= -DENABLE_BAD_BOOST="ON"
-.endif
-.if ${PORT_OPTIONS:MUSRP}
-CMAKE_ARGS+= -DENABLE_GR_UHD:STRING="ON"
-BUILD_DEPENDS+= ${LOCALBASE}/include/uhd/config.hpp:${PORTSDIR}/comms/usrp
-PLIST_SUB+= UHD=""
-.else
-CMAKE_ARGS+= -DENABLE_GR_UHD:STRING="OFF"
-PLIST_SUB+= UHD="@comment "
-.endif
+USRP_CMAKE_ON= -DENABLE_GR_UHD:STRING="ON"
+USRP_CMAKE_OFF= -DENABLE_GR_UHD:STRING="OFF"
+USRP_BUILD_DEPENDS= ${LOCALBASE}/include/uhd/config.hpp:${PORTSDIR}/comms/usrp
-.if ${PORT_OPTIONS:MTESTING}
-CMAKE_ARGS+= -DENABLE_TESTING:STRING="ON"
-BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
-.else
-CMAKE_ARGS+= -DENABLE_TESTING:STRING="OFF"
-.endif
+TESTING_CMAKE_ON= -DENABLE_TESTING:STRING="ON"
+TESTING_CMAKE_OFF= -DENABLE_TESTING:STRING="OFF"
+TESTING_BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
post-patch:
@${FIND} ${WRKSRC}/.. -name CMakeLists.txt | \
@@ -110,4 +97,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/cmake/Modules/FindPortaudio.cmake
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>