aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnuradio
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /comms/gnuradio
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'comms/gnuradio')
-rw-r--r--comms/gnuradio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 53583e2ad351..67e97329a43e 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -48,7 +48,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# volk/lib/volk_cpu.c: In function 'i_can_has_3dnow':
# volk/lib/volk_cpu.c:62: error: can't find a register in class 'BREG' while reloading 'asm'
# volk/lib/volk_cpu.c:62: error: 'asm' operand has impossible constraints
-USES= cmake:outsource compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 shebangfix
+USES= cmake:outsource compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 qt:4 shebangfix
SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in \
gnuradio-runtime/python/gnuradio/ctrlport/gr-ctrlport-monitor \
gnuradio-runtime/python/gnuradio/ctrlport/gr-perf-monitorx
@@ -67,7 +67,7 @@ DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
USE_GNOME= pygtk2
USE_PYQT= core gui opengl
USE_WX= 3.0+
-USE_QT4= corelib gui xml qmake moc_build rcc_build uic_build
+USE_QT= corelib gui xml qmake moc_build rcc_build uic_build
WX_COMPS= wx wx:build wx:run python:build python:run
USE_LDCONFIG= yes
PLIST_SUB+= MAJOR_VERSION="3"