aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gr-osmosdr
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-11-08 18:49:16 +0800
committermartymac <martymac@FreeBSD.org>2013-11-08 18:49:16 +0800
commit01f12c6b9467d7e9b837b1f8ae898e120f3ed8e5 (patch)
treed6cdd042f3799769e826e5134e1a9c4f19d20055 /comms/gr-osmosdr
parentcb4ff1ca2887925ea14c914198b860cf7d61e7a6 (diff)
downloadfreebsd-ports-gnome-01f12c6b9467d7e9b837b1f8ae898e120f3ed8e5.tar.gz
freebsd-ports-gnome-01f12c6b9467d7e9b837b1f8ae898e120f3ed8e5.tar.zst
freebsd-ports-gnome-01f12c6b9467d7e9b837b1f8ae898e120f3ed8e5.zip
- Enable staging
- Use new LIB_DEPENDS format - Use new options framework
Diffstat (limited to 'comms/gr-osmosdr')
-rw-r--r--comms/gr-osmosdr/Makefile24
-rw-r--r--comms/gr-osmosdr/pkg-plist5
2 files changed, 14 insertions, 15 deletions
diff --git a/comms/gr-osmosdr/Makefile b/comms/gr-osmosdr/Makefile
index 7285bdb81db6..3682958cbf12 100644
--- a/comms/gr-osmosdr/Makefile
+++ b/comms/gr-osmosdr/Makefile
@@ -15,11 +15,11 @@ LICENSE= GPLv3
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13 \
cheetah:${PORTSDIR}/devel/py-cheetah
-LIB_DEPENDS= gnuradio-core:${PORTSDIR}/comms/gnuradio \
- gnuradio-fcd:${PORTSDIR}/comms/gnuradio \
- gruel:${PORTSDIR}/comms/gnuradio \
- boost_system:${PORTSDIR}/devel/boost-libs \
- boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libgnuradio-core.so:${PORTSDIR}/comms/gnuradio \
+ libgnuradio-fcd.so:${PORTSDIR}/comms/gnuradio \
+ libgruel.so:${PORTSDIR}/comms/gnuradio \
+ libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs
USES= pkgconfig cmake
USE_LDCONFIG= yes
@@ -32,17 +32,11 @@ CMAKE_ARGS+= -DENABLE_DEFAULT:BOOL=OFF \
OPTIONS_DEFINE= RTLSDR
RTLSDR_DESC= Enable rtl-sdr (RTL2832) support
OPTIONS_DEFAULT= RTLSDR
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MRTLSDR}
-LIB_DEPENDS+= rtlsdr:${PORTSDIR}/comms/rtl-sdr
-CMAKE_ARGS+= -DENABLE_RTL:BOOL=ON \
- -DENABLE_RTL_TCP:BOOL=ON
-.endif
+RTLSDR_LIB_DEPENDS= librtlsdr.so:${PORTSDIR}/comms/rtl-sdr
+RTLSDR_CMAKE_ON= -DENABLE_RTL:BOOL=ON -DENABLE_RTL_TCP:BOOL=ON
post-install:
- ${LN} -s libgnuradio-osmosdr.so.0.0.1git ${PREFIX}/lib/libgnuradio-osmosdr.so.0
+ @${LN} -sf libgnuradio-osmosdr.so.0.0.1git \
+ ${STAGEDIR}${PREFIX}/lib/libgnuradio-osmosdr.so.0
.include <bsd.port.mk>
diff --git a/comms/gr-osmosdr/pkg-plist b/comms/gr-osmosdr/pkg-plist
index be2d4628cb31..82e8703bd149 100644
--- a/comms/gr-osmosdr/pkg-plist
+++ b/comms/gr-osmosdr/pkg-plist
@@ -29,4 +29,9 @@ share/gnuradio/grc/blocks/osmosdr_source_c.xml
%%PYTHON_SITELIBDIR%%/osmosdr/__init__.pyo
@dirrm include/osmosdr/swig
@dirrm include/osmosdr
+@dirrmtry share/gnuradio/grc/blocks
+@dirrmtry share/gnuradio/grc
+@dirrmtry share/gnuradio
@dirrm %%PYTHON_SITELIBDIR%%/osmosdr
+@dirrmtry %%PYTHON_SITELIBDIR%%
+@dirrmtry %%PYTHON_LIBDIR%%