aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gscmxx/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-08 19:04:34 +0800
committeredwin <edwin@FreeBSD.org>2003-10-08 19:04:34 +0800
commit19ded4f7a70181a882212b560cbe69bf41df2aef (patch)
tree2375c44dbdbce6a072eb54271e65d0f122abc794 /comms/gscmxx/Makefile
parent5d92353fbc67e0b13ec14e6e10d02c5597d84daf (diff)
downloadfreebsd-ports-gnome-19ded4f7a70181a882212b560cbe69bf41df2aef.tar.gz
freebsd-ports-gnome-19ded4f7a70181a882212b560cbe69bf41df2aef.tar.zst
freebsd-ports-gnome-19ded4f7a70181a882212b560cbe69bf41df2aef.zip
new port: comms/gscmxx 0.4.1 - gtk-frontend for scmxx
gscmxx can access siemens cellular phones via scmxx. it supports phonebooks, addressbooks, sms and some other features. PR: ports/52176 Submitted by: Sven Mohr <svmohr@red-mercury.de>
Diffstat (limited to 'comms/gscmxx/Makefile')
-rw-r--r--comms/gscmxx/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/comms/gscmxx/Makefile b/comms/gscmxx/Makefile
new file mode 100644
index 000000000000..84621b1037d3
--- /dev/null
+++ b/comms/gscmxx/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gscmxx
+# Date created: 13 May 2003
+# Whom: svmohr
+#
+# $FreeBSD$
+#
+
+PORTNAME= gscmxx
+PORTVERSION= 0.4.1
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= svmohr@red-mercury.de
+COMMENT= A graphical frontend for scmxx
+
+RUN_DEPENDS= ${SITE_PERL}/mach/Gtk:${PORTSDIR}/x11-toolkits/p5-Gtk
+BUILD_DEPENDS= ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
+ ${SITE_PERL}/mach/Gtk:${PORTSDIR}/x11-toolkits/p5-Gtk \
+ scmxx:${PORTSDIR}/comms/scmxx \
+ convert:${PORTSDIR}/graphics/ImageMagick
+
+PERL_CONFIGURE= YES
+
+USE_GNOME= gtk12
+MAN1= gscmxx.1
+
+.include <bsd.port.mk>