aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hamfax
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-06 03:07:33 +0800
committerpav <pav@FreeBSD.org>2003-12-06 03:07:33 +0800
commitb2c0f928f465e576cf15adfa99bfe16fd36a077c (patch)
tree720656933ed8fcb12baa9af29ab580620e80ff65 /comms/hamfax
parentfcfc7f08439186dc7593048b3c2d734af14fc2f3 (diff)
downloadfreebsd-ports-gnome-b2c0f928f465e576cf15adfa99bfe16fd36a077c.tar.gz
freebsd-ports-gnome-b2c0f928f465e576cf15adfa99bfe16fd36a077c.tar.zst
freebsd-ports-gnome-b2c0f928f465e576cf15adfa99bfe16fd36a077c.zip
Add hamfax, a Qt/X11 application for sending and receiving facsimiles
over ham radio. PR: ports/53444 Submitted by: Carl Makin <carl@stagecraft.cx>
Diffstat (limited to 'comms/hamfax')
-rw-r--r--comms/hamfax/Makefile28
-rw-r--r--comms/hamfax/distinfo1
-rw-r--r--comms/hamfax/files/patch-configure11
-rw-r--r--comms/hamfax/files/patch-sound.hpp11
-rw-r--r--comms/hamfax/pkg-descr8
-rw-r--r--comms/hamfax/pkg-plist4
6 files changed, 63 insertions, 0 deletions
diff --git a/comms/hamfax/Makefile b/comms/hamfax/Makefile
new file mode 100644
index 000000000000..9c397d895fbf
--- /dev/null
+++ b/comms/hamfax/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: hamfax
+# Date created: 7th June 2003
+# Whom: Carl Makin <carl@stagecraft.cx>
+#
+# $FreeBSD$
+
+PORTNAME= hamfax
+PORTVERSION= 0.6.3
+CATEGORIES= comms audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= hamfax
+DISTNAME= HamFax-${PORTVERSION}
+
+MAINTAINER= carl@stagecraft.cx
+COMMENT= QT application for sending and receiving facsimiles over radio
+
+LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+
+USE_QT_VER= 3
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-Qt-dir=${X11BASE} CXX="g++ ${PTHREAD_CFLAGS}" \
+ LIBS="-lcipher ${PTHREAD_LIBS}" CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+.include <bsd.port.mk>
diff --git a/comms/hamfax/distinfo b/comms/hamfax/distinfo
new file mode 100644
index 000000000000..4b480f03af01
--- /dev/null
+++ b/comms/hamfax/distinfo
@@ -0,0 +1 @@
+MD5 (HamFax-0.6.3.tar.bz2) = 1bca27a126079abaea522750562afbe2
diff --git a/comms/hamfax/files/patch-configure b/comms/hamfax/files/patch-configure
new file mode 100644
index 000000000000..46618fdb3593
--- /dev/null
+++ b/comms/hamfax/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Jun 7 11:05:07 2003
++++ configure Sat Jun 7 11:08:01 2003
+@@ -4172,7 +4172,7 @@
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }
+- bnv_err_4=`grep -v '^ *+' bnv_qt_test_4.out`
++ bnv_err_4=`grep -v '^ *+' bnv_qt_test_4.out | grep -v warning:`
+ if test x"$bnv_err_4" != x; then
+ echo "$bnv_err_4" >&5
+ else
diff --git a/comms/hamfax/files/patch-sound.hpp b/comms/hamfax/files/patch-sound.hpp
new file mode 100644
index 000000000000..2903185703b0
--- /dev/null
+++ b/comms/hamfax/files/patch-sound.hpp
@@ -0,0 +1,11 @@
+--- src/Sound.hpp.orig Sat Jun 7 11:12:19 2003
++++ src/Sound.hpp Sat Jun 7 11:12:43 2003
+@@ -19,6 +19,8 @@
+ #ifndef SOUND_HPP
+ #define SOUND_HPP
+
++#define AFMT_S16_NE AFMT_S16_LE
++
+ #include <qobject.h>
+ #include <qstring.h>
+ #include <qsocketnotifier.h>
diff --git a/comms/hamfax/pkg-descr b/comms/hamfax/pkg-descr
new file mode 100644
index 000000000000..703b483d9e55
--- /dev/null
+++ b/comms/hamfax/pkg-descr
@@ -0,0 +1,8 @@
+HamFax is a Qt/X11 application for sending and receiving facsimiles. It is
+licensed under the GNU General Public License (GPL), see the file COPYING for
+the complete text.
+
+If you have questions or comments please send them to me
+(cschmitt@users.sourceforge.net). I would like to have some feedback.
+
+WWW: http://hamfax.sourceforge.net/
diff --git a/comms/hamfax/pkg-plist b/comms/hamfax/pkg-plist
new file mode 100644
index 000000000000..e26f7956ac1e
--- /dev/null
+++ b/comms/hamfax/pkg-plist
@@ -0,0 +1,4 @@
+bin/hamfax
+share/HamFax/HamFax.html
+share/HamFax/hamfax_de.qm
+@dirrm share/HamFax