aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hcidump/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-12-11 04:10:22 +0800
committerpav <pav@FreeBSD.org>2004-12-11 04:10:22 +0800
commit225b75ecd21f1833c12d362ff4a99fdad80eb493 (patch)
treef4279b687a060cab1ed4849bbf6fd9df61e18c35 /comms/hcidump/Makefile
parent5923ad9a930790bca5272a33fd50a140ac3352e4 (diff)
downloadfreebsd-ports-gnome-225b75ecd21f1833c12d362ff4a99fdad80eb493.tar.gz
freebsd-ports-gnome-225b75ecd21f1833c12d362ff4a99fdad80eb493.tar.zst
freebsd-ports-gnome-225b75ecd21f1833c12d362ff4a99fdad80eb493.zip
Add hcidump, utility similar to tcpdump, but operating on Bluetooth stack.
This was ported to FreeBSD by emax and neglected by ports people for too long.
Diffstat (limited to 'comms/hcidump/Makefile')
-rw-r--r--comms/hcidump/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/comms/hcidump/Makefile b/comms/hcidump/Makefile
new file mode 100644
index 000000000000..14012e37e956
--- /dev/null
+++ b/comms/hcidump/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hcidump
+# Date created: 10 Dec 2004
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hcidump
+PORTVERSION= 1.5
+CATEGORIES= comms sysutils
+MASTER_SITES= http://www.geocities.com/m_evmenkin/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Bluetooth traffic dumper, similar to tcpdump
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= hcidump.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/hcidump
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502000
+IGNORE= it needs Bluetooth stack (FreeBSD 5.2 or newer)
+.endif
+
+.if ${OSVERSION} < 502121
+# libbluetooth is only installed on i386 before this version
+ONLY_FOR_ARCHS= i386
+.endif
+
+.include <bsd.port.post.mk>