aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hcidump
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-12-11 04:10:22 +0800
committerpav <pav@FreeBSD.org>2004-12-11 04:10:22 +0800
commit225b75ecd21f1833c12d362ff4a99fdad80eb493 (patch)
treef4279b687a060cab1ed4849bbf6fd9df61e18c35 /comms/hcidump
parent5923ad9a930790bca5272a33fd50a140ac3352e4 (diff)
downloadfreebsd-ports-gnome-225b75ecd21f1833c12d362ff4a99fdad80eb493.tar.gz
freebsd-ports-gnome-225b75ecd21f1833c12d362ff4a99fdad80eb493.tar.zst
freebsd-ports-gnome-225b75ecd21f1833c12d362ff4a99fdad80eb493.zip
Add hcidump, utility similar to tcpdump, but operating on Bluetooth stack.
This was ported to FreeBSD by emax and neglected by ports people for too long.
Diffstat (limited to 'comms/hcidump')
-rw-r--r--comms/hcidump/Makefile33
-rw-r--r--comms/hcidump/distinfo2
-rw-r--r--comms/hcidump/files/patch-hcidump-Makefile19
-rw-r--r--comms/hcidump/files/patch-parser-Makefile12
-rw-r--r--comms/hcidump/pkg-descr4
5 files changed, 70 insertions, 0 deletions
diff --git a/comms/hcidump/Makefile b/comms/hcidump/Makefile
new file mode 100644
index 000000000000..14012e37e956
--- /dev/null
+++ b/comms/hcidump/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hcidump
+# Date created: 10 Dec 2004
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hcidump
+PORTVERSION= 1.5
+CATEGORIES= comms sysutils
+MASTER_SITES= http://www.geocities.com/m_evmenkin/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Bluetooth traffic dumper, similar to tcpdump
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= hcidump.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/hcidump
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502000
+IGNORE= it needs Bluetooth stack (FreeBSD 5.2 or newer)
+.endif
+
+.if ${OSVERSION} < 502121
+# libbluetooth is only installed on i386 before this version
+ONLY_FOR_ARCHS= i386
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/hcidump/distinfo b/comms/hcidump/distinfo
new file mode 100644
index 000000000000..574b9deecaf9
--- /dev/null
+++ b/comms/hcidump/distinfo
@@ -0,0 +1,2 @@
+MD5 (hcidump-1.5.tar.gz) = 1fd74128cfc55a9b75032959bb9d90a0
+SIZE (hcidump-1.5.tar.gz) = 32351
diff --git a/comms/hcidump/files/patch-hcidump-Makefile b/comms/hcidump/files/patch-hcidump-Makefile
new file mode 100644
index 000000000000..cc47e508a4b5
--- /dev/null
+++ b/comms/hcidump/files/patch-hcidump-Makefile
@@ -0,0 +1,19 @@
+--- hcidump/Makefile.orig Fri Mar 12 23:16:58 2004
++++ hcidump/Makefile Fri Dec 10 21:06:23 2004
+@@ -2,13 +2,12 @@
+ # $FreeBSD$
+
+ PROG= hcidump
+-BINDIR= /usr/local/bin
+-MANDIR= /usr/local/man/man
++BINDIR= ${PREFIX}/bin
++MANDIR= ${PREFIX}/man/man
+ MAN1= hcidump.1
+ SRCS= hcidump.c
+ WARNS?= 2
+-DEBUG_FLAGS= -g
+-CFLAGS= -O2 -I../parser
++CFLAGS+= -I../parser
+
+ DPADD+= ../parser/libparser.a
+ LDADD+= -L../parser -lparser
diff --git a/comms/hcidump/files/patch-parser-Makefile b/comms/hcidump/files/patch-parser-Makefile
new file mode 100644
index 000000000000..ecb5464b60d3
--- /dev/null
+++ b/comms/hcidump/files/patch-parser-Makefile
@@ -0,0 +1,12 @@
+--- parser/Makefile.orig Fri Mar 12 23:16:59 2004
++++ parser/Makefile Fri Dec 10 21:07:28 2004
+@@ -7,8 +7,7 @@
+ MAN=
+ SRCS= bnep.c cmtp.c hidp.c l2cap.c rfcomm.c hci.c parser.c sdp.c
+ WARNS?= 2
+-DEBUG_FLAGS= -g
+-CFLAGS= -O2
++CFLAGS?= -O2
+
+ NOPROFILE= 1
+
diff --git a/comms/hcidump/pkg-descr b/comms/hcidump/pkg-descr
new file mode 100644
index 000000000000..455e813c92ca
--- /dev/null
+++ b/comms/hcidump/pkg-descr
@@ -0,0 +1,4 @@
+HCIdump reads raw HCI data coming from and going to a Bluetooth device and
+prints to screen commands, events and data in a human-readable form.
+Optionally, the dump can be written to a file rather than parsed, and the dump
+file can be parsed in a subsequent moment.