aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2000-06-27 19:59:36 +0800
committeralex <alex@FreeBSD.org>2000-06-27 19:59:36 +0800
commit29d8e9274456c869d5b28a8246b631cff9383800 (patch)
treea6a0543e92428d225517dce624f5c014c13510a5 /comms/hylafax/Makefile
parentd6a5b4a9a5b5be2d266fcd53fe8597ea66e3a5aa (diff)
downloadfreebsd-ports-gnome-29d8e9274456c869d5b28a8246b631cff9383800.tar.gz
freebsd-ports-gnome-29d8e9274456c869d5b28a8246b631cff9383800.tar.zst
freebsd-ports-gnome-29d8e9274456c869d5b28a8246b631cff9383800.zip
Update to version 4.1.b2, the latest stable release (dispite the "beta" flag),
which officially fixes the setuid security exploit by the vendors. Additionally, from the PR: * adds in distribution patches to allow it to interoperate with libtiff-3.5.5 (the current version in the ports tree), and replace an original FreeBSD patch. * includes security patches (replacements of 'strcpy' and 'sprintf', primarily), mostly based on patches originally submitted by Alex Langer [1] for 4.0pl2 and not yet commited, although some new work was done too. [1] I don't think, that these were my patches but those submitted by John Holland <john@zoner.org> in PR 19180. * Fixes some issues with the configure/setup scripts introduced since the previous version. * Additionally, original FreeBSD patches from 4.0pl2 were merged in where they were not addressed by anything else. (except the I18N patch, sorry). I removed the FORBIDDEN line since there are at least no obvious security concerns left. PR: 19237 Submitted by: Andy Sparrow <andy@geek4food.org>
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile39
1 files changed, 16 insertions, 23 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 4ee8ccc63a82..fcefae554424 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -6,17 +6,14 @@
#
PORTNAME= hylafax
-PORTVERSION= 4.0.2
+PORTVERSION= 4.1.b2
CATEGORIES= comms
-MASTER_SITES= ftp://ftp.sgi.com/sgi/fax/source/ \
- ftp://ftp.leo.org/pub/comp/os/unix/networking/fax/hylafax/source/ \
- ftp://ftp.sisis.de/pub/hylafax/source/
-DISTNAME= ${PORTNAME}-v4.0pl2
-EXTRACT_SUFX= -tar.gz
+MASTER_SITES= ftp://ftp.hylafax.org/hylafax/source/BETA/
+DISTNAME= ${PORTNAME}-4.1beta2
PATCH_SITES= http://www.hylafax.org/patches/
-PATCHFILES= gcc-2.8.x.patch
-PATCH_DIST_STRIP= -p1
+PATCHFILES= tiff-3.5-interfaces.patch cvtDateTime.patch
+PATCH_DIST_STRIP= -p0
MAINTAINER= ports@FreeBSD.org
@@ -28,12 +25,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg
-FORBIDDEN= "Security hole (buffer overflow yielding setuid uucp)"
-
DIST_SUBDIR= hylafax
-Y2K= http://www.hylafax.org/HylaFAQ/Q189.html
-
USE_GMAKE= yes
CONFIGURE_ARGS= --with-INSTALL="" \
--with-MAKE=gmake --with-CC=/usr/bin/cc \
@@ -41,18 +34,18 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-TIFFINC="${LOCALBASE}/include"
HAS_CONFIGURE= yes
-MAN1= hylafax.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 sendfax.1 \
+MAN1= hylafax.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 sendfax.1 \
sendpage.1 sgi2fax.1 textfmt.1
-MAN5= pagesizes.5f typerules.5f \
- hylafax.5f cid.5f config.5f destctrls.5f dialrules.5f hosts.5f \
- info.5f log.5f pagermap.5f recvq.5f sendq.5f shutdown.5f status.5f \
- tsi.5f xferlog.5f
-MAN8= cqtest.8c choptest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
- faxanswer.8c faxconfig.8c faxmodem.8c faxstate.8c faxcron.8c \
- faxgetty.8c faxinfo.8c faxq.8c faxqclean.8c faxquit.8c faxrcvd.8c \
- faxsend.8c faxsetup.8c faxwatch.8c hfaxd.8c mkcover.8c notify.8c \
- pagesend.8c pollrcvd.8c ps2fax.8c recvstats.8c tagtest.8c tiff2fax.8c \
- tiffcheck.8c tsitest.8c wedged.8c xferstats.8c
+MAN5= pagesizes.5f typerules.5f hosts.hfaxd.5f xferfaxlog.5f \
+ hylafax.5f cid.5f config.5f destctrls.5f dialrules.5f info.5f \
+ log.5f pagermap.5f recvq.5f sendq.5f shutdown.5f status.5f tsi.5f
+MAN8= cqtest.8c choptest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
+ faxadduser.8c faxanswer.8c faxconfig.8c faxdeluser.8c faxmodem.8c \
+ faxstate.8c faxcron.8c faxgetty.8c faxinfo.8c faxq.8c faxqclean.8c \
+ faxquit.8c faxrcvd.8c faxsend.8c faxsetup.8c faxwatch.8c hfaxd.8c \
+ mkcover.8c notify.8c pagesend.8c pollrcvd.8c ps2fax.8c recvstats.8c \
+ tagtest.8c tiff2fax.8c tiffcheck.8c tsitest.8c wedged.8c \
+ xferfaxstats.8c
SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter