aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-10-17 07:51:18 +0800
committermi <mi@FreeBSD.org>2001-10-17 07:51:18 +0800
commit300efeb534ccbf0707cf9d5efd3009df45277fe8 (patch)
tree3fa6d4d1c9ceb7f3e32aed1200b8ded33e578abf /comms/hylafax/Makefile
parentb8c447e03f6d3f62f37ae9a70d7dcaa7e675021e (diff)
downloadfreebsd-ports-gnome-300efeb534ccbf0707cf9d5efd3009df45277fe8.tar.gz
freebsd-ports-gnome-300efeb534ccbf0707cf9d5efd3009df45277fe8.tar.zst
freebsd-ports-gnome-300efeb534ccbf0707cf9d5efd3009df45277fe8.zip
Upgrade to 4.1 (release -- released in July). The size
of the pkg-plist diff is due to the default location move from /var/spool/fax to /var/spool/hylafax. Also, allow package building by passing -nointeractive to configure.
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile38
1 files changed, 25 insertions, 13 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 1e4fa64185a7..ccc7b13ca281 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -6,15 +6,9 @@
#
PORTNAME= hylafax
-PORTVERSION= 4.1.b2
-PORTREVISION= 2
+PORTVERSION= 4.1
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
-DISTNAME= ${PORTNAME}-4.1beta2
-
-PATCH_SITES= http://www.hylafax.org/patches/
-PATCHFILES= tiff-3.5-interfaces.patch cvtDateTime.patch
-PATCH_DIST_STRIP= -p0
MAINTAINER= ports@FreeBSD.org
@@ -32,20 +26,29 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
--with-ZLIB=no --with-LIBZ=-lz --with-ZLIBINC=none \
--with-TIFFINC="${LOCALBASE}/include" \
+ --with-GCOPTS=" " --with-GCXXOPTS=" " \
--with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none
+.ifdef PACKAGE_BUILDING
+CONFIGURE_ARGS+=--nointeractive
+.endif
+MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER
+
HAS_CONFIGURE= yes
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
-MAN1= hylafax.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 sendfax.1 \
+MAN1= hylafax-client.1 faxalter.1 faxcover.1 faxmail.1 \
+ faxrm.1 faxstat.1 sendfax.1 \
sendpage.1 sgi2fax.1 textfmt.1
MAN5= pagesizes.5f typerules.5f hosts.hfaxd.5f xferfaxlog.5f \
- hylafax.5f cid.5f config.5f destctrls.5f dialrules.5f info.5f \
- log.5f pagermap.5f recvq.5f sendq.5f shutdown.5f status.5f tsi.5f
+ cid.5f doneq.5f hylafax-config.5f destctrls.5f dialrules.5f \
+ hylafax-info.5f hylafax-log.5f pagermap.5f recvq.5f sendq.5f \
+ hylafax-server.5f hylafax-shutdown.5f status.5f tsi.5f
MAN8= cqtest.8c choptest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
faxadduser.8c faxanswer.8c faxconfig.8c faxdeluser.8c faxmodem.8c \
faxstate.8c faxcron.8c faxgetty.8c faxinfo.8c faxq.8c faxqclean.8c \
faxquit.8c faxrcvd.8c faxsend.8c faxsetup.8c faxwatch.8c hfaxd.8c \
- mkcover.8c notify.8c pagesend.8c pollrcvd.8c ps2fax.8c recvstats.8c \
+ mkcover.8c notify.8c pagesend.8c pdf2fax.8c pollrcvd.8c ps2fax.8c \
+ recvstats.8c \
tagtest.8c tiff2fax.8c tiffcheck.8c tsitest.8c wedged.8c \
xferfaxstats.8c
@@ -55,12 +58,21 @@ SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
post-extract:
${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
+.if ${LOCALBASE} != "/usr/local"
+post-patch:
+ ${PERL} -pi -e 's^/usr/local^${LOCALBASE}^g' \
+ `find work/hylafax-4.1 -type f -print0 | \
+ xargs -0 fgrep -l --mmap /usr/local`
+.endif
+
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}
@if [ ! -f ${PREFIX}/etc/rc.d/hylafax.sh.sample ]; then \
- ${CP} ${FILESDIR}/hylafax.sh.sample ${PREFIX}/etc/rc.d; \
+ ${SED} 's^/usr/local^${PREFIX}^g' \
+ < ${FILESDIR}/hylafax.sh.sample \
+ > ${PREFIX}/etc/rc.d/hylafax.sh.sample; \
fi
- ${CAT} ${PKGMESSAGE}
+ @${SED} 's^/usr/local^${PREFIX}^g' < ${PKGMESSAGE}
.include <bsd.port.mk>