aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-10-17 23:43:08 +0800
committermi <mi@FreeBSD.org>2001-10-17 23:43:08 +0800
commit93a7c0389c79ba501dcc5d4b4adb84aef150b44b (patch)
treea07c9de5302860ed3c53eafe3aff5d59cb03e3f1 /comms/hylafax/Makefile
parent60a6a578fd47c90d1fe5eceeb1a5c5474ac2feff (diff)
downloadfreebsd-ports-gnome-93a7c0389c79ba501dcc5d4b4adb84aef150b44b.tar.gz
freebsd-ports-gnome-93a7c0389c79ba501dcc5d4b4adb84aef150b44b.tar.zst
freebsd-ports-gnome-93a7c0389c79ba501dcc5d4b4adb84aef150b44b.zip
Prepend the bsd.port.pre.mk to the conditional patching
/usr/local -> ${LOCALBASE}. The condition was, naturally ${LOCALBASE} != /usr/local, but the value of LOCALBASE is not necessarily known without bsd.port.pre.mk. Sorry for the breakage. Submitted by: Brian Dean, Dan Langille
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index ccc7b13ca281..70da04e2aaa2 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -58,13 +58,6 @@ SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
post-extract:
${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
-.if ${LOCALBASE} != "/usr/local"
-post-patch:
- ${PERL} -pi -e 's^/usr/local^${LOCALBASE}^g' \
- `find work/hylafax-4.1 -type f -print0 | \
- xargs -0 fgrep -l --mmap /usr/local`
-.endif
-
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}
@@ -75,4 +68,13 @@ post-install:
fi
@${SED} 's^/usr/local^${PREFIX}^g' < ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${LOCALBASE} != /usr/local
+post-patch:
+ ${PERL} -pi -e 's^/usr/local^${LOCALBASE}^g' \
+ `find work/hylafax-4.1 -type f -print0 | \
+ xargs -0 fgrep -l --mmap /usr/local`
+.endif
+
+.include <bsd.port.post.mk>