aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-08 03:09:19 +0800
committersteve <steve@FreeBSD.org>2000-07-08 03:09:19 +0800
commitbf3544c0631f0b62637c378c7fa1671d23cf7176 (patch)
tree8d076a3edd2990ae8e4551bcdbce39e986cec560 /comms/hylafax
parent03b2e586781b8f0082cb8acce5e4c5f4dec81cf9 (diff)
downloadfreebsd-ports-gnome-bf3544c0631f0b62637c378c7fa1671d23cf7176.tar.gz
freebsd-ports-gnome-bf3544c0631f0b62637c378c7fa1671d23cf7176.tar.zst
freebsd-ports-gnome-bf3544c0631f0b62637c378c7fa1671d23cf7176.zip
From the submitter:
Currently, the hylafax port has a few flaws -- it uses the libz and regex libraries that come with the software instead of the implementations available on FreeBSD and ignores the local CFLAGS settings. It also needlessly (it seems) requires gmake. PR: 19552 Submitted by: Mikhail Teterin <mi@aldan.algebra.com>
Diffstat (limited to 'comms/hylafax')
-rw-r--r--comms/hylafax/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index fcefae554424..f9e231fce46e 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -27,12 +27,13 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
DIST_SUBDIR= hylafax
-USE_GMAKE= yes
CONFIGURE_ARGS= --with-INSTALL="" \
- --with-MAKE=gmake --with-CC=/usr/bin/cc \
--with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
- --with-TIFFINC="${LOCALBASE}/include"
+ --with-ZLIB=no --with-LIBZ=-lz --with-ZLIBINC=none \
+ --with-TIFFINC="${LOCALBASE}/include" \
+ --with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none
HAS_CONFIGURE= yes
+CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
MAN1= hylafax.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 sendfax.1 \
sendpage.1 sgi2fax.1 textfmt.1
@@ -50,6 +51,9 @@ MAN8= cqtest.8c choptest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
+post-extract:
+ ${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
+
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}