aboutsummaryrefslogtreecommitdiffstats
path: root/comms/kremotecontrol/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-08-30 11:50:06 +0800
committerwill <will@FreeBSD.org>2000-08-30 11:50:06 +0800
commit38d02d9acf77ef9df18e45358b8817fdbd9025c1 (patch)
tree69c7bea06ea30de910ccca1150743cc4085a62f2 /comms/kremotecontrol/Makefile
parentd48002a5eba327be116a39d98284bc777b760595 (diff)
downloadfreebsd-ports-gnome-38d02d9acf77ef9df18e45358b8817fdbd9025c1.tar.gz
freebsd-ports-gnome-38d02d9acf77ef9df18e45358b8817fdbd9025c1.tar.zst
freebsd-ports-gnome-38d02d9acf77ef9df18e45358b8817fdbd9025c1.zip
Finish updating to KDE2 snapshot 20000829A. Re-add kdenetwork and kdeutils
dependencies to kde2, and add koffice to kde2, because it's part of the 2.0 release. Fix my bogon in forgetting to remove obsolete qt22 patches. The current state of the ports as far as building and installing is quite good, but I expect minor problems with PLISTs other than for the ones I've fixed here. I'm going to let bento figure it out. :-) Please, test these ports and report bugs to submit@bugs.kde.org, and send me problems with the ports themselves. I've found that KDE2 seems to have stabilized significantly since the last snapshot. And now, I am removing the last patch remaining in the KDE2 ports, except for the QT 2.2 snapshot.
Diffstat (limited to 'comms/kremotecontrol/Makefile')
-rw-r--r--comms/kremotecontrol/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index 473eb031817c..a0b3728b1547 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -6,27 +6,27 @@
#
PORTNAME= kdeutils
-PORTVERSION= 1.90
+PORTVERSION= 20000829A
CATEGORIES= misc kde
-MASTER_SITES= $(MASTER_SITE_KDE)
-MASTER_SITE_SUBDIR= unstable/distribution/tar/src
+MASTER_SITES= http://www.physics.purdue.edu/~will/
MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- kdecore.4:${PORTSDIR}/x11/kdelibs2
-
-BROKEN= "Does not compile/run properly"
+ kdecore.4:${PORTSDIR}/x11/kdelibs2 \
+ qt2.4:${PORTSDIR}/x11-toolkits/qt22
MOC?= ${X11BASE}/bin/moc2
USE_BZIP2= yes
-USE_QT2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}"
+CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -lqt2 -ljpeg -lstdc++ -lgcc" \
+ USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -lqt2 -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
.include <bsd.port.mk>