aboutsummaryrefslogtreecommitdiffstats
path: root/comms/kremotecontrol
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-04-09 08:51:55 +0800
committerarved <arved@FreeBSD.org>2003-04-09 08:51:55 +0800
commitfa354714ab3a39d3d2a8fcf9d42e4f3de896144e (patch)
tree0939726aae5be834ad4e6c933269c772b83839f7 /comms/kremotecontrol
parentab70e474033366c800f918014b543bcb5245c9c3 (diff)
downloadfreebsd-ports-gnome-fa354714ab3a39d3d2a8fcf9d42e4f3de896144e.tar.gz
freebsd-ports-gnome-fa354714ab3a39d3d2a8fcf9d42e4f3de896144e.tar.zst
freebsd-ports-gnome-fa354714ab3a39d3d2a8fcf9d42e4f3de896144e.zip
Fix build on CURRENT
Reported by: many Tested by: jeff@walters.name (Jeff Walters), seanc
Diffstat (limited to 'comms/kremotecontrol')
-rw-r--r--comms/kremotecontrol/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index 6667a23a3320..a2cdd777537f 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -23,6 +23,7 @@ KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
@@ -49,5 +50,12 @@ PLIST_APPEND+= plist.kfloppy
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.endif # defined(DO_NOT_COMPILE)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500107
+post-patch:
+ ${REINPLACE_CMD} -e 's,selectdevs,devstat_selectdevs,' ${WRKSRC}/configure
+.endif
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>