aboutsummaryrefslogtreecommitdiffstats
path: root/comms/ktrack/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-10 03:55:57 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-10 03:55:57 +0800
commitfe357b15571d74c511b8a5a78c2f340a8093233f (patch)
tree6a804619eb85f2ee5210f9674fb078afd35ac813 /comms/ktrack/Makefile
parentcbf57b28c0382e36ab433d8c92d85ae701358aab (diff)
downloadfreebsd-ports-gnome-fe357b15571d74c511b8a5a78c2f340a8093233f.tar.gz
freebsd-ports-gnome-fe357b15571d74c511b8a5a78c2f340a8093233f.tar.zst
freebsd-ports-gnome-fe357b15571d74c511b8a5a78c2f340a8093233f.zip
K-Track is an graphical satellite prediction Program that runs under KDE.
It's really accurate as it calculates using the NORAD SGP4/SDP4 Models. It Controls your Rig for doppler compensation / antenna pointing Written by lx2gt AT users.sourceforge.net WWW: http://ktrack.sourceforge.net/ - Diane Bruce, VA3DB db@db.net PR: ports/93781 Submitted by: Diane Bruce <db at db.net>
Diffstat (limited to 'comms/ktrack/Makefile')
-rw-r--r--comms/ktrack/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/comms/ktrack/Makefile b/comms/ktrack/Makefile
new file mode 100644
index 000000000000..f807e93418e0
--- /dev/null
+++ b/comms/ktrack/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: ktrack
+# Date created: 22 February 2006
+# Whom: Diane Bruce <db@db.net>
+#
+# $FreeBSD$
+
+PORTNAME= ktrack
+PORTVERSION= 0.3.0r1
+CATEGORIES= comms hamradio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ktrack
+DISTNAME= ${PORTNAME}-0.3.0-rc1
+
+MAINTAINER= db@db.net
+COMMENT= Amateur Radio satellite tracking and prediction
+
+RUN_DEPENDS= xplanet:${PORTSDIR}/astro/xplanet:install
+LIB_DEPENDS= hamlib:${PORTSDIR}/comms/hamlib \
+ jpeg:${PORTSDIR}/graphics/jpeg
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+USE_BZIP2= yes
+USE_KDEBASE_VER=3
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GETTEXT= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3+
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/HTML/en/ktrack
+ ${MKDIR} ${PREFIX}/share/doc/HTML/en/ktrack/common
+ ${INSTALL_MAN} ${WRKSRC}/doc/en/index.cache.bz2 ${PREFIX}/share/doc/HTML/en/ktrack/
+ ${INSTALL_MAN} ${WRKSRC}/doc/en/index.docbook ${PREFIX}/share/doc/HTML/en/ktrack/
+.endif
+
+.include <bsd.port.post.mk>