aboutsummaryrefslogtreecommitdiffstats
path: root/comms/libimobiledevice
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-10-31 11:59:57 +0800
committerdanfe <danfe@FreeBSD.org>2013-10-31 11:59:57 +0800
commitca73cc80db36e4d4940a23cb5a16c9b8cb3bdb6b (patch)
tree1fad8f98815cc64efc57dc097169e313e8804a4c /comms/libimobiledevice
parent37a183f1b74a54540aaf2b8d3db004ec47913865 (diff)
downloadfreebsd-ports-gnome-ca73cc80db36e4d4940a23cb5a16c9b8cb3bdb6b.tar.gz
freebsd-ports-gnome-ca73cc80db36e4d4940a23cb5a16c9b8cb3bdb6b.tar.zst
freebsd-ports-gnome-ca73cc80db36e4d4940a23cb5a16c9b8cb3bdb6b.zip
None of the binaries installed by comms/libimobiledevice are actually linked
to gnutls/gcrypt/tasn1, while they are explicitly listed in the LIB_DEPENDS, remove them. Judging from configure script, GnuTLS is used only when OpenSSL is explicitly disabled with --disable-openssl; Gentoo ebuild agrees. OpenSSL is preferred, and is our standard SSL provider. If GnuTLS is required for some special feature of libimobiledevice, it can be introduced as an OPTION. While here: stagify the port, use modern LIB_DEPENDS syntax. Approved by: maintainer (avilla; timeout since May 16th)
Diffstat (limited to 'comms/libimobiledevice')
-rw-r--r--comms/libimobiledevice/Makefile22
-rw-r--r--comms/libimobiledevice/pkg-plist13
2 files changed, 18 insertions, 17 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 638f5895bb8b..17575e2a2484 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -22,11 +22,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
.if ${SLAVE_PORT} == "no"
-LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
- tasn1:${PORTSDIR}/security/libtasn1 \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- plist:${PORTSDIR}/devel/libplist \
- usbmuxd:${PORTSDIR}/comms/usbmuxd
+LIB_DEPENDS= libplist.so:${PORTSDIR}/devel/libplist \
+ libusbmuxd.so:${PORTSDIR}/comms/usbmuxd
USE_GNOME= glib20
CONFIGURE_ARGS+=--without-cython
@@ -35,14 +32,7 @@ USE_LDCONFIG= yes
PORTDOCS= AUTHORS NEWS README
-MAN1= idevice_id.1 idevicebackup.1 idevicebackup2.1 idevicedate.1 \
- idevicedebugserverproxy.1 idevicediagnostics.1 \
- ideviceenterrecovery.1 ideviceimagemounter.1 ideviceinfo.1 \
- idevicepair.1 ideviceprovision.1 idevicescreenshot.1 \
- idevicesyslog.1
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's, *@ssl_requires@,,' \
@@ -51,10 +41,8 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif # ${SLAVE_PORT} == "no"
diff --git a/comms/libimobiledevice/pkg-plist b/comms/libimobiledevice/pkg-plist
index 054c58bb8eb2..0c9abd23fad5 100644
--- a/comms/libimobiledevice/pkg-plist
+++ b/comms/libimobiledevice/pkg-plist
@@ -34,4 +34,17 @@ lib/libimobiledevice.la
lib/libimobiledevice.so
lib/libimobiledevice.so.4
libdata/pkgconfig/libimobiledevice-1.0.pc
+man/man1/idevice_id.1.gz
+man/man1/idevicebackup.1.gz
+man/man1/idevicebackup2.1.gz
+man/man1/idevicedate.1.gz
+man/man1/idevicedebugserverproxy.1.gz
+man/man1/idevicediagnostics.1.gz
+man/man1/ideviceenterrecovery.1.gz
+man/man1/ideviceimagemounter.1.gz
+man/man1/ideviceinfo.1.gz
+man/man1/idevicepair.1.gz
+man/man1/ideviceprovision.1.gz
+man/man1/idevicescreenshot.1.gz
+man/man1/idevicesyslog.1.gz
@dirrm include/libimobiledevice