aboutsummaryrefslogtreecommitdiffstats
path: root/comms/linpsk
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /comms/linpsk
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'comms/linpsk')
-rw-r--r--comms/linpsk/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/comms/linpsk/Makefile b/comms/linpsk/Makefile
index 5379e14d63a5..709b7bb624e0 100644
--- a/comms/linpsk/Makefile
+++ b/comms/linpsk/Makefile
@@ -9,15 +9,14 @@ PORTNAME= linpsk
PORTVERSION= 0.8.1
PORTREVISION= 4
CATEGORIES= comms hamradio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= xride@FreeBSD.org
COMMENT= A qt psk31 client
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
portaudio:${PORTSDIR}/audio/portaudio
-RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/bitstream-vera/fonts.dir:${PORTSDIR}/x11-fonts/bitstream-vera
+RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/fonts.dir:${PORTSDIR}/x11-fonts/bitstream-vera
USE_PERL5_BUILD=yes
USE_QT_VER= 3
@@ -27,14 +26,14 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-qtdir=${X11BASE} --prefix=${PREFIX}
+CONFIGURE_ARGS= --with-qtdir=${LOCALBASE} --prefix=${PREFIX}
SUB_FILES= pkg-message
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-I$$(top_srcdir)/src/portaudio||' \
${WRKSRC}/src/Makefile.in \
${WRKSRC}/src/interfaces/Makefile.in