aboutsummaryrefslogtreecommitdiffstats
path: root/comms/minicom
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2005-11-27 23:07:30 +0800
committeranders <anders@FreeBSD.org>2005-11-27 23:07:30 +0800
commit37189186e4c54b0a5a79a71758e491100f1c11f6 (patch)
tree8a62c3e0b5826e65e15c1c350a565b37a50ce58d /comms/minicom
parent06584d1895d63b9b8e9579314cefad6f1f2ead46 (diff)
downloadfreebsd-ports-gnome-37189186e4c54b0a5a79a71758e491100f1c11f6.tar.gz
freebsd-ports-gnome-37189186e4c54b0a5a79a71758e491100f1c11f6.tar.zst
freebsd-ports-gnome-37189186e4c54b0a5a79a71758e491100f1c11f6.zip
Make /dev/cuad0 the default serial port in FreeBSD 6 and newer.
Drop the script to choose serial port and make the link from /dev/modem (I assume people do not need or want it anymore), set the port directly instead (and let people override with a make switch if they want). Users can change the default port in the configuration anyway. PR: ports/82241
Diffstat (limited to 'comms/minicom')
-rw-r--r--comms/minicom/Makefile18
-rw-r--r--comms/minicom/scripts/create-dev-link58
2 files changed, 8 insertions, 68 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 7c6785d1af4f..d17a1e8aa37a 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -33,11 +33,15 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock
-.if defined(BATCH)
-CONFIGURE_ARGS+= --enable-dfl-port=/dev/cuaa0
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+MINICOM_DEFAULT_PORT?= /dev/cuad0
.else
-CONFIGURE_ARGS+= --enable-dfl-port=/dev/modem
+MINICOM_DEFAULT_PORT?= /dev/cuaa0
.endif
+CONFIGURE_ARGS+= --enable-dfl-port=${MINICOM_DEFAULT_PORT}
MAN1= minicom.1 runscript.1 ascii-xfr.1 xminicom.1
@@ -48,12 +52,6 @@ post-patch:
${REINPLACE_CMD} -E -e "s@^(SUBDIRS = .*) intl@\1@" \
${WRKSRC}/Makefile.in
-pre-configure:
-.if !defined(BATCH)
- # this script creates a link from your comm port to /dev/modem
- ${SH} ${SCRIPTDIR}/create-dev-link
-.endif
-
post-install:
${CHOWN} uucp:dialer ${PREFIX}/bin/minicom
${CHMOD} 4511 ${PREFIX}/bin/minicom
@@ -72,4 +70,4 @@ post-install:
${DOCSDIR})
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/minicom/scripts/create-dev-link b/comms/minicom/scripts/create-dev-link
deleted file mode 100644
index 6c1d44d467ab..000000000000
--- a/comms/minicom/scripts/create-dev-link
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/sh -
-#
-# pre-install script for Minicom port to FreeBSD 2.x
-
-echo ""
-echo "Minicom will be installed mode 4511 (setuid) owner uucp, and group dialer."
-echo ""
-echo -n "Is this ok? [y] "
- read fooz
- if [ ! ${fooz} ] ; then
- fooz=Y
- fi
- if [ ${fooz} = Y -o ${fooz} = y -o ${fooz} = yes ] ; then
- # ok to continue
- else
- echo ""
- exit 1
- fi
-
-
-echo ""
-echo "Minicom needs to know what device your modem is hanging off of."
-echo "I (the porter) have adopted Satoshi Asami's lead of using /dev/modem."
-echo ""
-echo -n "Lets see if you have too..."
-
-# might want to test for ``-h'' rather than ``-e''
-if [ -e /dev/modem ]; then
- echo " Good you have:"
- /bin/ls -l /dev/modem
-else
- echo "Nope, you haven't (yet)."
- echo "The patches to Minicom hardcode /dev/modem."
- echo -n "Would you like me to make this link for you? [Y] "
- read foo
- if [ ! ${foo} ] ; then
- foo=Y
- fi
- if [ ${foo} = Y -o ${foo} = y -o ${foo} = yes ] ; then
- echo "From the list below, what port number is your modem attached to?"
- cd /dev
- /bin/ls -C cuaa*
- echo ""
- echo -n "Enter the number X from cuaaX above : "
- read bar
- if [ ${bar} ] ; then
- if [ -e /dev/cuaa${bar} ]; then
- ln -s /dev/cuaa${bar} /dev/modem
- else
- echo "Error: /dev/cuaa${bar} doesn't exist."
- exit 1
- fi
- fi
- fi
-fi
-
-echo ""
-exit 0