aboutsummaryrefslogtreecommitdiffstats
path: root/comms/minicom
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2011-08-18 05:04:58 +0800
committerjohans <johans@FreeBSD.org>2011-08-18 05:04:58 +0800
commit849a182806b537606a071e9dab66b92bb3e74c8b (patch)
treed9d0aedcbad34b216abe5fe6a66056f688913fc2 /comms/minicom
parenta8e064667744feb31f3e764fc497eefdc84063c8 (diff)
downloadfreebsd-ports-gnome-849a182806b537606a071e9dab66b92bb3e74c8b.tar.gz
freebsd-ports-gnome-849a182806b537606a071e9dab66b92bb3e74c8b.tar.zst
freebsd-ports-gnome-849a182806b537606a071e9dab66b92bb3e74c8b.zip
Fix minicom build for WITHOUT_NLS (force libiconv dependency and linking)
Reported by: Gordon Shumway PR: ports/159739
Diffstat (limited to 'comms/minicom')
-rw-r--r--comms/minicom/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 6deff9a547ef..4f4f3000e3c0 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -16,22 +16,25 @@ COMMENT= An MS-DOS Telix serial communication program "workalike"
RUN_DEPENDS= lrz:${PORTSDIR}/comms/lrzsz
+USE_ICONV= yes
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock \
--enable-dfl-port=${MINICOM_DEFAULT_PORT} \
- CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+MAKE_ARGS+= LIBS+="-liconv -lcurses"
MAN1= minicom.1 runscript.1 ascii-xfr.1 xminicom.1