aboutsummaryrefslogtreecommitdiffstats
path: root/comms/minicom
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2007-07-02 17:34:37 +0800
committerkevlo <kevlo@FreeBSD.org>2007-07-02 17:34:37 +0800
commitff37a3341236cc7a8b971398d79bfbabc214eb6b (patch)
tree7cc466779f432c10d30dba2c9b496a382ada2850 /comms/minicom
parenteaf67f48134ef874b70c24ca874608b8bb41d6cc (diff)
downloadfreebsd-ports-gnome-ff37a3341236cc7a8b971398d79bfbabc214eb6b.tar.gz
freebsd-ports-gnome-ff37a3341236cc7a8b971398d79bfbabc214eb6b.tar.zst
freebsd-ports-gnome-ff37a3341236cc7a8b971398d79bfbabc214eb6b.zip
Fix build with gcc4.
Approved by: anders (maintainer)
Diffstat (limited to 'comms/minicom')
-rw-r--r--comms/minicom/files/patch-af46
1 files changed, 44 insertions, 2 deletions
diff --git a/comms/minicom/files/patch-af b/comms/minicom/files/patch-af
index 387e345e911a..785aa386f70a 100644
--- a/comms/minicom/files/patch-af
+++ b/comms/minicom/files/patch-af
@@ -1,5 +1,14 @@
---- src/window.c.orig Sun Jan 27 18:57:13 2002
-+++ src/window.c Sun Jan 27 18:57:25 2002
+--- src/window.c.orig 2003-05-17 04:06:26.000000000 +0800
++++ src/window.c 2007-06-22 11:33:39.000000000 +0800
+@@ -62,7 +62,7 @@
+ static char *CS, *SF, *SR, *VB, *BL;
+ static char *VE, *VI, *KS, *KE;
+ static char *CD, *CL, *IC, *DC;
+-static char *BC, *CR, *NL;
++static char *mcBC, *CR, *NL;
+ #if ST_LINE
+ static char *TS, *FS, *DS;
+ #endif
@@ -110,7 +110,7 @@
int useattr = 1;
@@ -9,3 +18,36 @@
int usecolor = 0;
WIN *stdwin;
char *_tptr = CNULL;
+@@ -322,8 +322,8 @@
+ else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
+ outstr(NL);
+ #endif
+- else if (BC != CNULL && y == cury && x == curx - 1)
+- outstr(BC);
++ else if (mcBC != CNULL && y == cury && x == curx - 1)
++ outstr(mcBC);
+ else
+ outstr(tgoto(CM, x, y));
+ curx = x;
+@@ -1918,7 +1918,7 @@
+ CL = tgetstr("cl", &_tptr);
+ IC = tgetstr("ic", &_tptr);
+ DC = tgetstr("dc", &_tptr);
+- BC = tgetstr("bc", &_tptr);
++ mcBC = tgetstr("bc", &_tptr);
+ CR = tgetstr("cr", &_tptr);
+ NL = tgetstr("nl", &_tptr);
+ AC = tgetstr("ac", &_tptr);
+@@ -1967,10 +1967,10 @@
+ _has_am = tgetflag("am");
+ _mv_standout = tgetflag("ms");
+ if (tgetflag("bs")) {
+- if (BC == CNULL) BC = "\b";
++ if (mcBC == CNULL) mcBC = "\b";
+ }
+ else
+- BC = CNULL;
++ mcBC = CNULL;
+
+ /* Special IBM box-drawing characters */
+ D_UL = 201;
+2 * Upgrade to version 2.1.0.olgeni2003-10-093-91/+98 * Use USE_GNOME to fix the build on bento.marcus2003-09-211-4/+1 * Upgrade to version 2.0.1.olgeni2003-07-252-2/+2 * Update to version 2.0.0.olgeni2003-06-032-2/+2 * Update to version 1.3.10.olgeni2003-06-012-2/+2 * Add default CHARSET fallback (iso-8859-1).olgeni2003-05-201-0/+5 * Update to version 1.3.9. Add support for updating the shared mimeolgeni2003-05-183-2/+11 * Do not call autoconf in post-patch target.olgeni2003-05-141-5/+1 * Install the rox binary mode 755, not 775kris2003-04-211-1/+1 * Update to version 1.3.8.olgeni2003-03-302-2/+2 * Trim whitespace at end of file.olgeni2003-03-301-2/+0 * Add message about non-UTF-8 filenames and fallback CHARSET encoding.olgeni2003-03-301-0/+11 * Fix WWW using specific project page.olgeni2003-03-241-1/+1 * Update to version 1.3.7.olgeni2003-03-235-42/+48 * De-pkg-comment my ports + some more.olgeni2003-02-232-1/+1 * Chase gtk20's shared lib version.marcus2003-02-081-1/+2 * Upgrade to version 1.3.6.olgeni2003-01-122-2/+2 * (whitespace) Separate assignments from Makefile targets.olgeni2003-01-021-4/+4 * Update to 1.3.5.olgeni2003-01-025-17/+64 * Add support for ARCH != i386.olgeni2003-01-022-4/+14 * Update to version 1.3.4.olgeni2002-10-113-6/+4 * Update port to version 1.3.3.olgeni2002-07-293-16/+5 * Update to version 1.3.2.olgeni2002-06-232-2/+2 * Update port to version 1.3.1 (uses shared-mime-info rather than rox-base).olgeni2002-05-313-13/+73 * Update port to version 1.3.0 (which requires gtk2).olgeni2002-05-243-29/+31 * Update port to version 1.2.0.olgeni2002-02-182-2/+2 * Update port to version 1.1.14.olgeni2002-02-162-2/+2 * Update port to version 1.1.12.olgeni2002-01-273-4/+8 * Add missing dependency on textproc/libxml (from bento error logs).olgeni2001-10-281-1/+2 * Update port to version 1.1.7, and sort PLIST.olgeni2001-10-073-8/+9 * Do not depend on the whole Gnome: this port only uses gtk and gdk-pixbuf.olgeni2001-09-231-1/+2 * Add missing file (de.gmo).olgeni2001-09-231-0/+1 * Update port to version 1.1.6.olgeni2001-07-132-2/+2 * Update port to version 1.1.5.olgeni2001-06-103-6/+9 * Update port to version 1.1.3.olgeni2001-05-272-3/+2 * Various patches (mainly shared library revision changes) for thoseade2001-05-051-5/+3 * Update port to version 1.1.2olgeni2001-04-013-3/+4 * Fix pkg-plist.olgeni2001-03-291-1/+1 * Add missing gdk-pixbuf dependency.olgeni2001-03-191-1/+2 * Add missed libxml dependency.sobomax2001-03-141-0/+1 * Update port to version 1.1.1.olgeni2001-03-122-12/+3 * Port bugfix: the "files/rox" script did not pass command line arguments toolgeni2001-03-081-1/+1 * Use proper capitalization (freebsd.org -> FreeBSD.org)olgeni2001-01-241-1/+1 * Change maintainer email address (olgeni@uli.it -> olgeni@freebsd.org)olgeni2001-01-241-1/+1 * Update to version 1.0.0kevlo2000-12-273-16/+16 * Remove trailing period and package name from the pkg-comment.demon2000-12-191-1/+1