aboutsummaryrefslogtreecommitdiffstats
path: root/comms/mwavem
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-21 17:39:10 +0800
committeredwin <edwin@FreeBSD.org>2002-11-21 17:39:10 +0800
commitc0dcfcc86204fda0556a510f0ce57678e4a5672a (patch)
tree15b01ec2305e2cd9c29788796f75c6c2b515be0e /comms/mwavem
parentb28c3f2813d0bcd26ea738ade24e5493a9bb3d76 (diff)
downloadfreebsd-ports-gnome-c0dcfcc86204fda0556a510f0ce57678e4a5672a.tar.gz
freebsd-ports-gnome-c0dcfcc86204fda0556a510f0ce57678e4a5672a.tar.zst
freebsd-ports-gnome-c0dcfcc86204fda0556a510f0ce57678e4a5672a.zip
liblthread.so.3 is used with GCC3
liblthread.so.2 is used with GCC2 Noticed on: bento
Diffstat (limited to 'comms/mwavem')
-rw-r--r--comms/mwavem/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/comms/mwavem/Makefile b/comms/mwavem/Makefile
index 16867d816abb..3df75588168e 100644
--- a/comms/mwavem/Makefile
+++ b/comms/mwavem/Makefile
@@ -15,8 +15,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= oberman@es.net
-LIB_DEPENDS= lthread.2:${PORTSDIR}/devel/linuxthreads
-
ONLY_FOR_ARCHS= i386
GNU_CONFIGURE= yes
@@ -26,6 +24,21 @@ SLEEP= /bin/sleep
.include <bsd.port.pre.mk>
+LTHREADVERSION=2
+.if ${OSVERSION} >= 500035
+LTHREADVERSION= 3
+.endif
+.if ${CC:Mgcc30}!=""
+LTHREADVERSION= 3
+.endif
+.if ${CC:Mgcc31}!=""
+LTHREADVERSION= 3
+.endif
+.if ${CC:Mgcc32}!=""
+LTHREADVERSION= 3
+.endif
+LIB_DEPENDS= lthread.${LTHREADVERSION}:${PORTSDIR}/devel/linuxthreads
+
pre-build:
${PERL} -pi.orig -e "s@ /modules@ ${PREFIX}/share/mwavem@g" ${WRKSRC}/src/drivers/Makefile
${PERL} -pi.orig -e "s@#include <malloc.h>\n@@g" \