aboutsummaryrefslogtreecommitdiffstats
path: root/comms/obexapp/Makefile
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2007-05-25 18:50:47 +0800
committermm <mm@FreeBSD.org>2007-05-25 18:50:47 +0800
commit38887e87062ab01eca4586dcf8711f050b30a3f7 (patch)
tree69528ee3288ab662a9140c7b273f322a9985aadd /comms/obexapp/Makefile
parent933a4f446218bbdb4fbd1fc2d785a8695258f20c (diff)
downloadfreebsd-ports-gnome-38887e87062ab01eca4586dcf8711f050b30a3f7.tar.gz
freebsd-ports-gnome-38887e87062ab01eca4586dcf8711f050b30a3f7.tar.zst
freebsd-ports-gnome-38887e87062ab01eca4586dcf8711f050b30a3f7.zip
- counterpatch proposed by mm@ (maintainer approved)
- fixed build on i386 if devel/readline installed - fixed build on FreeBSD 5.5 - added NO_INSTALL_MANPAGES knob PR: ports/112321 Approved by: garga (mentor)
Diffstat (limited to 'comms/obexapp/Makefile')
-rw-r--r--comms/obexapp/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/comms/obexapp/Makefile b/comms/obexapp/Makefile
index 3df1ebfd7448..06de7533401a 100644
--- a/comms/obexapp/Makefile
+++ b/comms/obexapp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= obexapp
PORTVERSION= 1.4.6
+PORTREVISION= 1
CATEGORIES= comms net
MASTER_SITES= http://www.geocities.com/m_evmenkin/
@@ -18,14 +19,21 @@ LIB_DEPENDS= openobex:${PORTSDIR}/comms/openobex
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ICONV= yes
+PLIST_FILES= bin/obexapp
+
+.if !defined(NO_INSTALL_MANPAGES)
MAN1= obexapp.1
MANCOMPRESSED= yes
-PLIST_FILES= bin/obexapp
+.else
+MAKE_ENV+= NO_MAN=yes
+.endif
+
+MAKE_ENV+= NO_WERROR=yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502101
-IGNORE= Needs 5.x from 20 Jan 2004 or later (sdpd)
+IGNORE= needs 5.x from 20 Jan 2004 or later (sdpd)
.endif
.if ${OSVERSION} < 502121
@@ -33,8 +41,4 @@ IGNORE= Needs 5.x from 20 Jan 2004 or later (sdpd)
ONLY_FOR_ARCHS= i386
.endif
-post-patch:
- @${FIND} ${WRKSRC} -name \*.c | ${XARGS} \
- ${REINPLACE_CMD} -e 's|<sdp.h>|</usr/include/sdp.h>|'
-
.include <bsd.port.post.mk>