aboutsummaryrefslogtreecommitdiffstats
path: root/comms/p5-SMS-Send-NexmoUnicode/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-12-01 17:39:49 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-12-01 17:39:49 +0800
commitddbe91f300de0ef0bf54334a63a6f54129d19cc6 (patch)
treef1833ac78f5d3c8a93cf8d14628c8b48bc0f0e56 /comms/p5-SMS-Send-NexmoUnicode/Makefile
parent82c62c1eab744e30abd8a5f78ccc47905ddea12d (diff)
downloadfreebsd-ports-gnome-ddbe91f300de0ef0bf54334a63a6f54129d19cc6.tar.gz
freebsd-ports-gnome-ddbe91f300de0ef0bf54334a63a6f54129d19cc6.tar.zst
freebsd-ports-gnome-ddbe91f300de0ef0bf54334a63a6f54129d19cc6.zip
- Add p5-SMS-Send-NexmoUnicode 0.01
SMS::Send::NexmoUnicode is a SMS::Send driver which allows you to send messages through www.nexmo.com WWW: http://search.cpan.org/dist/SMS-Send-NexmoUnicode/ PR: ports/162980 Submitted by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw> Feature safe: yes
Diffstat (limited to 'comms/p5-SMS-Send-NexmoUnicode/Makefile')
-rw-r--r--comms/p5-SMS-Send-NexmoUnicode/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/comms/p5-SMS-Send-NexmoUnicode/Makefile b/comms/p5-SMS-Send-NexmoUnicode/Makefile
new file mode 100644
index 000000000000..917418f35623
--- /dev/null
+++ b/comms/p5-SMS-Send-NexmoUnicode/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-SMS-Send-NexmoUnicode
+# Date created: 2011-12-01
+# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SMS-Send-NexmoUnicode
+PORTVERSION= 0.01
+CATEGORIES= comms perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:JNLIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jnlin@csie.nctu.edu.tw
+COMMENT= SMS::Send driver for www.nexmo.com (Unicode)
+
+BUILD_DEPENDS= p5-Nexmo-SMS>=0.04:${PORTSDIR}/comms/p5-Nexmo-SMS \
+ p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SMS::Send::NexmoUnicode.3
+
+.include <bsd.port.mk>