aboutsummaryrefslogtreecommitdiffstats
path: root/comms/py-libimobiledevice
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2013-05-07 08:35:40 +0800
committeravilla <avilla@FreeBSD.org>2013-05-07 08:35:40 +0800
commit72dc6dc291ba1d2555b8d287800611f790fa6cf3 (patch)
tree9ebfe1585debeacef8ee21fbe5923a2b5e906d7c /comms/py-libimobiledevice
parentc440e4ebf341b68dbf133f0e8239aa253ccc15eb (diff)
downloadfreebsd-ports-gnome-72dc6dc291ba1d2555b8d287800611f790fa6cf3.tar.gz
freebsd-ports-gnome-72dc6dc291ba1d2555b8d287800611f790fa6cf3.tar.zst
freebsd-ports-gnome-72dc6dc291ba1d2555b8d287800611f790fa6cf3.zip
- Update libimobiledevice to 1.1.5.
- Add a port with its Python bindings. The update brings important improvements: * backup/restore support on iOS 4+; * OpenSSL support; * compatibility with iOS 6+.
Diffstat (limited to 'comms/py-libimobiledevice')
-rw-r--r--comms/py-libimobiledevice/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/comms/py-libimobiledevice/Makefile b/comms/py-libimobiledevice/Makefile
new file mode 100644
index 000000000000..f8e5ae42a91e
--- /dev/null
+++ b/comms/py-libimobiledevice/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= comms python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Python bindings for libimobiledevice
+
+LIB_DEPENDS= imobiledevice:${PORTSDIR}/${MASTER_PORT}
+BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython \
+ ${PYTHON_SITELIBDIR}/plist.so:${PORTSDIR}/devel/py-libplist
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/plist.so:${PORTSDIR}/devel/py-libplist
+
+USE_PYTHON= yes
+SLAVE_PORT= yes
+MASTERDIR= ${.CURDIR:H:H}/comms/libimobiledevice
+
+PLIST= ${.CURDIR}/pkg-plist
+BUILD_WRKSRC= ${WRKSRC}/cython
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+PLIST_FILES= ${PYTHON_SITELIBDIR}/imobiledevice.a \
+ ${PYTHON_SITELIBDIR}/imobiledevice.la \
+ ${PYTHON_SITELIBDIR}/imobiledevice.so
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,../src/libimobiledevice.la,${LOCALBASE}/lib/libimobiledevice.la,' \
+ ${BUILD_WRKSRC}/Makefile.in
+
+.include "${MASTERDIR}/Makefile"