aboutsummaryrefslogtreecommitdiffstats
path: root/comms/pyla/Makefile
diff options
context:
space:
mode:
authormr <mr@FreeBSD.org>2005-02-09 18:57:39 +0800
committermr <mr@FreeBSD.org>2005-02-09 18:57:39 +0800
commit332e14dc82e77e9e697a5392f6e70e70e9140548 (patch)
tree71d98e2a19453bcfd038fbb43abac80592c72deb /comms/pyla/Makefile
parent139952a0c618d4c8905951b18fb54ca178477892 (diff)
downloadfreebsd-ports-gnome-332e14dc82e77e9e697a5392f6e70e70e9140548.tar.gz
freebsd-ports-gnome-332e14dc82e77e9e697a5392f6e70e70e9140548.tar.zst
freebsd-ports-gnome-332e14dc82e77e9e697a5392f6e70e70e9140548.zip
Add the pyla Hylafax client 1.1.4 for sending receiving
and managing faxes via hfaxd. For more information see: http://www.teamsw.it/pyla/
Diffstat (limited to 'comms/pyla/Makefile')
-rw-r--r--comms/pyla/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/comms/pyla/Makefile b/comms/pyla/Makefile
new file mode 100644
index 000000000000..59fd8d1db29b
--- /dev/null
+++ b/comms/pyla/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: pylafax
+# Date created: 6 January 2005
+# Whom: Michael Reifenberger (mike@Reifenberger.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyla
+PORTVERSION= 1.1.4
+CATEGORIES= comms python
+MASTER_SITES= http://www.teamsw.it/pyla/download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyla${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mike@Reifenberger.com
+COMMENT= Hylafax client written in Python
+
+#LIB_DEPENDS= lirc_client.0:${PORTSDIR}/comms/lirc
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+DATADIR= ${PREFIX}/lib/pyla
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ @(cd ${FILESDIR} && ${CP} pyla.sh ${WRKDIR})
+ @(cd ${WRKDIR} && ${REINPLACE_CMD} \
+ -e "s|%%PREFIX%%|${PREFIX}|g;" \
+ -e "s|%%PYTHON_CMD%%|${PYTHON_CMD}|g;" \
+ pyla.sh)
+ @(cd ${WRKSRC} && ${CP} language.en language.db)
+
+pre-install:
+ @${ECHO_CMD} '@exec ${MKDIR} %D/lib/pyla' > ${PLIST}
+ @${ECHO_CMD} 'bin/pyla' >> ${PLIST}
+ @${FIND} ${WRKSRC}/ -type f | \
+ ${SED} -e "s:^${WRKSRC}/:lib/pyla/:g" >> ${PLIST}
+ @${FIND} -d ${WRKSRC} -type d | \
+ ${SED} -e "s:^${WRKSRC}:@dirrm lib/pyla:g" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL} -m755 ${WRKDIR}/pyla.sh ${PREFIX}/bin/pyla
+ ${TAR} -C ${WRKSRC} --exclude CVS -cf - . | \
+ ${TAR} -C ${DATADIR} --unlink -xf -
+
+.include <bsd.port.post.mk>