aboutsummaryrefslogtreecommitdiffstats
path: root/comms/quisk
diff options
context:
space:
mode:
authorshurd <shurd@FreeBSD.org>2014-11-07 19:54:30 +0800
committershurd <shurd@FreeBSD.org>2014-11-07 19:54:30 +0800
commitdff6024b58812f90e2802e7c5763acaab0829c35 (patch)
treee8d14eed4a0e258887eb0794f32c233b3c66208c /comms/quisk
parentca70d91524a2bec25bd6fb4431f76372211123c7 (diff)
downloadfreebsd-ports-gnome-dff6024b58812f90e2802e7c5763acaab0829c35.tar.gz
freebsd-ports-gnome-dff6024b58812f90e2802e7c5763acaab0829c35.tar.zst
freebsd-ports-gnome-dff6024b58812f90e2802e7c5763acaab0829c35.zip
Update to 3.6.19.
From the changelog: I added device names to PulseAudio. The PulseAudio name "pulse" still refers to the default device. Otherwise, enter a PulseAudio name such as "pulse:alsa_input.pci-0000_00_1b.0.analog-stereo". PulseAudio support enables you to connect to recent versions of wsjt-x. To turn this off, set show_pulse_audio_devices = False in your config file. Submitted by: shurd
Diffstat (limited to 'comms/quisk')
-rw-r--r--comms/quisk/Makefile3
-rw-r--r--comms/quisk/distinfo4
-rw-r--r--comms/quisk/files/patch-quisk.c11
3 files changed, 3 insertions, 15 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index d3915da0cfcf..7f9f15554460 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= quisk
-PORTVERSION= 3.6.18
-PORTREVISION= 3
+PORTVERSION= 3.6.19
CATEGORIES= comms hamradio
MASTER_SITES= http://james.ahlstrom.name/quisk/ \
${MASTER_SITE_LOCAL}
diff --git a/comms/quisk/distinfo b/comms/quisk/distinfo
index 312d3253d350..102c35c11748 100644
--- a/comms/quisk/distinfo
+++ b/comms/quisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (quisk-3.6.18.tar.gz) = 851e13193ed43ea992345f438b34ae968e0ed5e44c6635a6e4503459932cdce8
-SIZE (quisk-3.6.18.tar.gz) = 1106206
+SHA256 (quisk-3.6.19.tar.gz) = 4472d2447f5d2c87a422bf7da647ebecd7e27252f2e77c247fead0aeb8342a17
+SIZE (quisk-3.6.19.tar.gz) = 1138544
diff --git a/comms/quisk/files/patch-quisk.c b/comms/quisk/files/patch-quisk.c
deleted file mode 100644
index 25344a07f5d7..000000000000
--- a/comms/quisk/files/patch-quisk.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- quisk.c.orig 2014-06-28 19:10:12.000000000 -0700
-+++ quisk.c 2014-06-28 19:10:48.000000000 -0700
-@@ -1156,7 +1156,7 @@
- if (filter_bandwidth < 19000) { // No filtering for wide bandwidth
- for (i = 0; i < nSamples; i++)
- cSamples[i] = dRxFilterOut(cSamples[i], bank);
-- measure_audio_sum += cSamples[i] * conj(cSamples[i]);
-+ measure_audio_sum = measure_audio_sum + cSamples[i] * conj(cSamples[i]);
- measure_audio_count += 1;
- }
- break;