aboutsummaryrefslogtreecommitdiffstats
path: root/comms/rxtx
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-10-30 19:36:44 +0800
committerlinimon <linimon@FreeBSD.org>2018-10-30 19:36:44 +0800
commitf2ec12c33219b96b88363969dd05e4cba0d168ba (patch)
tree655818a9103233c641b2f80e84c0890030d050a2 /comms/rxtx
parent3ee447da7e3b8191035c0dbcec3eb0d6cb2edc8a (diff)
downloadfreebsd-ports-gnome-f2ec12c33219b96b88363969dd05e4cba0d168ba.tar.gz
freebsd-ports-gnome-f2ec12c33219b96b88363969dd05e4cba0d168ba.tar.zst
freebsd-ports-gnome-f2ec12c33219b96b88363969dd05e4cba0d168ba.zip
Fix build on powerpc64, and, possibly, armvX.
PR: 231600 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'comms/rxtx')
-rw-r--r--comms/rxtx/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/comms/rxtx/Makefile b/comms/rxtx/Makefile
index 2f4fae7a5390..754fe2da697b 100644
--- a/comms/rxtx/Makefile
+++ b/comms/rxtx/Makefile
@@ -15,9 +15,6 @@ COMMENT= Native interface to serial ports in Java
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_armv6= fails to link: librxtxParallel.so: No such file or directory
-BROKEN_armv7= fails to link: librxtxParallel.so: No such file or directory
-BROKEN_powerpc64= fails to link: librxtxParallel.so: No such file or directory
NOT_FOR_ARCHS= mips mips64
NOT_FOR_ARCHS_REASON= Java not available for this architecture
@@ -32,6 +29,14 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-PLIST_SUB= ARCH=${ARCH} JAVA_HOME=${JAVA_HOME:S,^${PREFIX}/,,}
+PLIST_SUB= JAVA_HOME=${JAVA_HOME:S,^${PREFIX}/,,}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc64"
+PLIST_SUB+= ARCH=ppc64
+.else
+PLIST_SUB+= ARCH=${ARCH}
+.endif
+
+.include <bsd.port.post.mk>