aboutsummaryrefslogtreecommitdiffstats
path: root/comms/smstools/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-25 20:54:10 +0800
committerpav <pav@FreeBSD.org>2006-04-25 20:54:10 +0800
commitc257cdcac065a53ad02724bd137321202ab5a483 (patch)
tree8aad6cf4b92388c294c13ec9799091d5b80cd120 /comms/smstools/Makefile
parent2d7a36096fc222ca077a376bbf419bbbfa5feb90 (diff)
downloadfreebsd-ports-gnome-c257cdcac065a53ad02724bd137321202ab5a483.tar.gz
freebsd-ports-gnome-c257cdcac065a53ad02724bd137321202ab5a483.tar.zst
freebsd-ports-gnome-c257cdcac065a53ad02724bd137321202ab5a483.zip
- Fix obvious damage from previous commit:
* cvs rm patch files, which are gone according to PR * fix USE_RC_SUBR handling
Diffstat (limited to 'comms/smstools/Makefile')
-rw-r--r--comms/smstools/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/comms/smstools/Makefile b/comms/smstools/Makefile
index 6038a836e8ca..16358199b5c7 100644
--- a/comms/smstools/Makefile
+++ b/comms/smstools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smstools
PORTVERSION= 2.0.7
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.meinemullemaus.de/software/smstools/packages/
@@ -18,19 +19,12 @@ LIB_DEPENDS= mm:${PORTSDIR}/devel/mm
WRKSRC= ${WRKDIR}/smstools
USE_GMAKE= yes
USE_RC_SUBR= smsd.sh
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} \
- EXAMPLESDIR=${EXAMPLESDIR}
post-patch:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/smsd.sh.in > ${WRKDIR}/smsd.sh
- @${REINPLACE_CMD} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ @${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/src/smsd_cfg.c \
${WRKSRC}/install.sh \
${WRKSRC}/examples/smsd.conf.easy \
${WRKSRC}/examples/smsd.conf.full
-post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/smsd.sh ${PREFIX}/etc/rc.d/smsd.sh
-
.include <bsd.port.mk>