aboutsummaryrefslogtreecommitdiffstats
path: root/comms/thebridge/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-27 21:56:54 +0800
committerpav <pav@FreeBSD.org>2004-06-27 21:56:54 +0800
commit0442713430fe0e2ee3580cd29bc157bfcac31b80 (patch)
treecf3140bbaeebd8136a707dbde2755c2badc760cf /comms/thebridge/Makefile
parentb8a3e4e91041af0826e54d19f0718203036cfd01 (diff)
downloadfreebsd-ports-gnome-0442713430fe0e2ee3580cd29bc157bfcac31b80.tar.gz
freebsd-ports-gnome-0442713430fe0e2ee3580cd29bc157bfcac31b80.tar.zst
freebsd-ports-gnome-0442713430fe0e2ee3580cd29bc157bfcac31b80.zip
Add thebridge, an amateur radio EchoLink compatible conference bridge
reimplementation for UNIX PR: ports/68350 Submitted by: Diane Bruce <db@db.net>
Diffstat (limited to 'comms/thebridge/Makefile')
-rw-r--r--comms/thebridge/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/comms/thebridge/Makefile b/comms/thebridge/Makefile
new file mode 100644
index 000000000000..9f912c7a870b
--- /dev/null
+++ b/comms/thebridge/Makefile
@@ -0,0 +1,34 @@
+# ports collection makefile for: thebridge
+# Date created: 22 June 2004
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= thebridge
+PORTVERSION= 0.72
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cqinet
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= db@db.net
+COMMENT= Amateur Radio Echolink conference bridge
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/FreeBSD/tbd.sh
+ @${MV} ${WRKSRC}/tbd.conf ${WRKSRC}/tbd.conf.sample
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/FreeBSD/tbd.sh ${PREFIX}/etc/rc.d/tbd.sh.sample
+
+.include <bsd.port.mk>