aboutsummaryrefslogtreecommitdiffstats
path: root/comms/thebridge/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-27 21:56:54 +0800
committerpav <pav@FreeBSD.org>2004-06-27 21:56:54 +0800
commit0442713430fe0e2ee3580cd29bc157bfcac31b80 (patch)
treecf3140bbaeebd8136a707dbde2755c2badc760cf /comms/thebridge/files
parentb8a3e4e91041af0826e54d19f0718203036cfd01 (diff)
downloadfreebsd-ports-gnome-0442713430fe0e2ee3580cd29bc157bfcac31b80.tar.gz
freebsd-ports-gnome-0442713430fe0e2ee3580cd29bc157bfcac31b80.tar.zst
freebsd-ports-gnome-0442713430fe0e2ee3580cd29bc157bfcac31b80.zip
Add thebridge, an amateur radio EchoLink compatible conference bridge
reimplementation for UNIX PR: ports/68350 Submitted by: Diane Bruce <db@db.net>
Diffstat (limited to 'comms/thebridge/files')
-rw-r--r--comms/thebridge/files/patch-FreeBSD-tbd.sh11
-rw-r--r--comms/thebridge/files/patch-Makefile.in16
-rw-r--r--comms/thebridge/files/patch-configure20
-rw-r--r--comms/thebridge/files/patch-src-Makefile.in21
4 files changed, 68 insertions, 0 deletions
diff --git a/comms/thebridge/files/patch-FreeBSD-tbd.sh b/comms/thebridge/files/patch-FreeBSD-tbd.sh
new file mode 100644
index 000000000000..6a32ae0835bc
--- /dev/null
+++ b/comms/thebridge/files/patch-FreeBSD-tbd.sh
@@ -0,0 +1,11 @@
+--- FreeBSD/tbd.sh.orig Wed Jun 23 16:02:28 2004
++++ FreeBSD/tbd.sh Wed Jun 23 16:02:59 2004
+@@ -2,7 +2,7 @@
+ # $Id: tbd.sh,v 1.1.1.1 2002/08/10 20:33:40 wb6ymh Exp $
+
+ pidfiledir=/var/run
+-tbd=/usr/local/libexec/tbd
++tbd=%%PREFIX%%/libexec/tbd
+
+ # start
+ if [ "x$1" = "x" -o "x$1" = "xstart" ]; then
diff --git a/comms/thebridge/files/patch-Makefile.in b/comms/thebridge/files/patch-Makefile.in
new file mode 100644
index 000000000000..4e99ac3cf636
--- /dev/null
+++ b/comms/thebridge/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig Tue Sep 9 17:06:55 2003
++++ Makefile.in Wed Jun 23 17:50:24 2004
+@@ -85,10 +85,10 @@
+ RANLIB = @RANLIB@
+ VERSION = @VERSION@
+
+-SUBDIRS = common zlib src inc tbdcmd
+-EXTRA_DIST = theBridge.dsp tbd.conf README.txt FreeBSD RedHat config SCRIPTING.txt
++SUBDIRS = common src inc tbdcmd
++EXTRA_DIST = theBridge.dsp tbd.conf.sample README.txt FreeBSD RedHat config SCRIPTING.txt
+
+-sysconf_DATA = tbd.conf
++sysconf_DATA = tbd.conf.sample
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
+ CONFIG_HEADER = config.h
diff --git a/comms/thebridge/files/patch-configure b/comms/thebridge/files/patch-configure
new file mode 100644
index 000000000000..0396c744ee62
--- /dev/null
+++ b/comms/thebridge/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Thu Jun 24 14:32:44 2004
++++ configure Thu Jun 24 14:33:09 2004
+@@ -1961,7 +1961,7 @@
+ ac_given_srcdir=$srcdir
+ ac_given_INSTALL="$INSTALL"
+
+-trap 'rm -fr `echo "Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile zlib/Makefile config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
++trap 'rm -fr `echo "Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
+ EOF
+ cat >> $CONFIG_STATUS <<EOF
+
+@@ -2054,7 +2054,7 @@
+
+ cat >> $CONFIG_STATUS <<EOF
+
+-CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile zlib/Makefile"}
++CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile "}
+ EOF
+ cat >> $CONFIG_STATUS <<\EOF
+ for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
diff --git a/comms/thebridge/files/patch-src-Makefile.in b/comms/thebridge/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..9a3adda8f580
--- /dev/null
+++ b/comms/thebridge/files/patch-src-Makefile.in
@@ -0,0 +1,21 @@
+--- src/Makefile.in.orig Tue Sep 9 23:06:56 2003
++++ src/Makefile.in Sun Jun 27 15:46:18 2004
+@@ -86,7 +86,7 @@
+ tbd_SOURCES = conference.c conference.h configvars.c configvars.h dirclient.c dirclient.h thebridge.c users.c users.h hostfile.c hostfile.h eventhook.c eventhook.h
+
+
+-tbd_LDADD = $(top_builddir)/common/libcommon.a $(top_builddir)/zlib/libzlib.a
++tbd_LDADD = $(top_builddir)/common/libcommon.a -lz
+
+ AM_CPPFLAGS = -I$(top_srcdir)/inc
+ AM_CFLAGS = -Wall -DSYSCON_DIR=\"$(sysconfdir)\"
+@@ -102,8 +102,7 @@
+ LIBS = @LIBS@
+ tbd_OBJECTS = conference.o configvars.o dirclient.o thebridge.o users.o \
+ hostfile.o eventhook.o
+-tbd_DEPENDENCIES = $(top_builddir)/common/libcommon.a \
+-$(top_builddir)/zlib/libzlib.a
++tbd_DEPENDENCIES = $(top_builddir)/common/libcommon.a
+ tbd_LDFLAGS =
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)