aboutsummaryrefslogtreecommitdiffstats
path: root/comms/tilp/files
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 19:03:44 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 19:03:44 +0800
commitfd7c7b3bb64787711ad7bcdfc8e0eb392bc37ec1 (patch)
tree59464144a53620a9591479b3fda0034783a924a1 /comms/tilp/files
parente9d81a8259d23bf8fdcdda94e5ca44603a255806 (diff)
downloadfreebsd-ports-gnome-fd7c7b3bb64787711ad7bcdfc8e0eb392bc37ec1.tar.gz
freebsd-ports-gnome-fd7c7b3bb64787711ad7bcdfc8e0eb392bc37ec1.tar.zst
freebsd-ports-gnome-fd7c7b3bb64787711ad7bcdfc8e0eb392bc37ec1.zip
[new port] TiLP: TI calculator link program
TiLP is a Linking Program to send/receive files to/from your TI calculator. PR: ports/56137 Submitted by: Tijl Coosemans <tijl@ulyssis.org>
Diffstat (limited to 'comms/tilp/files')
-rw-r--r--comms/tilp/files/patch-Makefile.in10
-rw-r--r--comms/tilp/files/patch-man-Makefile.in11
-rw-r--r--comms/tilp/files/patch-src-action.c10
-rw-r--r--comms/tilp/files/patch-src-tilp_misc.c11
-rw-r--r--comms/tilp/files/patch-src-tilp_plugin.c19
5 files changed, 61 insertions, 0 deletions
diff --git a/comms/tilp/files/patch-Makefile.in b/comms/tilp/files/patch-Makefile.in
new file mode 100644
index 000000000000..f93ccafb01d8
--- /dev/null
+++ b/comms/tilp/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig Wed Aug 27 22:44:39 2003
++++ Makefile.in Wed Aug 27 22:45:35 2003
+@@ -185,7 +185,6 @@
+ # subdirectories to scan
+ SUBDIRS = \
+ glade help icons man misc pixmaps src win32 \
+- plugins registry \
+ po intl
+
+
diff --git a/comms/tilp/files/patch-man-Makefile.in b/comms/tilp/files/patch-man-Makefile.in
new file mode 100644
index 000000000000..724f8561685b
--- /dev/null
+++ b/comms/tilp/files/patch-man-Makefile.in
@@ -0,0 +1,11 @@
+--- man/Makefile.in.orig Wed Aug 27 23:02:13 2003
++++ man/Makefile.in Wed Aug 27 23:03:09 2003
+@@ -393,7 +393,7 @@
+ groff -Tascii -man $(man_MANS) > Manpage
+ gcc cleaner.c -o cleaner
+ ./cleaner Manpage
+- dos2unix Manpage.txt
++# dos2unix Manpage.txt
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/comms/tilp/files/patch-src-action.c b/comms/tilp/files/patch-src-action.c
new file mode 100644
index 000000000000..9b89e4f8f51c
--- /dev/null
+++ b/comms/tilp/files/patch-src-action.c
@@ -0,0 +1,10 @@
+--- src/action.c.orig Mon Apr 21 15:44:39 2003
++++ src/action.c Mon Apr 21 15:49:32 2003
+@@ -23,6 +23,7 @@
+
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ #include "action.h"
diff --git a/comms/tilp/files/patch-src-tilp_misc.c b/comms/tilp/files/patch-src-tilp_misc.c
new file mode 100644
index 000000000000..eddd821ff083
--- /dev/null
+++ b/comms/tilp/files/patch-src-tilp_misc.c
@@ -0,0 +1,11 @@
+--- src/tilp_misc.c.orig Mon Apr 21 14:30:31 2003
++++ src/tilp_misc.c Mon Apr 21 12:44:08 2003
+@@ -78,7 +78,7 @@
+ options.web_options = g_strdup("");
+ strcpy(options.left_font_name, "");
+ strcpy(options.right_font_name,
+- "-adobe-courier-medium-r-*-*-*-125-*-*-*-*-*-*");
++ "-adobe-courier-medium-r-*-*-*-120-*-*-*-*-*-*");
+ options.console_mode = !0;
+ locale = setlocale(LC_ALL, NULL);
+ strcpy(options.locale, locale);
diff --git a/comms/tilp/files/patch-src-tilp_plugin.c b/comms/tilp/files/patch-src-tilp_plugin.c
new file mode 100644
index 000000000000..73c94e2548ae
--- /dev/null
+++ b/comms/tilp/files/patch-src-tilp_plugin.c
@@ -0,0 +1,19 @@
+--- src/tilp_plugin.c.orig Wed Apr 23 20:51:57 2003
++++ src/tilp_plugin.c Thu Apr 24 13:33:41 2003
+@@ -168,6 +168,7 @@
+ g_dir_close(dir);
+ DISPLAY(_("Done !\n"));
+
++#ifndef __BSD__
+ // Scan registry
+ DISPLAY(_("Scanning registry... "));
+ #ifdef __WIN32__
+@@ -229,7 +230,7 @@
+ }
+ fclose(reg);
+ DISPLAY(_("Done !\n"));
+-
++#endif
+ return 0;
+ }
+