aboutsummaryrefslogtreecommitdiffstats
path: root/comms/trustedqsl/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-23 05:40:50 +0800
committerpav <pav@FreeBSD.org>2005-11-23 05:40:50 +0800
commitce8cdae9deb87066fcae02ac4d24552847178099 (patch)
tree715eebf7a09160ea8a5b7cf01ae82940f1162e63 /comms/trustedqsl/files
parent9e07dec8bb71d9093d8a583dcdae1323a13c920b (diff)
downloadfreebsd-ports-gnome-ce8cdae9deb87066fcae02ac4d24552847178099.tar.gz
freebsd-ports-gnome-ce8cdae9deb87066fcae02ac4d24552847178099.tar.zst
freebsd-ports-gnome-ce8cdae9deb87066fcae02ac4d24552847178099.zip
- Update to 1.11
PR: ports/89430 Submitted by: Diane Bruce <db@db.net> (maintainer)
Diffstat (limited to 'comms/trustedqsl/files')
-rw-r--r--comms/trustedqsl/files/Makefile4
-rw-r--r--comms/trustedqsl/files/Makefile.TrustedQSL-1.1165
-rw-r--r--comms/trustedqsl/files/Makefile.tqsllib4
-rw-r--r--comms/trustedqsl/files/Makefile.tqsllib-apps56
-rw-r--r--comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm9
-rw-r--r--comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp18
-rw-r--r--comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm9
-rw-r--r--comms/trustedqsl/files/patch-tqsllib_sysconfig.h31
-rw-r--r--comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.1180
-rw-r--r--comms/trustedqsl/files/sysconfig.h.tqsllib45
10 files changed, 230 insertions, 91 deletions
diff --git a/comms/trustedqsl/files/Makefile b/comms/trustedqsl/files/Makefile
index ba304dc4ce5e..553f160a83dd 100644
--- a/comms/trustedqsl/files/Makefile
+++ b/comms/trustedqsl/files/Makefile
@@ -2,8 +2,8 @@
all:
(cd tqsllib;make)
- (cd tqsllib-apps;make)
+ (cd TrustedQSL-1.11;make)
install:
(cd tqsllib;make install)
- (cd tqsllib-apps;make install)
+ (cd TrustedQSL-1.11;make install)
diff --git a/comms/trustedqsl/files/Makefile.TrustedQSL-1.11 b/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
new file mode 100644
index 000000000000..d8527c17b62f
--- /dev/null
+++ b/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
@@ -0,0 +1,65 @@
+TQSLLIB=../tqsllib
+TQSLINC=../tqsllib
+TQSL_VERSION_MAJOR = 1
+TQSL_VERSION_MINOR = 11
+OPENSSL=/usr/local
+LIBS=-lz -lexpat -lcrypto
+INCDIR = -I$(TQSLINC)
+BUILD = unofficial
+WXFLAGS=`wxgtk2-2.6-config --cflags`
+WXLIBS=`wxgtk2-2.6-config --libs`
+DEFS = -DHAVE_CONFIG_H
+CXXFLAGS += $(DEFS) $(INCDIR) -DHAVE_LIBCRYPTO=1 -DSTDC_HEADERS=1 -DHAVE_MKDIR=1 -DHAVE_STRERROR=1 $(WXFLAGS)
+
+LDLIBS = -L$(TQSLLIB) -L$(OPENSSL)/lib -ltqsllib $(LIBS) $(WXLIBS)
+TQSLLIBFILE=$(TQSLLIB)/libtqsllib.a
+CCDEPMODE = depmode=gcc3
+BINDIR=${PREFIX}/bin
+DOCDIR=${PREFIX}/share/doc
+ETCDIR=${PREFIX}/etc
+PERL ?=perl
+CP ?=cp
+TOUCH ?=touch
+
+TARGETS = tqslcert tqsl
+
+all: tqslcertbuild.h tqslbuild.h $(TARGETS)
+
+TQSLCERT_OBJ = tqslcert.o crqwiz.o dxcc.o certtree.o tqslcert_prefs.o \
+ getpassword.o extwizard.o loadcertwiz.o wxutil.o
+
+TQSL_OBJ = tqsl.o extwizard.o tqslwiz.o dxcc.o stationdial.o qsodatadialog.o \
+ tqslvalidator.o tqsl_prefs.o wxutil.o
+
+tqslcert: $(TQSLCERT_OBJ) $(TQSLLIBFILE)
+ $(CC) $(CXXFLAGS) -o $@ $(TQSLCERT_OBJ) $(LDLIBS) -lstdc++
+
+tqsl: $(TQSL_OBJ) $(TQSLLIBFILE)
+ $(CC) $(CXXFLAGS) -o $@ $(TQSL_OBJ) $(LDLIBS) -lstdc++
+
+tqslcert.o:
+ ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
+
+tqslcertbuild.h: tqslcertbuild.h.in Makefile
+ $(PERL) touchver.pl tqslcertbuild.h.in BUILD $(BUILD)
+ $(CP) tqslcertbuild.h.in tqslcertbuild.h
+ $(TOUCH) tqslcertbuild.h.in
+
+tqslbuild.h: tqslbuild.h.in Makefile
+ $(PERL) touchver.pl tqslbuild.h.in BUILD $(BUILD)
+ $(CP) tqslbuild.h.in tqslbuild.h
+ $(TOUCH) tqslbuild.h.in
+
+tqsl.o:
+ ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
+
+%.o: %.cpp
+ ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
+
+clean:
+ rm -f $(TARGETS) *.o *.a *~ xxx.*
+
+install:
+ ${INSTALL} -d $(BINDIR) $(ETCDIR)/tqsl
+ ${INSTALL} -C $(TARGETS) $(BINDIR)
+ ${INSTALL} -C ../tqsllib/config.xml $(ETCDIR)/tqsl
diff --git a/comms/trustedqsl/files/Makefile.tqsllib b/comms/trustedqsl/files/Makefile.tqsllib
index 509c68f152b4..89bbe3851aaa 100644
--- a/comms/trustedqsl/files/Makefile.tqsllib
+++ b/comms/trustedqsl/files/Makefile.tqsllib
@@ -1,8 +1,8 @@
CXX = g++
CC ?= gcc
LIBS=-lcrypto -lexpat
-CXXFLAGS += -I. $(INCDIR) -DHAVE_CONFIG_H
-LDFLAGS += -L. $(LIBS) -lstdc++
+CXXFLAGS += -I. -I${LOCALBASE}/include -DHAVE_CONFIG_H
+LDFLAGS = -L. $(LIBS) -L${LOCALBASE}/lib -lstdc++
TARGETS = gen_crq load_cert station_loc dumptqsldata converter
ZLIB=z
MYLIB=tqsllib
diff --git a/comms/trustedqsl/files/Makefile.tqsllib-apps b/comms/trustedqsl/files/Makefile.tqsllib-apps
deleted file mode 100644
index 26548b007b57..000000000000
--- a/comms/trustedqsl/files/Makefile.tqsllib-apps
+++ /dev/null
@@ -1,56 +0,0 @@
-TQSLLIB=../tqsllib
-TQSLINC=../tqsllib
-OPENSSL=/usr
-LIBS=-lz -lexpat -lcrypto
-INCDIR = -I$(TQSLINC)
-BUILD=unofficial
-WXFLAGS=`wxgtk2-2.4-config --cflags`
-WXLIBS=`wxgtk2-2.4-config --libs`
-CXXFLAGS += $(INCDIR) -DHAVE_LIBCRYPTO=1 -DSTDC_HEADERS=1 -DHAVE_MKDIR=1 -DHAVE_STRERROR=1 $(WXFLAGS)
-LDLIBS = -L$(OPENSSL)/lib -L$(TQSLLIB) -ltqsllib $(LIBS) $(WXLIBS)
-TQSLLIBFILE=$(TQSLLIB)/libtqsllib.a
-
-BINDIR=${PREFIX}/bin
-DOCDIR=${PREFIX}/share/doc
-ETCDIR=${PREFIX}/etc
-
-TARGETS = tqslcert tqsl
-
-all: $(TARGETS)
-
-TQSLCERT_OBJ = tqslcert.o crqwiz.o dxcc.o certtree.o tqslcert_prefs.o \
- getpassword.o extwizard.o loadcertwiz.o wxutil.o
-
-TQSL_OBJ = tqsl.o extwizard.o tqslwiz.o dxcc.o stationdial.o qsodatadialog.o \
- tqslvalidator.o tqsl_prefs.o wxutil.o
-
-tqslcert: $(TQSLCERT_OBJ) $(TQSLLIBFILE)
- $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@ $(TQSLCERT_OBJ) $(LDLIBS) -lstdc++
-
-tqsl: $(TQSL_OBJ) $(TQSLLIBFILE)
- $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@ $(TQSL_OBJ) $(LDLIBS) -lstdc++
-
-include apps.depends
-
-tqslcertbuild.h: buildskel.h
- cp buildskel.h tqslcertbuild.h
-
-tqslcert.o:
- ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
-
-tqslbuild.h: buildskel.h
- cp buildskel.h tqslbuild.h
-
-tqsl.o:
- ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
-
-%.o: %.cpp
- ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
-
-clean:
- rm -f $(TARGETS) *.o *.a *~ xxx.*
-
-install:
- ${INSTALL} -d $(BINDIR) $(ETCDIR)/tqsl
- ${INSTALL} -C $(TARGETS) $(BINDIR)
- ${INSTALL} -C ../tqsllib/config.xml $(ETCDIR)/tqsl
diff --git a/comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm b/comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm
new file mode 100644
index 000000000000..1e83e4bb9c2e
--- /dev/null
+++ b/comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm
@@ -0,0 +1,9 @@
+--- TrustedQSL-1.11/left.xpm.orig Mon Nov 21 21:27:38 2005
++++ TrustedQSL-1.11/left.xpm Mon Nov 21 21:33:47 2005
+@@ -1,5 +1,5 @@
+ /* XPM */
+-static char *left[]={
++static char *left_i[]={
+ "10 10 29 1",
+ ". c None",
+ "d c #000000",
diff --git a/comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp b/comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp
new file mode 100644
index 000000000000..4e597f366c7f
--- /dev/null
+++ b/comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp
@@ -0,0 +1,18 @@
+--- TrustedQSL-1.11/qsodatadialog.cpp.orig Mon Nov 21 21:27:29 2005
++++ TrustedQSL-1.11/qsodatadialog.cpp Mon Nov 21 21:34:00 2005
+@@ -302,13 +302,13 @@
+ sizer = new wxBoxSizer(wxHORIZONTAL);
+ _recbottom_ctrl = new wxBitmapButton(this, QD_RECBOTTOM, wxBitmap(bottom), wxDefaultPosition, wxSize(18, TEXT_HEIGHT)),
+ sizer->Add(_recbottom_ctrl, 0, wxTOP|wxBOTTOM, 5);
+- _recdown_ctrl = new wxBitmapButton(this, QD_RECDOWN, wxBitmap(left), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
++ _recdown_ctrl = new wxBitmapButton(this, QD_RECDOWN, wxBitmap(left_i), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
+ sizer->Add(_recdown_ctrl, 0, wxTOP|wxBOTTOM, 5);
+ _recno_ctrl = new wxTextCtrl(this, QD_RECNO, wxT("1"), wxDefaultPosition,
+ wxSize(4*TEXT_WIDTH,TEXT_HEIGHT));
+ _recno_ctrl->Enable(FALSE);
+ sizer->Add(_recno_ctrl, 0, wxALL, 5);
+- _recup_ctrl = new wxBitmapButton(this, QD_RECUP, wxBitmap(right), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
++ _recup_ctrl = new wxBitmapButton(this, QD_RECUP, wxBitmap(right_i), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
+ sizer->Add(_recup_ctrl, 0, wxTOP|wxBOTTOM, 5);
+ _rectop_ctrl = new wxBitmapButton(this, QD_RECTOP, wxBitmap(top), wxDefaultPosition, wxSize(18, TEXT_HEIGHT)),
+ sizer->Add(_rectop_ctrl, 0, wxTOP|wxBOTTOM, 5);
diff --git a/comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm b/comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm
new file mode 100644
index 000000000000..56b2d8d0101e
--- /dev/null
+++ b/comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm
@@ -0,0 +1,9 @@
+--- TrustedQSL-1.11/right.xpm.orig Mon Nov 21 21:27:56 2005
++++ TrustedQSL-1.11/right.xpm Mon Nov 21 21:33:41 2005
+@@ -1,5 +1,5 @@
+ /* XPM */
+-static char *right[]={
++static char *right_i[]={
+ "10 10 30 1",
+ "a c None",
+ "g c #000000",
diff --git a/comms/trustedqsl/files/patch-tqsllib_sysconfig.h b/comms/trustedqsl/files/patch-tqsllib_sysconfig.h
deleted file mode 100644
index a801e4e3e78c..000000000000
--- a/comms/trustedqsl/files/patch-tqsllib_sysconfig.h
+++ /dev/null
@@ -1,31 +0,0 @@
---- tqsllib/sysconfig.h.orig Wed Jul 21 11:51:59 2004
-+++ tqsllib/sysconfig.h Wed Jul 21 11:54:05 2004
-@@ -14,7 +14,7 @@
- /* #undef TM_IN_SYS_TIME */
-
- /* Defined if this is LOTW server code */
--#define LOTW_SERVER 1
-+#undef LOTW_SERVER
-
- /* Define if you have the mkdir function. */
- #define HAVE_MKDIR 1
-@@ -29,7 +29,7 @@
- #define HAVE_UNISTD_H 1
-
- /* Define if you have the <getopt.h> header file. */
--/* #undef HAVE_GETOPT_H */
-+#define HAVE_GETOPT_H
-
- /* Define if you have the crypto library (-lcrypto). */
- #define HAVE_LIBCRYPTO 1
-@@ -38,8 +38,8 @@
- #define HAVE_LIBDL 1
-
- /* Define if you have the pcrl library (-lpcrl). */
--#define HAVE_LIBPCRL 1
-+#undef HAVE_LIBPCRL
-
- /* Define if you have the sqlca library (-lsqlca). */
--#define HAVE_LIBSQLCA 1
-+#undef HAVE_LIBSQLCA
-
diff --git a/comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.11 b/comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.11
new file mode 100644
index 000000000000..cddeb15f995d
--- /dev/null
+++ b/comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.11
@@ -0,0 +1,80 @@
+/* sysconfig.h. Generated by configure. */
+/* sysconfig.h.in. Generated from configure.in by autoheader. */
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#define HAVE_INTTYPES_H 1
+
+/* Define to 1 if you have the `crypto' library (-lcrypto). */
+#define HAVE_LIBCRYPTO 1
+
+/* Define to 1 if you have the `expat' library (-lexpat). */
+#define HAVE_LIBEXPAT 1
+
+/* Define to 1 if you have the `tqsllib' library (-ltqsllib). */
+#define HAVE_LIBTQSLLIB 1
+
+/* Define to 1 if you have the `tqsllibd' library (-ltqsllibd). */
+/* #undef HAVE_LIBTQSLLIBD */
+
+/* Define to 1 if you have the `z' library (-lz). */
+#define HAVE_LIBZ 1
+
+/* Define to 1 if you have the <memory.h> header file. */
+#define HAVE_MEMORY_H 1
+
+/* Define to 1 if you have the `mkdir' function. */
+#define HAVE_MKDIR 1
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#define HAVE_STDINT_H 1
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#define HAVE_STDLIB_H 1
+
+/* Define to 1 if you have the `strerror' function. */
+#define HAVE_STRERROR 1
+
+/* Define to 1 if you have the <strings.h> header file. */
+#define HAVE_STRINGS_H 1
+
+/* Define to 1 if you have the <string.h> header file. */
+#define HAVE_STRING_H 1
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#define HAVE_SYS_STAT_H 1
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#define HAVE_SYS_TYPES_H 1
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#define HAVE_UNISTD_H 1
+
+/* Name of package */
+#define PACKAGE "TrustedQSL"
+
+/* Define to the address where bug reports for this package should be sent. */
+#define PACKAGE_BUGREPORT "lotw-help@arrl.org"
+
+/* Define to the full name of this package. */
+#define PACKAGE_NAME "TrustedQSL"
+
+/* Define to the full name and version of this package. */
+#define PACKAGE_STRING "TrustedQSL 1.11"
+
+/* Define to the one symbol short name of this package. */
+#define PACKAGE_TARNAME "TrustedQSL"
+
+/* Define to the version of this package. */
+#define PACKAGE_VERSION "1.11"
+
+/* Define to 1 if you have the ANSI C header files. */
+#define STDC_HEADERS 1
+
+/* Version number of package */
+#define VERSION "1.11"
+
+/* Define to empty if `const' does not conform to ANSI C. */
+/* #undef const */
+
+/* Define to `unsigned' if <sys/types.h> does not define. */
+/* #undef size_t */
diff --git a/comms/trustedqsl/files/sysconfig.h.tqsllib b/comms/trustedqsl/files/sysconfig.h.tqsllib
new file mode 100644
index 000000000000..de7c9c9b2d01
--- /dev/null
+++ b/comms/trustedqsl/files/sysconfig.h.tqsllib
@@ -0,0 +1,45 @@
+/* tqsllib/sysconfig.h. Generated automatically by configure. */
+/* lotwdb/sysconfig.h.in. Generated automatically from configure.in by autoheader. */
+
+/* Define to empty if the keyword does not work. */
+/* #undef const */
+
+/* Define to `int' if <sys/types.h> doesn't define. */
+/* #undef mode_t */
+
+/* Define if you have the ANSI C header files. */
+#define STDC_HEADERS 1
+
+/* Define if your <sys/time.h> declares struct tm. */
+/* #undef TM_IN_SYS_TIME */
+
+/* Defined if this is LOTW server code */
+#undef LOTW_SERVER
+
+/* Define if you have the mkdir function. */
+#define HAVE_MKDIR 1
+
+/* Define if you have the strerror function. */
+#define HAVE_STRERROR 1
+
+/* Define if you have the snprintf function. */
+#define HAVE_SNPRINTF 1
+
+/* Define if you have the <unistd.h> header file. */
+#define HAVE_UNISTD_H 1
+
+/* Define if you have the <getopt.h> header file. */
+#define HAVE_GETOPT_H
+
+/* Define if you have the crypto library (-lcrypto). */
+#define HAVE_LIBCRYPTO 1
+
+/* Define if you have the dl library (-ldl). */
+#define HAVE_LIBDL 1
+
+/* Define if you have the pcrl library (-lpcrl). */
+#undef HAVE_LIBPCRL
+
+/* Define if you have the sqlca library (-lsqlca). */
+#undef HAVE_LIBSQLCA
+
t; 0.1.0.9 hs-mutable-containers 0.3.2 --> 0.3.3 hs-mwc-random 0.13.3.2 --> 0.13.6.0 hs-mysql 0.1.1.8 --> 0.1.4 hs-network 2.6.2.1 --> 2.6.3.2 hs-network-info 0.2.0.7 --> 0.2.0.8 hs-network-multicast 0.1.0 --> 0.2.0 hs-network-uri 2.6.0.3 --> 2.6.1.0 hs-nonce 1.0.2 --> 1.0.4 hs-oeis 0.3.6 --> 0.3.9 hs-optparse-applicative 0.11.0.2 --> 0.14.0.0 hs-pandoc 1.15.0.6_1 --> 1.19.2.1 hs-pandoc-citeproc 0.7.3.1 --> 0.10.5.1 hs-pandoc-types 1.12.4.5 --> 1.19 hs-pango 0.13.1.0 --> 0.13.3.1 hs-parallel 3.2.0.6 --> 3.2.1.1 hs-parsec 3.1.9 --> 3.1.11 hs-path-pieces 0.2.0 --> 0.2.1 hs-pcre-light 0.4.0.3 --> 0.4.0.4 hs-persistent 2.2 --> 2.7.0 hs-persistent-sqlite 2.2 --> 2.6.2 hs-persistent-template 2.1.3.4 --> 2.5.2 hs-pointed 4.2.0.2 --> 5 hs-polyparse 1.11 --> 1.12 hs-prelude-extras 0.4_2 --> 0.4.0.3 hs-primitive 0.6 --> 0.6.2.0 hs-probability 0.2.4.1_2 --> 0.2.5.1 hs-profunctors 5.1.1 --> 5.2 hs-pureMD5 2.1.2.1_10 --> 2.1.3 hs-quickcheck-io 0.1.1_2 --> 0.2.0 hs-reflection 2 --> 2.1.2 hs-regex-applicative 0.3.2.1 --> 0.3.3 hs-regex-tdfa 1.2.0_2 --> 1.2.2 hs-resourcet 1.1.6 --> 1.1.9 hs-safe 0.3.9 --> 0.3.15 hs-sandi 0.3.5 --> 0.4.0 hs-scientific 0.3.3.8 --> 0.3.5.1 hs-semigroupoids 5.0.0.3 --> 5.2 hs-semigroups 0.16.2.2 --> 0.18.3 hs-setlocale 1.0.0.4 --> 1.0.0.5 hs-shake 0.15.5 --> 0.15.11 hs-shakespeare 2.0.5 --> 2.0.13 hs-shelly 1.6.3.3 --> 1.6.8.3 hs-simple-sendfile 0.2.21 --> 0.2.25 hs-skein 1.0.9.3 --> 1.0.9.4 hs-snap 0.14.0.6 --> 1.0.0.1 hs-snap-core 0.9.7.2 --> 1.0.2.1 hs-snap-server 0.9.5.1 --> 1.0.2.2 hs-socks 0.5.4_2 --> 0.5.5 hs-split 0.2.2_7 --> 0.2.3.2 hs-statistics 0.13.2.3 --> 0.14.0.2 hs-stm 2.4.4 --> 2.4.4.1 hs-streaming-commons 0.1.12.1 --> 0.1.18 hs-svgcairo 0.13.0.3 --> 0.13.1.1 hs-syb 0.5.1 --> 0.7 hs-syb-with-class 0.6.1.6 --> 0.6.1.7 hs-tagged 0.8.1 --> 0.8.5 hs-tagsoup 0.13.3 --> 0.14.1 hs-tar 0.4.2.1 --> 0.5.0.3 hs-temporary 1.2.0.3_2 --> 1.2.1 hs-test-framework-hunit 0.3.0.1_2 --> 0.3.0.2 hs-test-framework-quickcheck2 0.3.0.3_2 --> 0.3.0.4 hs-texmath 0.8.3 --> 0.9.4.1 hs-text 1.2.1.3 --> 1.2.2.2 hs-threads 0.5.1.3 --> 0.5.1.4 hs-threadscope 0.2.7 --> 0.2.8 hs-time-locale-compat 0.1.1.0 --> 0.1.1.3 hs-timezone-olson 0.1.7 --> 0.1.8 hs-timezone-series 0.1.5.1 --> 0.1.8 hs-tls 1.3.1 --> 1.3.11 hs-torrent 10000.0.0 --> 10000.1.1 hs-transformers-compat 0.4.0.4 --> 0.5.1.4 hs-unix-compat 0.4.1.4 --> 0.4.3.1 hs-unix-time 0.3.5 --> 0.3.7 hs-unlambda 0.1.4.1 --> 0.1.4.2 hs-unordered-containers 0.2.5.1 --> 0.2.8.0 hs-uri 0.1.6.3 --> 0.1.6.4 hs-utf8-string 1 --> 1.0.1.1 hs-utility-ht 0.0.10_2 --> 0.0.14_2 hs-uuid 1.3.11 --> 1.3.13 hs-uuid-types 1.0.2 --> 1.0.3 hs-uulib 0.9.20 --> 0.9.22 hs-vault 0.3.0.4 --> 0.3.0.7 hs-vector 0.10.12.3 --> 0.12.0.1 hs-vector-binary-instances 0.2.1.0_2 --> 0.2.3.5 hs-vector-instances 3.3.1 --> 3.4 hs-vector-space 0.10.2 --> 0.10.4 hs-vector-th-unbox 0.2.1.2 --> 0.2.1.6 hs-void 0.7 --> 0.7.2 hs-vte 0.13.0.2 --> 0.13.1.1 hs-wai 3.0.3.0 --> 3.2.1.1 hs-wai-app-static 3.1.1 --> 3.1.6.1 hs-wai-extra 3.0.10 --> 3.0.20.0 hs-wai-logger 2.2.4.1 --> 2.3.0 hs-warp 3.1.3 --> 3.2.13 hs-warp-tls 3.1.1 --> 3.2.4 hs-webkit 0.13.1.3 --> 0.14.2.1 hs-wx 0.91.0.0 --> 0.92.3.0 hs-wxc 0.91.0.0 --> 0.92.3.0 hs-wxcore 0.91.0.0 --> 0.92.3.0 hs-wxdirect 0.91.0.0 --> 0.92.3.0 hs-x509 1.6.0 --> 1.6.5 hs-x509-store 1.6.0 --> 1.6.2 hs-x509-system 1.6.0 --> 1.6.4 hs-x509-validation 1.6.0 --> 1.6.5 hs-xml-conduit 1.3.1 --> 1.5.1 hs-xml-hamlet 0.4.0.11 --> 0.4.1 hs-xmlhtml 0.2.3.4 --> 0.2.4 hs-xmobar 0.24.3 --> 0.24.5 hs-xss-sanitize 0.3.5.6 --> 0.3.5.7 hs-yaml 0.8.13 --> 0.8.23.1 hs-yesod 1.4.1.5 --> 1.4.5 hs-yesod-auth 1.4.6 --> 1.4.17.2 hs-yesod-auth-hashdb 1.4.2.2 --> 1.6.1 hs-yesod-bin 1.4.13.3 --> 1.5.2.3 hs-yesod-core 1.4.13 --> 1.4.35 hs-yesod-form 1.4.4.1 --> 1.4.12 hs-yesod-persistent 1.4.0.3 --> 1.4.2 hs-yesod-static 1.5.0.2 --> 1.5.3 hs-yesod-test 1.4.3.1 --> 1.5.7 hs-zip-archive 0.2.3.7 --> 0.3.1.1 hs-zlib 0.5.4.2 --> 0.6.1.2 scroll 1.20151219 --> 1.20170122 Removed ports (5): hs-MonadCatchIO-mtl Deprecated in favor of exceptions hs-MonadCatchIO-transformers Deprecated in favor of exceptions hs-citeproc-hs Replaced by pandoc-citeproc hs-directory Part of the packages shipped with GHC hs-syb-with-class-instances-text Upstream is unmaintained This was created together with pgj@. Reviewed by: pgj, 6yearold_gmail.com Differential Revision: https://reviews.freebsd.org/D11558 * - Update The Glorious Glasgow Haskell Compiler to version 7.10.2pgj2015-08-21