aboutsummaryrefslogtreecommitdiffstats
path: root/comms/uhso-kmod
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2012-06-11 15:13:00 +0800
committermartymac <martymac@FreeBSD.org>2012-06-11 15:13:00 +0800
commit4696e22bf44d70060c1a3df73abc3c1d3af8a4ee (patch)
tree1d723e5e060767ea0d18d83cbadb640101aeac7f /comms/uhso-kmod
parentbc0a37d813eac23377341e8e4a0bbe12fd1389f5 (diff)
downloadfreebsd-ports-gnome-4696e22bf44d70060c1a3df73abc3c1d3af8a4ee.tar.gz
freebsd-ports-gnome-4696e22bf44d70060c1a3df73abc3c1d3af8a4ee.tar.zst
freebsd-ports-gnome-4696e22bf44d70060c1a3df73abc3c1d3af8a4ee.zip
Switch to OptionsNg
Diffstat (limited to 'comms/uhso-kmod')
-rw-r--r--comms/uhso-kmod/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/comms/uhso-kmod/Makefile b/comms/uhso-kmod/Makefile
index 0bea559d157b..041e3daad864 100644
--- a/comms/uhso-kmod/Makefile
+++ b/comms/uhso-kmod/Makefile
@@ -22,8 +22,10 @@ CONFLICTS= hso-kmod-[0-9]*
NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
-OPTIONS= UHSOCTL "Build uhsoctl tool" on \
- DEBUG "Build with debug symbols" off
+OPTIONS_DEFINE= UHSOCTL DEBUG
+OPTIONS_DEFAULT= UHSOCTL
+
+UHSOCTL_DESC= Build uhsoctl tool
SUB_FILES= pkg-message
KMODDIR?= /boot/modules
@@ -42,7 +44,7 @@ IGNORE= requires FreeBSD 8.0 or later, please try comms/hso-kmod instead
IGNORE= the uhso driver is already available in the base system
.endif
-.if !defined(WITHOUT_UHSOCTL)
+.if ${PORT_OPTIONS:MUHSOCTL}
UHSOCTL_VERSION= 20100416
DISTFILES+= uhsoctl-${UHSOCTL_VERSION}${EXTRACT_SUFX}
WRKSRC_UHSOCTL= ${WRKDIR}/uhsoctl-${UHSOCTL_VERSION}
@@ -52,25 +54,23 @@ MAN1= uhsoctl.1
PLIST_SUB+= PL_UHSOCTL="@comment "
.endif
-.if !defined(WITH_DEBUG)
+.if empty(${PORT_OPTIONS:MDEBUG})
EXTRA_PATCHES+= ${PATCHDIR}/UHSO-NODEBUG-patch-Makefile
.endif
post-patch:
-.if !defined(WITHOUT_UHSOCTL)
-.if defined(WITH_DEBUG)
+.if !empty(${PORT_OPTIONS:MUHSOCTL}) && !empty(${PORT_OPTIONS:MDEBUG})
@${PATCH} -d ${WRKSRC_UHSOCTL} < ${PATCHDIR}/UHSOCTL-DEBUG-patch-Makefile
.endif
-.endif
post-build:
-.if !defined(WITHOUT_UHSOCTL)
+.if ${PORT_OPTIONS:MUHSOCTL}
@cd ${WRKSRC_UHSOCTL} && ${SETENV} NO_MANCOMPRESS= ${MAKE} all
.endif
post-install:
${INSTALL_MAN} ${MAN4:S|^|${WRKSRC}/|} ${PREFIX}/man/man4
-.if !defined(WITHOUT_UHSOCTL)
+.if ${PORT_OPTIONS:MUHSOCTL}
@cd ${WRKSRC_UHSOCTL} && \
${SETENV} DESTDIR=${PREFIX}/ BINDIR=bin MANDIR=man/man NO_MANCOMPRESS= \
${MAKE} install