aboutsummaryrefslogtreecommitdiffstats
path: root/comms/uird
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-11-24 02:44:22 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-11-24 02:44:22 +0800
commitb0473323c458fe238bd51c2f6c891f7f0c1b6253 (patch)
tree0c714ea2b91deec162c2978699486e38c6ff7a10 /comms/uird
parent5fadc121fefb7167d66d180701b5ca64660eb6fc (diff)
downloadfreebsd-ports-gnome-b0473323c458fe238bd51c2f6c891f7f0c1b6253.tar.gz
freebsd-ports-gnome-b0473323c458fe238bd51c2f6c891f7f0c1b6253.tar.zst
freebsd-ports-gnome-b0473323c458fe238bd51c2f6c891f7f0c1b6253.zip
Add uird, a Universal IR Receiver Daemon
PR: 89404 Submitted by: lx@deepthought.redundancy.org
Diffstat (limited to 'comms/uird')
-rw-r--r--comms/uird/Makefile40
-rw-r--r--comms/uird/distinfo3
-rw-r--r--comms/uird/pkg-descr15
3 files changed, 58 insertions, 0 deletions
diff --git a/comms/uird/Makefile b/comms/uird/Makefile
new file mode 100644
index 000000000000..6afe590aad97
--- /dev/null
+++ b/comms/uird/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: uird
+# Date created: 2005-11-21
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uird
+PORTVERSION= 1.1
+CATEGORIES= comms
+MASTER_SITES= http://vvv.purjo.nu/uird/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lx@deepthought.redundancy.org
+COMMENT= The Universal IR Receiver Daemon
+
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+
+MAKE_ENV+= CC="${CC}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/uird
+PORTDOCS= Documentation
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|$${CC}\ $${CFLAGS}|; /strip/d' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/uird ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/uird/distinfo b/comms/uird/distinfo
new file mode 100644
index 000000000000..2063a2aa793a
--- /dev/null
+++ b/comms/uird/distinfo
@@ -0,0 +1,3 @@
+MD5 (uird-1.1.tgz) = bccfb171d475308546204da8174f1003
+SHA256 (uird-1.1.tgz) = 22b896b885d9f05356680d0b813d2fe29a2de73038755376701313ac21ccf1e5
+SIZE (uird-1.1.tgz) = 11409
diff --git a/comms/uird/pkg-descr b/comms/uird/pkg-descr
new file mode 100644
index 000000000000..bd8bdb94485a
--- /dev/null
+++ b/comms/uird/pkg-descr
@@ -0,0 +1,15 @@
+UIRD is software to control your PC via a normal remote control. It is designed
+to interface with the UIRR (Universal IR Receiver), which is a piece of
+hardware that you can easily build yourself.
+
+Features:
+
+ * Embedded perl-interpreter for advanced scripting features
+ * Learning mode - interactively press a button on your remote and then enter
+ what should happend every time you push that button
+ * Simple configuration-file for specifying what should happen when you push a
+ particular button
+ * Network mode sends IR-data encapsulated in UDP-packets over the network to a
+ remote host
+
+WWW: http://vvv.purjo.nu/uird/