aboutsummaryrefslogtreecommitdiffstats
path: root/comms/vpb2/Makefile
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2003-12-29 15:58:47 +0800
committerlinimon <linimon@FreeBSD.org>2003-12-29 15:58:47 +0800
commit2aea8e8a7bed432c584eeae2170ed2666c77d3ce (patch)
tree1837e5950e5691cffa220faa9ca022e41a6040f0 /comms/vpb2/Makefile
parent12b4fb5ae1c44cc81ffcc3030bdce2d9d03e94c0 (diff)
downloadfreebsd-ports-gnome-2aea8e8a7bed432c584eeae2170ed2666c77d3ce.tar.gz
freebsd-ports-gnome-2aea8e8a7bed432c584eeae2170ed2666c77d3ce.tar.zst
freebsd-ports-gnome-2aea8e8a7bed432c584eeae2170ed2666c77d3ce.zip
The port did not build on many systems due to conflicting and missing
headers in certain files. It also blindly assumed the default prefix for the etc directory was /etc. Also pet portlint. PR: ports/60680 Submitted by: Samy Al Bahra <samy@kerneled.com>
Diffstat (limited to 'comms/vpb2/Makefile')
-rw-r--r--comms/vpb2/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/comms/vpb2/Makefile b/comms/vpb2/Makefile
index 3429ca6bf2a7..e2ef540276b1 100644
--- a/comms/vpb2/Makefile
+++ b/comms/vpb2/Makefile
@@ -1,4 +1,3 @@
-# Generated automatically from Makefile.in by configure.
# New ports collection makefile for: vpb2
# Date created: 07 Sept 2000
# Whom: David Sugar <dyfet@gnu.org>
@@ -14,18 +13,20 @@ MASTER_SITES= ftp://www.voxilla.org/pub/vpb/
MAINTAINER= dyfet@gnu.org
COMMENT= User mode API for Voicetronix 4 port analog DSP telephony cards
-BROKEN= "Installs file into /etc"
-
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_AUTOCONF= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib \
+ LDFLAGS=${PTHREAD_LIBS}
post-extract:
@${FIND} ${WRKSRC} -name "Makefile.in" | \
${XARGS} ${REINPLACE_CMD} -e 's|-release \$$\(LT_RELEASE\)||g'
+post-patch:
+ ${REINPLACE_CMD} -e "s|PREFIX|${PREFIX}|" ${WRKSRC}/vpbreg.cpp
+
.include <bsd.port.mk>