aboutsummaryrefslogtreecommitdiffstats
path: root/comms/vpb2
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-24 05:57:18 +0800
committerkris <kris@FreeBSD.org>2004-02-24 05:57:18 +0800
commit866c06f429a9e10256e929b51ce024bc7443379b (patch)
treee7d66c9e2e798b5c748d1a5ee6e4a1e79aea3bc8 /comms/vpb2
parent2715acbd85b3ec87c9ab3c0b40082edfd62aa982 (diff)
downloadfreebsd-ports-gnome-866c06f429a9e10256e929b51ce024bc7443379b.tar.gz
freebsd-ports-gnome-866c06f429a9e10256e929b51ce024bc7443379b.tar.zst
freebsd-ports-gnome-866c06f429a9e10256e929b51ce024bc7443379b.zip
BROKEN on !i386: Does not compile
Diffstat (limited to 'comms/vpb2')
-rw-r--r--comms/vpb2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/comms/vpb2/Makefile b/comms/vpb2/Makefile
index 972b5d849b9e..42cead44a331 100644
--- a/comms/vpb2/Makefile
+++ b/comms/vpb2/Makefile
@@ -23,6 +23,12 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib \
LDFLAGS=${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} -name "Makefile.in" | \
${XARGS} ${REINPLACE_CMD} -e 's|-release \$$\(LT_RELEASE\)||g'
@@ -30,4 +36,4 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e "s|PREFIX|${PREFIX}|" ${WRKSRC}/vpbreg.cpp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>