aboutsummaryrefslogtreecommitdiffstats
path: root/comms/vpb2
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2003-12-29 15:58:47 +0800
committerlinimon <linimon@FreeBSD.org>2003-12-29 15:58:47 +0800
commit2aea8e8a7bed432c584eeae2170ed2666c77d3ce (patch)
tree1837e5950e5691cffa220faa9ca022e41a6040f0 /comms/vpb2
parent12b4fb5ae1c44cc81ffcc3030bdce2d9d03e94c0 (diff)
downloadfreebsd-ports-gnome-2aea8e8a7bed432c584eeae2170ed2666c77d3ce.tar.gz
freebsd-ports-gnome-2aea8e8a7bed432c584eeae2170ed2666c77d3ce.tar.zst
freebsd-ports-gnome-2aea8e8a7bed432c584eeae2170ed2666c77d3ce.zip
The port did not build on many systems due to conflicting and missing
headers in certain files. It also blindly assumed the default prefix for the etc directory was /etc. Also pet portlint. PR: ports/60680 Submitted by: Samy Al Bahra <samy@kerneled.com>
Diffstat (limited to 'comms/vpb2')
-rw-r--r--comms/vpb2/Makefile9
-rw-r--r--comms/vpb2/files/patch-Makefile.in11
-rw-r--r--comms/vpb2/files/patch-configure.in27
-rw-r--r--comms/vpb2/files/patch-genericfreebsd.cpp10
-rw-r--r--comms/vpb2/files/patch-playrec.cpp10
-rw-r--r--comms/vpb2/files/patch-vpbreg.cpp11
-rw-r--r--comms/vpb2/pkg-plist8
7 files changed, 78 insertions, 8 deletions
diff --git a/comms/vpb2/Makefile b/comms/vpb2/Makefile
index 3429ca6bf2a7..e2ef540276b1 100644
--- a/comms/vpb2/Makefile
+++ b/comms/vpb2/Makefile
@@ -1,4 +1,3 @@
-# Generated automatically from Makefile.in by configure.
# New ports collection makefile for: vpb2
# Date created: 07 Sept 2000
# Whom: David Sugar <dyfet@gnu.org>
@@ -14,18 +13,20 @@ MASTER_SITES= ftp://www.voxilla.org/pub/vpb/
MAINTAINER= dyfet@gnu.org
COMMENT= User mode API for Voicetronix 4 port analog DSP telephony cards
-BROKEN= "Installs file into /etc"
-
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_AUTOCONF= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib \
+ LDFLAGS=${PTHREAD_LIBS}
post-extract:
@${FIND} ${WRKSRC} -name "Makefile.in" | \
${XARGS} ${REINPLACE_CMD} -e 's|-release \$$\(LT_RELEASE\)||g'
+post-patch:
+ ${REINPLACE_CMD} -e "s|PREFIX|${PREFIX}|" ${WRKSRC}/vpbreg.cpp
+
.include <bsd.port.mk>
diff --git a/comms/vpb2/files/patch-Makefile.in b/comms/vpb2/files/patch-Makefile.in
new file mode 100644
index 000000000000..81bb55121ed3
--- /dev/null
+++ b/comms/vpb2/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Dec 28 11:51:29 2003
++++ Makefile.in Sun Dec 28 11:51:38 2003
+@@ -119,7 +119,7 @@
+ mtisa_SOURCES = mtisa.cpp
+ mtisa_LDADD = libvpb2.la
+
+-etc_prefix = /
++etc_prefix = $(prefix)
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
+ CONFIG_HEADER = config.h
diff --git a/comms/vpb2/files/patch-configure.in b/comms/vpb2/files/patch-configure.in
new file mode 100644
index 000000000000..4d339fefa10a
--- /dev/null
+++ b/comms/vpb2/files/patch-configure.in
@@ -0,0 +1,27 @@
+--- configure.in.orig Sun Dec 28 11:55:40 2003
++++ configure.in Sun Dec 28 11:55:52 2003
+@@ -23,24 +23,6 @@
+ OST_MAINTAINER_MODE
+ OST_CXX_PROGRAMMING
+
+-AC_CACHE_CHECK(whether ${CC-cc} accepts -pthread,
+- ost_cv_prog_cc_pthread,
+- [echo 'void f(){}' >conftest.c
+- if test -z "`${CC-cc} -pthread -c conftest.c 2>&1`"; then
+- ost_cv_prog_cc_pthread=yes
+- else
+- ost_cv_prog_cc_pthread=no
+- fi
+- rm -f conftest*
+- ])
+-if test $ost_cv_prog_cc_pthread = yes ; then
+- LIBS="$LIBS -pthread"
+-else
+- AC_CHECK_LIB(c_r, pthread_self,
+- LIBS="$LIBS -lc_r",
+- AC_CHECK_LIB(pthread, pthread_self,
+- LIBS="$LIBS -lpthread"))
+-fi
+
+ AC_SUBST(LT_RELEASE)
+ AC_OUTPUT(Makefile vpb2.spec freebsd/Makefile)
diff --git a/comms/vpb2/files/patch-genericfreebsd.cpp b/comms/vpb2/files/patch-genericfreebsd.cpp
new file mode 100644
index 000000000000..220dab63406f
--- /dev/null
+++ b/comms/vpb2/files/patch-genericfreebsd.cpp
@@ -0,0 +1,10 @@
+--- genericfreebsd.cpp.orig Sun Dec 28 10:54:45 2003
++++ genericfreebsd.cpp Sun Dec 28 10:55:01 2003
+@@ -28,6 +28,7 @@
+ \*---------------------------------------------------------------------------*/
+
+ #include "config.h"
++#include "contypes.h"
+
+ #include <assert.h>
+ #include <pthread.h>
diff --git a/comms/vpb2/files/patch-playrec.cpp b/comms/vpb2/files/patch-playrec.cpp
new file mode 100644
index 000000000000..8da7bf062cc3
--- /dev/null
+++ b/comms/vpb2/files/patch-playrec.cpp
@@ -0,0 +1,10 @@
+--- playrec.cpp.orig Sun Dec 28 10:53:19 2003
++++ playrec.cpp Sun Dec 28 10:53:25 2003
+@@ -41,7 +41,6 @@
+ #include "generic.h"
+
+ #include <assert.h>
+-#include <memory>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <fcntl.h>
diff --git a/comms/vpb2/files/patch-vpbreg.cpp b/comms/vpb2/files/patch-vpbreg.cpp
new file mode 100644
index 000000000000..d351fafd2b02
--- /dev/null
+++ b/comms/vpb2/files/patch-vpbreg.cpp
@@ -0,0 +1,11 @@
+--- vpbreg.cpp.orig Sun Dec 28 11:07:43 2003
++++ vpbreg.cpp Sun Dec 28 11:08:25 2003
+@@ -57,7 +57,7 @@
+
+ #define NUM_CARDS 1 // number of VPBs in PC
+ #define BASE 0x300 // ISA card base address
+-#define FIRMWARE_FILE "/etc/vpbmain.out"
++#define FIRMWARE_FILE "PREFIX/etc/vpbmain.out"
+
+ /*-------------------------------------------------------------------------*\
+
diff --git a/comms/vpb2/pkg-plist b/comms/vpb2/pkg-plist
index 8a84c7667a5e..7a1f7c32b854 100644
--- a/comms/vpb2/pkg-plist
+++ b/comms/vpb2/pkg-plist
@@ -1,8 +1,8 @@
+bin/mtisa
+bin/tload
+bin/tvpb
+etc/vpbmain.out
include/vpbapi.h
lib/libvpb2.a
lib/libvpb2.so
lib/libvpb2.so.0
-bin/tvpb
-bin/tload
-bin/mtisa
-