aboutsummaryrefslogtreecommitdiffstats
path: root/comms/wy60
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2011-11-20 00:57:09 +0800
committernaddy <naddy@FreeBSD.org>2011-11-20 00:57:09 +0800
commitb0f1a104be2c57d31aef8b24c55528b061d91301 (patch)
treee4faefbf8073dda409d3a18b6670dd85bf27565c /comms/wy60
parentb57f66ed5ac87a237a572fd31bee42986732bfcb (diff)
downloadfreebsd-ports-gnome-b0f1a104be2c57d31aef8b24c55528b061d91301.tar.gz
freebsd-ports-gnome-b0f1a104be2c57d31aef8b24c55528b061d91301.tar.zst
freebsd-ports-gnome-b0f1a104be2c57d31aef8b24c55528b061d91301.zip
* Minor update to 2.0.9.
* Copy sample to live rc file also when installing from ports. * Clean up port. Feature safe: yes
Diffstat (limited to 'comms/wy60')
-rw-r--r--comms/wy60/Makefile14
-rw-r--r--comms/wy60/distinfo4
-rw-r--r--comms/wy60/files/patch-Makefile.in14
-rw-r--r--comms/wy60/files/patch-wy60.c98
-rw-r--r--comms/wy60/pkg-descr2
5 files changed, 12 insertions, 120 deletions
diff --git a/comms/wy60/Makefile b/comms/wy60/Makefile
index 4497e5694746..130353c1a23e 100644
--- a/comms/wy60/Makefile
+++ b/comms/wy60/Makefile
@@ -5,12 +5,9 @@
# $FreeBSD$
PORTNAME= wy60
-PORTVERSION= 2.0.8
+PORTVERSION= 2.0.9
CATEGORIES= comms
-# MASTER_SITES= http://gutschke.com/wy60/html/archive/
-# issues a temporary redirect to insert a session ID into the URL
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= naddy
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= naddy@FreeBSD.org
COMMENT= Curses-based emulator for the Wyse 60 terminal
@@ -18,9 +15,16 @@ COMMENT= Curses-based emulator for the Wyse 60 terminal
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
+MAKE_ARGS= etc_DATA=wy60.rc.sample
+
MAN1= wy60.1
pre-build:
@${CP} ${WRKSRC}/wy60.rc ${WRKSRC}/wy60.rc.sample
+post-install:
+ if test ! -f ${PREFIX}/etc/wy60.rc; then \
+ ${CP} -p ${PREFIX}/etc/wy60.rc.sample ${PREFIX}/etc/wy60.rc; \
+ fi
+
.include <bsd.port.mk>
diff --git a/comms/wy60/distinfo b/comms/wy60/distinfo
index 795993dceba5..c53e68cc3236 100644
--- a/comms/wy60/distinfo
+++ b/comms/wy60/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wy60-2.0.8.tar.gz) = 2542436adc40926c009819546a329706ac53688cfb8ac9e0641496206e2b5283
-SIZE (wy60-2.0.8.tar.gz) = 130518
+SHA256 (wy60-2.0.9.tar.gz) = f7379404f0baf38faba48af7b05f9e0df65266ab75071b2ca56195b63fc05ed0
+SIZE (wy60-2.0.9.tar.gz) = 159764
diff --git a/comms/wy60/files/patch-Makefile.in b/comms/wy60/files/patch-Makefile.in
deleted file mode 100644
index a9cdf2044d80..000000000000
--- a/comms/wy60/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Sun Sep 8 02:02:57 2002
-+++ Makefile.in Sun Sep 8 02:03:19 2002
-@@ -68,7 +68,7 @@
- wy60_SOURCES = wy60.c wy60.h
- man_MANS = wy60.1
- etcdir = "$(sysconfdir)"
--etc_DATA = wy60.rc
-+etc_DATA = wy60.rc.sample
- EXTRA_DIST = wy60.rc wy60.man.in wy60.ps
- CPPFLAGS = -DETCDIR="\"$(sysconfdir)\""
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/comms/wy60/files/patch-wy60.c b/comms/wy60/files/patch-wy60.c
deleted file mode 100644
index dba1aa142dea..000000000000
--- a/comms/wy60/files/patch-wy60.c
+++ /dev/null
@@ -1,98 +0,0 @@
-
-$FreeBSD$
-
---- wy60.c.orig
-+++ wy60.c
-@@ -59,6 +59,17 @@
- } ScreenBuffer;
-
-
-+static void flushConsole(void);
-+static void gotoXYforce(int x, int y);
-+static void putCapability(const char *capability);
-+static int putConsole(int ch);
-+static void putGraphics(char ch);
-+static void showCursor(int flag);
-+static void updateAttributes(void);
-+static void failure(int exitCode, const char *message, ...);
-+static void processSignal(int signalNumber, int pid, int pty);
-+
-+
- static int euid, egid, uid, gid, oldStylePty, streamsIO, jobControl;
- static char ptyName[40];
- static struct termios defaultTermios;
-@@ -260,7 +271,6 @@
- logFd = -1;
- }
- if (logFd >= 0) {
-- static void flushConsole(void);
- int header[4];
-
- gettimeofday(&timeValue, 0);
-@@ -295,7 +305,6 @@
- }
-
- if (logFd >= 0) {
-- static void flushConsole(void);
- char buffer[80];
-
- if (isatty(logFd))
-@@ -369,8 +378,6 @@
-
- static void logDecodeFlush(void) {
- if (_decodeFd >= 0) {
-- static void flushConsole(void);
--
- if (isatty(_decodeFd))
- strcat(_decodeBuffer, "\x1B[39m");
- strcat(_decodeBuffer, "\r\n");
-@@ -2203,14 +2210,6 @@
-
-
- static void displayCurrentScreenBuffer(void) {
-- static void flushConsole(void);
-- static void gotoXYforce(int x, int y);
-- static void putCapability(const char *capability);
-- static int putConsole(int ch);
-- static void putGraphics(char ch);
-- static void showCursor(int flag);
-- static void updateAttributes(void);
--
- int x, y, lastAttributes = -1;
- int oldX = currentBuffer->cursorX;
- int oldY = currentBuffer->cursorY;
-@@ -2346,8 +2345,6 @@
-
-
- static void putCapability(const char *capability) {
-- static void failure(int exitCode, const char *message, ...);
--
- if (!capability || !strcmp(capability, "@"))
- failure(127, "Terminal has insufficient capabilities");
- logHostString(capability);
-@@ -2756,8 +2753,6 @@
-
-
- static void putGraphics(char ch) {
-- static void updateAttributes(void);
--
- if (ch == '\x02')
- graphicsMode = 1;
- else if (ch == '\x03')
-@@ -2839,7 +2834,6 @@
-
-
- static void executeExternalProgram(const char *argv[]) {
-- static void failure(int exitCode, const char *message, ...);
- int pid, status;
-
- if ((pid = fork()) < 0) {
-@@ -2886,8 +2880,6 @@
-
-
- static void requestNewGeometry(int pty, int width, int height) {
-- static void processSignal(int signalNumber, int pid, int pty);
--
- logDecode("setScreenSize(%d,%d)", width, height);
-
- if (screenWidth != width || screenHeight != height) {
diff --git a/comms/wy60/pkg-descr b/comms/wy60/pkg-descr
index 0d55a5cc5ad9..4f73bef05771 100644
--- a/comms/wy60/pkg-descr
+++ b/comms/wy60/pkg-descr
@@ -8,4 +8,4 @@ The current set of supported escape sequences is limited, but should
suffice to run many existing legacy applications without requiring
any changes.
-WWW: http://gutschke.com/wy60/
+WWW: http://code.google.com/p/wy60/