aboutsummaryrefslogtreecommitdiffstats
path: root/comms/zmtx-zmrx
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2011-07-23 08:33:57 +0800
committerdelphij <delphij@FreeBSD.org>2011-07-23 08:33:57 +0800
commit0949fa639fea45cc87896a75b36c1a15a826c05b (patch)
treef480de615090e3f10f33bbeadea469fb8aa04373 /comms/zmtx-zmrx
parent2e31385b60db0920d42c88eaaa8b6bcef295647e (diff)
downloadfreebsd-ports-gnome-0949fa639fea45cc87896a75b36c1a15a826c05b.tar.gz
freebsd-ports-gnome-0949fa639fea45cc87896a75b36c1a15a826c05b.tar.zst
freebsd-ports-gnome-0949fa639fea45cc87896a75b36c1a15a826c05b.zip
Fix build when CC=clang.
Diffstat (limited to 'comms/zmtx-zmrx')
-rw-r--r--comms/zmtx-zmrx/Makefile1
-rw-r--r--comms/zmtx-zmrx/files/patch-0211
-rw-r--r--comms/zmtx-zmrx/files/patch-makefile10
-rw-r--r--comms/zmtx-zmrx/files/patch-zmdm.c10
-rw-r--r--comms/zmtx-zmrx/files/patch-zmrx.c (renamed from comms/zmtx-zmrx/files/patch-01)18
-rw-r--r--comms/zmtx-zmrx/files/patch-zmtx.c37
6 files changed, 71 insertions, 16 deletions
diff --git a/comms/zmtx-zmrx/Makefile b/comms/zmtx-zmrx/Makefile
index b90577993076..b659f22a4321 100644
--- a/comms/zmtx-zmrx/Makefile
+++ b/comms/zmtx-zmrx/Makefile
@@ -19,6 +19,7 @@ MAKEFILE= makefile
MAKE_JOBS_SAFE= yes
MAN1= zmrx.1 zmtx.1
PLIST_FILES= bin/zmrx bin/zmtx
+USE_CSTD= gnu89
do-install:
.for f in zmrx zmtx
diff --git a/comms/zmtx-zmrx/files/patch-02 b/comms/zmtx-zmrx/files/patch-02
deleted file mode 100644
index f7bb18664359..000000000000
--- a/comms/zmtx-zmrx/files/patch-02
+++ /dev/null
@@ -1,11 +0,0 @@
---- zmtx.c.orig Sat Oct 19 08:53:36 1996
-+++ zmtx.c Sat Oct 19 08:53:14 1996
-@@ -65,7 +65,7 @@
-
- cps = ftell(fp) / duration;
-
-- fprintf(stderr,"zmtx: sending file \"%s\" %8ld bytes (%3d %%/%5d cps) \r",
-+ fprintf(stderr,"sending file \"%s\" %8ld bytes (%3d %%/%5d cps)\r",
- name,ftell(fp),percentage,cps);
- }
-
diff --git a/comms/zmtx-zmrx/files/patch-makefile b/comms/zmtx-zmrx/files/patch-makefile
new file mode 100644
index 000000000000..2c6fe30df235
--- /dev/null
+++ b/comms/zmtx-zmrx/files/patch-makefile
@@ -0,0 +1,10 @@
+--- ./makefile.orig 1996-12-11 23:24:07.000000000 -0800
++++ ./makefile 2011-07-22 17:33:29.953245477 -0700
+@@ -1,6 +1,5 @@
+-CC=gcc
+ #CFLAGS=-O -DUNITE
+-CFLAGS=-O -DSUNOS4
++CFLAGS+=-DSUNOS4
+
+ all: zmtx zmrx
+
diff --git a/comms/zmtx-zmrx/files/patch-zmdm.c b/comms/zmtx-zmrx/files/patch-zmdm.c
new file mode 100644
index 000000000000..730742ac3ef6
--- /dev/null
+++ b/comms/zmtx-zmrx/files/patch-zmdm.c
@@ -0,0 +1,10 @@
+--- ./zmdm.c.orig 1996-12-11 23:24:08.000000000 -0800
++++ ./zmdm.c 2011-07-22 17:33:19.603250928 -0700
+@@ -18,6 +18,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <termios.h>
+ #include <signal.h>
+ #ifdef UNITE
diff --git a/comms/zmtx-zmrx/files/patch-01 b/comms/zmtx-zmrx/files/patch-zmrx.c
index dd6d0d8799cc..392c88537979 100644
--- a/comms/zmtx-zmrx/files/patch-01
+++ b/comms/zmtx-zmrx/files/patch-zmrx.c
@@ -1,6 +1,14 @@
---- zmrx.c.orig Sun Oct 13 12:25:53 1996
-+++ zmrx.c Mon Oct 14 20:17:03 1996
-@@ -70,7 +70,7 @@
+--- ./zmrx.c.orig 1996-12-11 23:24:08.000000000 -0800
++++ ./zmrx.c 2011-07-22 17:33:19.603250928 -0700
+@@ -15,6 +15,7 @@
+
+ #include <ctype.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <string.h>
+@@ -70,7 +71,7 @@
cps = ftell(fp) / duration;
@@ -9,7 +17,7 @@
name,ftell(fp),percentage,cps);
}
-@@ -223,7 +223,7 @@
+@@ -223,7 +224,7 @@
}
if (opt_v) {
@@ -18,7 +26,7 @@
}
sscanf(rx_data_subpacket + strlen(rx_data_subpacket) + 1,
-@@ -342,7 +342,7 @@
+@@ -342,7 +343,7 @@
*/
if (opt_v) {
diff --git a/comms/zmtx-zmrx/files/patch-zmtx.c b/comms/zmtx-zmrx/files/patch-zmtx.c
new file mode 100644
index 000000000000..83e297641cef
--- /dev/null
+++ b/comms/zmtx-zmrx/files/patch-zmtx.c
@@ -0,0 +1,37 @@
+--- ./zmtx.c.orig 1996-12-11 23:24:08.000000000 -0800
++++ ./zmtx.c 2011-07-22 17:33:19.613253798 -0700
+@@ -15,6 +15,7 @@
+
+ #include <ctype.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <string.h>
+@@ -65,7 +66,7 @@
+
+ cps = ftell(fp) / duration;
+
+- fprintf(stderr,"zmtx: sending file \"%s\" %8ld bytes (%3d %%/%5d cps) \r",
++ fprintf(stderr,"sending file \"%s\" %8ld bytes (%3d %%/%5d cps)\r",
+ name,ftell(fp),percentage,cps);
+ }
+
+@@ -201,7 +202,7 @@
+ if (opt_v) {
+ fprintf(stderr,"zmtx: can't open file %s\n",name);
+ }
+- return;
++ return FALSE;
+ }
+
+ fstat(fileno(fp),&s);
+@@ -357,7 +358,7 @@
+ if (opt_v) {
+ fprintf(stderr,"zmtx: skipped file \"%s\" \n",name);
+ }
+- return;
++ return FALSE;
+ }
+
+ } while (type != ZRPOS);