aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-01-25 02:10:14 +0800
committerrakuco <rakuco@FreeBSD.org>2016-01-25 02:10:14 +0800
commit168c09d7ac04fe1367cf358d9ef4b866358da769 (patch)
tree66663b28c2c298161be86b00114ab18d6fad8670 /comms
parentd6f5862ed14a358ca5995e92368a7a4c2c6cf2a4 (diff)
downloadfreebsd-ports-gnome-168c09d7ac04fe1367cf358d9ef4b866358da769.tar.gz
freebsd-ports-gnome-168c09d7ac04fe1367cf358d9ef4b866358da769.tar.zst
freebsd-ports-gnome-168c09d7ac04fe1367cf358d9ef4b866358da769.zip
Update Qt5 to 5.5.1.
This is the latest stable release at time of writing. Release announcement: http://blog.qt.io/blog/2015/07/01/qt-5-5-released/ New features in Qt 5.5: https://wiki.qt.io/New_Features_in_Qt_5.5 As usual, huge thanks to Tobias Berner (tcberner@gmail.com) for all his work on these ports in kde@'s experimental area51 repository. He's the one who started the update and did a lot of the initial work on Qt 5.5. Ralf Nolden (nolden@kde.org) has contributed the initial version of most of our new Qt5 ports. Also thanks to Yuri Victorovich (yuri@rawbw.com) for contributing PR 205805 with his own patch for the 5.5.1 update. Some of his changes there prompted additional fixes and changes present in the final patch generated from our experimental repository. New ports: - comms/qt5-connectivity, comms/qt5-sensors, devel/qt5-location, graphics/qt5-3d, net/qt5-enginio, x11-toolkits/qt5-canvas3d, x11-toolkits/qt5-uiplugin. General changes in all Qt5 ports: - All Qt5 ports are now built with -Wl,--as-needed to avoid overlinking, which is a problem with qmake-based because the libraries passed to the linker come from the modules .pri files and many are not necessary. - With this change, several ports had their USE_QT5 lines adjusted to explicitly include some libraries that were pulled in implicitly, and to exclude libraries no longer required with -Wl,--as-needed. Changes in specific ports: - devel/qt5: Drop the SQL_PLUGINS and TOOLS options and depend on all Qt5 ports by default. It makes the Makefile much simpler, and those options were already on by default. - devel/qt5-core: The clang+base libstdc++ workaround has been expanded and more C++11 features have been disabled when that combination is used by a port (basically, FreeBSD 9 with USES=compiler:c++11-lang). The disabled features have explanations for why they were disabled in the patched header itself. - devel/qt5-designer: uiplugins has been split out following a similar change upstream. By depending on qt5-uiplugin, qt5-uitools avoids having to depend on the big qt5-designer port. - multimedia/qt5-multimedia: The port now uses GStreamer 1.0 instead of 0.10. - net/qt5-network: The port now depends on libproxy for proxy settings. Using libproxy allows proxy settings to be read from different sources, and also allows .pac files to work with Qt. - www/qt5-webkit: The port now uses GStreamer 1.0 instead of 0.10. PR: 205805 PR: 206435
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile2
-rw-r--r--comms/qt5-connectivity/Makefile17
-rw-r--r--comms/qt5-connectivity/pkg-plist208
-rw-r--r--comms/qt5-sensors/Makefile17
-rw-r--r--comms/qt5-sensors/pkg-plist140
-rw-r--r--comms/qt5-serialport/pkg-plist12
6 files changed, 384 insertions, 12 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 31ee133e4c2a..20e939993c35 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -141,6 +141,8 @@
SUBDIR += qico
SUBDIR += qrq
SUBDIR += qsstv
+ SUBDIR += qt5-connectivity
+ SUBDIR += qt5-sensors
SUBDIR += qt5-serialport
SUBDIR += qtel
SUBDIR += quisk
diff --git a/comms/qt5-connectivity/Makefile b/comms/qt5-connectivity/Makefile
new file mode 100644
index 000000000000..c504ea587f2c
--- /dev/null
+++ b/comms/qt5-connectivity/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= connectivity
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= comms
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt connectivity (Bluetooth/NFC) module
+
+USE_QT5= concurrent core qml quick buildtools_build
+QT_DIST= ${PORTNAME}
+USES= qmake
+
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+.include <bsd.port.mk>
diff --git a/comms/qt5-connectivity/pkg-plist b/comms/qt5-connectivity/pkg-plist
new file mode 100644
index 000000000000..a17a9dd25e26
--- /dev/null
+++ b/comms/qt5-connectivity/pkg-plist
@@ -0,0 +1,208 @@
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/adapter1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/adapter_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/agent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/androidbroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/bluez5_helper_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/bluez_data_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/corebluetoothwrapper_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/device1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/device_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/devicediscoverybroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/hcimanager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/inputstreamthread_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/jni_android_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/localdevicebroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/lowenergynotificationhub_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/manager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_agent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_client1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_client_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_manager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_objectpush1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_transfer1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_transfer_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/objectmanager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtcentralmanager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtchanneldelegate_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtconnectionmonitor_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtdeviceinquiry_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtdevicepair_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtl2capchannel_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtledeviceinquiry_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtobexsession_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtrfcommchannel_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtsdpinquiry_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtservicerecord_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtsocketlistener_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtutility_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/ppshelpers_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/profile1_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/properties_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothaddress_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdevicediscoveryagent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdevicediscoverytimer_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdeviceinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothhostinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothlocaldevice_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserver_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothservicediscoveryagent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserviceinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothsocket_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothsocket_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_bluez_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_qnx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferrequest_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergycontroller_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergycontroller_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergyserviceprivate_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qprivatelinearbuffer_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/serveracceptancethread_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/service_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/servicediscoverybroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/servicemap_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/uistrings_p.h
+%%QT_INCDIR%%/QtBluetooth/QBluetoothAddress
+%%QT_INCDIR%%/QtBluetooth/QBluetoothDeviceDiscoveryAgent
+%%QT_INCDIR%%/QtBluetooth/QBluetoothDeviceInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothHostInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothLocalDevice
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServer
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServiceDiscoveryAgent
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServiceInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothSocket
+%%QT_INCDIR%%/QtBluetooth/QBluetoothTransferManager
+%%QT_INCDIR%%/QtBluetooth/QBluetoothTransferReply
+%%QT_INCDIR%%/QtBluetooth/QBluetoothTransferRequest
+%%QT_INCDIR%%/QtBluetooth/QBluetoothUuid
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyCharacteristic
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyController
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyDescriptor
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyHandle
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyService
+%%QT_INCDIR%%/QtBluetooth/QtBluetooth
+%%QT_INCDIR%%/QtBluetooth/QtBluetoothDepends
+%%QT_INCDIR%%/QtBluetooth/QtBluetoothVersion
+%%QT_INCDIR%%/QtBluetooth/qbluetooth.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothaddress.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothdevicediscoveryagent.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothdeviceinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothglobal.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothhostinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothlocaldevice.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothserver.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothservicediscoveryagent.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothserviceinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothsocket.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothtransfermanager.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothtransferreply.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothtransferrequest.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothuuid.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergycharacteristic.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergycontroller.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergydescriptor.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergyservice.h
+%%QT_INCDIR%%/QtBluetooth/qtbluetoothversion.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/adapter_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/agent_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/dbusobjectmanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/dbusproperties_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/manager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/neard_helper_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_p_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_simulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_p_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_simulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qndefnfcsmartposterrecord_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qndefrecord_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_emulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_neard_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_simulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanagerimpl_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanagervirtualbase_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharemanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharemanager_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharemanagerimpl_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharetarget_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharetarget_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharetargetimpl_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype1_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype2_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype3_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype4_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_emulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_neard_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnxnfceventfilter_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnxnfcmanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnxnfcsharemanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qtlv_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/tag_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/targetemulator_p.h
+%%QT_INCDIR%%/QtNfc/QNdefFilter
+%%QT_INCDIR%%/QtNfc/QNdefMessage
+%%QT_INCDIR%%/QtNfc/QNdefNfcIconRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcSmartPosterRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcTextRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcUriRecord
+%%QT_INCDIR%%/QtNfc/QNdefRecord
+%%QT_INCDIR%%/QtNfc/QNearFieldManager
+%%QT_INCDIR%%/QtNfc/QNearFieldShareManager
+%%QT_INCDIR%%/QtNfc/QNearFieldShareTarget
+%%QT_INCDIR%%/QtNfc/QNearFieldTarget
+%%QT_INCDIR%%/QtNfc/QQmlNdefRecord
+%%QT_INCDIR%%/QtNfc/QtNfc
+%%QT_INCDIR%%/QtNfc/QtNfcDepends
+%%QT_INCDIR%%/QtNfc/QtNfcVersion
+%%QT_INCDIR%%/QtNfc/qndeffilter.h
+%%QT_INCDIR%%/QtNfc/qndefmessage.h
+%%QT_INCDIR%%/QtNfc/qndefnfcsmartposterrecord.h
+%%QT_INCDIR%%/QtNfc/qndefnfctextrecord.h
+%%QT_INCDIR%%/QtNfc/qndefnfcurirecord.h
+%%QT_INCDIR%%/QtNfc/qndefrecord.h
+%%QT_INCDIR%%/QtNfc/qnearfieldmanager.h
+%%QT_INCDIR%%/QtNfc/qnearfieldsharemanager.h
+%%QT_INCDIR%%/QtNfc/qnearfieldsharetarget.h
+%%QT_INCDIR%%/QtNfc/qnearfieldtarget.h
+%%QT_INCDIR%%/QtNfc/qnfcglobal.h
+%%QT_INCDIR%%/QtNfc/qqmlndefrecord.h
+%%QT_INCDIR%%/QtNfc/qtnfcversion.h
+%%QT_LIBDIR%%/cmake/Qt5Bluetooth/Qt5BluetoothConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5Bluetooth/Qt5BluetoothConfigVersion.cmake
+%%QT_LIBDIR%%/cmake/Qt5Nfc/Qt5NfcConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5Nfc/Qt5NfcConfigVersion.cmake
+%%QT_LIBDIR%%/libQt5Bluetooth.prl
+%%QT_LIBDIR%%/libQt5Bluetooth.so
+%%QT_LIBDIR%%/libQt5Bluetooth.so.5
+%%QT_LIBDIR%%/libQt5Bluetooth.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5Bluetooth.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5Bluetooth.so.%%FULLVER%%.debug
+%%QT_LIBDIR%%/libQt5Nfc.prl
+%%QT_LIBDIR%%/libQt5Nfc.so
+%%QT_LIBDIR%%/libQt5Nfc.so.5
+%%QT_LIBDIR%%/libQt5Nfc.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5Nfc.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5Nfc.so.%%FULLVER%%.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_bluetooth.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_bluetooth_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_nfc.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_nfc_private.pri
+%%QT_QMLDIR%%/QtBluetooth/libdeclarative_bluetooth.so
+%%DEBUG%%%%QT_QMLDIR%%/QtBluetooth/libdeclarative_bluetooth.so.debug
+%%QT_QMLDIR%%/QtBluetooth/plugins.qmltypes
+%%QT_QMLDIR%%/QtBluetooth/qmldir
+%%QT_QMLDIR%%/QtNfc/libdeclarative_nfc.so
+%%DEBUG%%%%QT_QMLDIR%%/QtNfc/libdeclarative_nfc.so.debug
+%%QT_QMLDIR%%/QtNfc/plugins.qmltypes
+%%QT_QMLDIR%%/QtNfc/qmldir
+libdata/pkgconfig/Qt5Bluetooth.pc
+libdata/pkgconfig/Qt5Nfc.pc
diff --git a/comms/qt5-sensors/Makefile b/comms/qt5-sensors/Makefile
new file mode 100644
index 000000000000..27749bc7d9f5
--- /dev/null
+++ b/comms/qt5-sensors/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= sensors
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= comms
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt sensors module
+
+USE_QT5= core qml quick buildtools_build
+QT_DIST= ${PORTNAME}
+USES= qmake
+
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+.include <bsd.port.mk>
diff --git a/comms/qt5-sensors/pkg-plist b/comms/qt5-sensors/pkg-plist
new file mode 100644
index 000000000000..dd476871a332
--- /dev/null
+++ b/comms/qt5-sensors/pkg-plist
@@ -0,0 +1,140 @@
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qaccelerometer_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qaltimeter_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qambientlightsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qambienttemperaturesensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qcompass_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qdistancesensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qgyroscope_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qholstersensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qirproximitysensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qlightsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qmagnetometer_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qorientationsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qpressuresensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qproximitysensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qrotationsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensorbackend_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensorgesture_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qsensorgesturemanagerprivate_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qtapsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/qtiltsensor_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/sensorlog_p.h
+%%QT_INCDIR%%/QtSensors/%%FULLVER%%/QtSensors/private/simulatorgesturescommon_p.h
+%%QT_INCDIR%%/QtSensors/QAccelerometer
+%%QT_INCDIR%%/QtSensors/QAccelerometerFilter
+%%QT_INCDIR%%/QtSensors/QAccelerometerReading
+%%QT_INCDIR%%/QtSensors/QAltimeter
+%%QT_INCDIR%%/QtSensors/QAltimeterFilter
+%%QT_INCDIR%%/QtSensors/QAltimeterReading
+%%QT_INCDIR%%/QtSensors/QAmbientLightFilter
+%%QT_INCDIR%%/QtSensors/QAmbientLightReading
+%%QT_INCDIR%%/QtSensors/QAmbientLightSensor
+%%QT_INCDIR%%/QtSensors/QAmbientTemperatureFilter
+%%QT_INCDIR%%/QtSensors/QAmbientTemperatureReading
+%%QT_INCDIR%%/QtSensors/QAmbientTemperatureSensor
+%%QT_INCDIR%%/QtSensors/QCompass
+%%QT_INCDIR%%/QtSensors/QCompassFilter
+%%QT_INCDIR%%/QtSensors/QCompassReading
+%%QT_INCDIR%%/QtSensors/QDistanceFilter
+%%QT_INCDIR%%/QtSensors/QDistanceReading
+%%QT_INCDIR%%/QtSensors/QDistanceSensor
+%%QT_INCDIR%%/QtSensors/QGyroscope
+%%QT_INCDIR%%/QtSensors/QGyroscopeFilter
+%%QT_INCDIR%%/QtSensors/QGyroscopeReading
+%%QT_INCDIR%%/QtSensors/QHolsterFilter
+%%QT_INCDIR%%/QtSensors/QHolsterReading
+%%QT_INCDIR%%/QtSensors/QHolsterSensor
+%%QT_INCDIR%%/QtSensors/QIRProximityFilter
+%%QT_INCDIR%%/QtSensors/QIRProximityReading
+%%QT_INCDIR%%/QtSensors/QIRProximitySensor
+%%QT_INCDIR%%/QtSensors/QLightFilter
+%%QT_INCDIR%%/QtSensors/QLightReading
+%%QT_INCDIR%%/QtSensors/QLightSensor
+%%QT_INCDIR%%/QtSensors/QMagnetometer
+%%QT_INCDIR%%/QtSensors/QMagnetometerFilter
+%%QT_INCDIR%%/QtSensors/QMagnetometerReading
+%%QT_INCDIR%%/QtSensors/QOrientationFilter
+%%QT_INCDIR%%/QtSensors/QOrientationReading
+%%QT_INCDIR%%/QtSensors/QOrientationSensor
+%%QT_INCDIR%%/QtSensors/QPressureFilter
+%%QT_INCDIR%%/QtSensors/QPressureReading
+%%QT_INCDIR%%/QtSensors/QPressureSensor
+%%QT_INCDIR%%/QtSensors/QProximityFilter
+%%QT_INCDIR%%/QtSensors/QProximityReading
+%%QT_INCDIR%%/QtSensors/QProximitySensor
+%%QT_INCDIR%%/QtSensors/QRotationFilter
+%%QT_INCDIR%%/QtSensors/QRotationReading
+%%QT_INCDIR%%/QtSensors/QRotationSensor
+%%QT_INCDIR%%/QtSensors/QSensor
+%%QT_INCDIR%%/QtSensors/QSensorBackend
+%%QT_INCDIR%%/QtSensors/QSensorBackendFactory
+%%QT_INCDIR%%/QtSensors/QSensorChangesInterface
+%%QT_INCDIR%%/QtSensors/QSensorFilter
+%%QT_INCDIR%%/QtSensors/QSensorGesture
+%%QT_INCDIR%%/QtSensors/QSensorGestureManager
+%%QT_INCDIR%%/QtSensors/QSensorGesturePluginInterface
+%%QT_INCDIR%%/QtSensors/QSensorGestureRecognizer
+%%QT_INCDIR%%/QtSensors/QSensorManager
+%%QT_INCDIR%%/QtSensors/QSensorPluginInterface
+%%QT_INCDIR%%/QtSensors/QSensorReading
+%%QT_INCDIR%%/QtSensors/QTapFilter
+%%QT_INCDIR%%/QtSensors/QTapReading
+%%QT_INCDIR%%/QtSensors/QTapSensor
+%%QT_INCDIR%%/QtSensors/QTiltFilter
+%%QT_INCDIR%%/QtSensors/QTiltReading
+%%QT_INCDIR%%/QtSensors/QTiltSensor
+%%QT_INCDIR%%/QtSensors/QtSensors
+%%QT_INCDIR%%/QtSensors/QtSensorsDepends
+%%QT_INCDIR%%/QtSensors/QtSensorsVersion
+%%QT_INCDIR%%/QtSensors/qaccelerometer.h
+%%QT_INCDIR%%/QtSensors/qaltimeter.h
+%%QT_INCDIR%%/QtSensors/qambientlightsensor.h
+%%QT_INCDIR%%/QtSensors/qambienttemperaturesensor.h
+%%QT_INCDIR%%/QtSensors/qcompass.h
+%%QT_INCDIR%%/QtSensors/qdistancesensor.h
+%%QT_INCDIR%%/QtSensors/qgyroscope.h
+%%QT_INCDIR%%/QtSensors/qholstersensor.h
+%%QT_INCDIR%%/QtSensors/qirproximitysensor.h
+%%QT_INCDIR%%/QtSensors/qlightsensor.h
+%%QT_INCDIR%%/QtSensors/qmagnetometer.h
+%%QT_INCDIR%%/QtSensors/qorientationsensor.h
+%%QT_INCDIR%%/QtSensors/qpressuresensor.h
+%%QT_INCDIR%%/QtSensors/qproximitysensor.h
+%%QT_INCDIR%%/QtSensors/qrotationsensor.h
+%%QT_INCDIR%%/QtSensors/qsensor.h
+%%QT_INCDIR%%/QtSensors/qsensorbackend.h
+%%QT_INCDIR%%/QtSensors/qsensorgesture.h
+%%QT_INCDIR%%/QtSensors/qsensorgesturemanager.h
+%%QT_INCDIR%%/QtSensors/qsensorgestureplugininterface.h
+%%QT_INCDIR%%/QtSensors/qsensorgesturerecognizer.h
+%%QT_INCDIR%%/QtSensors/qsensormanager.h
+%%QT_INCDIR%%/QtSensors/qsensorplugin.h
+%%QT_INCDIR%%/QtSensors/qsensorsglobal.h
+%%QT_INCDIR%%/QtSensors/qtapsensor.h
+%%QT_INCDIR%%/QtSensors/qtiltsensor.h
+%%QT_INCDIR%%/QtSensors/qtsensorsversion.h
+%%QT_LIBDIR%%/cmake/Qt5Sensors/Qt5SensorsConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5Sensors/Qt5SensorsConfigVersion.cmake
+%%QT_LIBDIR%%/cmake/Qt5Sensors/Qt5Sensors_QShakeSensorGesturePlugin.cmake
+%%QT_LIBDIR%%/cmake/Qt5Sensors/Qt5Sensors_QtSensorGesturePlugin.cmake
+%%QT_LIBDIR%%/cmake/Qt5Sensors/Qt5Sensors_genericSensorPlugin.cmake
+%%QT_LIBDIR%%/libQt5Sensors.prl
+%%QT_LIBDIR%%/libQt5Sensors.so
+%%QT_LIBDIR%%/libQt5Sensors.so.5
+%%QT_LIBDIR%%/libQt5Sensors.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5Sensors.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5Sensors.so.%%FULLVER%%.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_sensors.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_sensors_private.pri
+%%QT_PLUGINDIR%%/sensorgestures/libqtsensorgestures_plugin.so
+%%DEBUG%%%%QT_PLUGINDIR%%/sensorgestures/libqtsensorgestures_plugin.so.debug
+%%QT_PLUGINDIR%%/sensorgestures/libqtsensorgestures_shakeplugin.so
+%%DEBUG%%%%QT_PLUGINDIR%%/sensorgestures/libqtsensorgestures_shakeplugin.so.debug
+%%QT_PLUGINDIR%%/sensors/libqtsensors_generic.so
+%%DEBUG%%%%QT_PLUGINDIR%%/sensors/libqtsensors_generic.so.debug
+%%QT_QMLDIR%%/QtSensors/libdeclarative_sensors.so
+%%DEBUG%%%%QT_QMLDIR%%/QtSensors/libdeclarative_sensors.so.debug
+%%QT_QMLDIR%%/QtSensors/plugins.qmltypes
+%%QT_QMLDIR%%/QtSensors/qmldir
+libdata/pkgconfig/Qt5Sensors.pc
diff --git a/comms/qt5-serialport/pkg-plist b/comms/qt5-serialport/pkg-plist
index 012924fd00c1..1b444990cb18 100644
--- a/comms/qt5-serialport/pkg-plist
+++ b/comms/qt5-serialport/pkg-plist
@@ -1,27 +1,15 @@
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qcore_mac_p.h
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qcore_unix_p.h
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qlockfile_p.h
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qringbuffer_p.h
%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialport_p.h
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialport_symbian_p.h
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialport_unix_p.h
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialport_win_p.h
-%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialport_wince_p.h
%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialportinfo_p.h
%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qtudev_p.h
-%%QT_INCDIR%%/QtSerialPort/QLockFile
%%QT_INCDIR%%/QtSerialPort/QSerialPort
%%QT_INCDIR%%/QtSerialPort/QSerialPortInfo
-%%QT_INCDIR%%/QtSerialPort/QWinEventNotifier
%%QT_INCDIR%%/QtSerialPort/QtSerialPort
%%QT_INCDIR%%/QtSerialPort/QtSerialPortDepends
%%QT_INCDIR%%/QtSerialPort/QtSerialPortVersion
-%%QT_INCDIR%%/QtSerialPort/qlockfile.h
%%QT_INCDIR%%/QtSerialPort/qserialport.h
%%QT_INCDIR%%/QtSerialPort/qserialportglobal.h
%%QT_INCDIR%%/QtSerialPort/qserialportinfo.h
%%QT_INCDIR%%/QtSerialPort/qtserialportversion.h
-%%QT_INCDIR%%/QtSerialPort/qwineventnotifier.h
%%QT_LIBDIR%%/cmake/Qt5SerialPort/Qt5SerialPortConfig.cmake
%%QT_LIBDIR%%/cmake/Qt5SerialPort/Qt5SerialPortConfigVersion.cmake
%%QT_LIBDIR%%/libQt5SerialPort.prl