aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2007-12-19 03:07:40 +0800
committerdb <db@FreeBSD.org>2007-12-19 03:07:40 +0800
commit549ae814b710c28cebb4db935e2c064e8022f061 (patch)
treec2d240d6f899b3bf5aa61529b4599961119febec /comms
parent3d2571e528fccb58f27aa45bc21a53329e531edb (diff)
downloadfreebsd-ports-gnome-549ae814b710c28cebb4db935e2c064e8022f061.tar.gz
freebsd-ports-gnome-549ae814b710c28cebb4db935e2c064e8022f061.tar.zst
freebsd-ports-gnome-549ae814b710c28cebb4db935e2c064e8022f061.zip
- When reading an ADIF log, in which the frequency is given (instead of
the band), the conversion of this frequency to a band fails in some cases, when the locale settings define anything different than a '.' as decimal separator (e.g. LANG=de_DE, where it is ','). further description at: http://people.freebsd.org/~db/tqsllib_bug.txt Submitted by: Fabian Kurz <mail@fkurz.net>
Diffstat (limited to 'comms')
-rw-r--r--comms/trustedqsl/Makefile2
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp18
2 files changed, 19 insertions, 1 deletions
diff --git a/comms/trustedqsl/Makefile b/comms/trustedqsl/Makefile
index ae46ea036a94..27fed4ea0451 100644
--- a/comms/trustedqsl/Makefile
+++ b/comms/trustedqsl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trustedqsl
PORTVERSION= 1.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= trustedqsl
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp b/comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp
new file mode 100644
index 000000000000..c07b0b4d029a
--- /dev/null
+++ b/comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp
@@ -0,0 +1,18 @@
+--- tqsllib-2.0/tqslconvert.cpp.orig 2007-12-18 08:39:49.000000000 -0500
++++ tqsllib-2.0/tqslconvert.cpp 2007-12-18 08:42:31.000000000 -0500
+@@ -23,6 +23,7 @@
+ #include <string>
+ #include <ctype.h>
+ #include <set>
++#include <locale.h>
+
+ //#include <iostream>
+
+@@ -264,6 +265,7 @@
+
+ static const char *
+ tqsl_infer_band(const char* infreq) {
++ setlocale(LC_NUMERIC, "C");
+ double freq = atof(infreq);
+ double freq_khz = freq * 1000.0;
+ int nband = 0;