aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorshurd <shurd@FreeBSD.org>2015-01-12 09:16:52 +0800
committershurd <shurd@FreeBSD.org>2015-01-12 09:16:52 +0800
commitf97e5bdfbdba23b739cc87e679fa3cb796664586 (patch)
treea43612496e759aef0aaa7d51b0fd6a03d34da3dd /comms
parented33cd14d2bb53164a2cb08ea7f9cab920e429b2 (diff)
downloadfreebsd-ports-gnome-f97e5bdfbdba23b739cc87e679fa3cb796664586.tar.gz
freebsd-ports-gnome-f97e5bdfbdba23b739cc87e679fa3cb796664586.tar.zst
freebsd-ports-gnome-f97e5bdfbdba23b739cc87e679fa3cb796664586.zip
Fix waterfall display (was previously disabled by the patch).
Diffstat (limited to 'comms')
-rw-r--r--comms/wsjt/Makefile2
-rw-r--r--comms/wsjt/files/patch-WsjtMod_specjt.py23
2 files changed, 21 insertions, 4 deletions
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index 86315f1e32d0..70e532dc8537 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wsjt
VERSION= 9.1
-PORTREVISION= 8
+PORTREVISION= 9
DISTVERSION= ${VERSION}.r${SVN_REV}
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_LOCAL}
diff --git a/comms/wsjt/files/patch-WsjtMod_specjt.py b/comms/wsjt/files/patch-WsjtMod_specjt.py
index 6304ea084cde..b2466f35832c 100644
--- a/comms/wsjt/files/patch-WsjtMod_specjt.py
+++ b/comms/wsjt/files/patch-WsjtMod_specjt.py
@@ -1,5 +1,5 @@
---- WsjtMod/specjt.py.orig 2011-09-13 15:56:59.000000000 -0400
-+++ WsjtMod/specjt.py 2014-12-15 21:26:06.000000000 -0500
+--- WsjtMod/specjt.py.orig 2011-09-13 12:56:59.000000000 -0700
++++ WsjtMod/specjt.py 2015-01-09 04:04:37.000000000 -0800
@@ -11,13 +11,9 @@
import cPickle
import tkMessageBox
@@ -22,7 +22,24 @@
c=Canvas()
-a=zeros(225000,'s')
-+##a=zeros(225000,'s')
++a=zeros(225000,'uint16')
im=Image.new('P',(750,300))
line0=Image.new('P',(750,1)) #Image fragment for top line of waterfall
draw=ImageDraw.Draw(im)
+@@ -330,11 +326,14 @@
+ except:
+ print "Images did not match, continuing anyway."
+ for i in range(n):
+- line0.putdata(a[750*i:750*(i+1)]) #One row of pixels to line0
++ for j in range(0, 749):
++ line0.putpixel((j,0), a[750*i+j])
+ im.paste(line0,(0,i)) #Paste in new top line
+ nscroll=nscroll+n
+ else: #A scale factor has changed
+- im.putdata(a) #Compute whole new image
++ for i in range(0, 300):
++ for j in range(0, 749):
++ im.putpixel((j,i), a[750*i+j])
+ b0=brightness #Save scale values
+ c0=contrast
+ logm0=logm