aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-25 02:27:23 +0800
committermiwi <miwi@FreeBSD.org>2009-03-25 02:27:23 +0800
commit0a48c27f4946229ac0b1e39af07a39b91b7bca19 (patch)
tree10ad21ac5c5445bc87c4d33e2366e8c82ac83723 /comms
parent925d3839359c95e297e39468cc2d38d9f015771a (diff)
downloadfreebsd-ports-gnome-0a48c27f4946229ac0b1e39af07a39b91b7bca19.tar.gz
freebsd-ports-gnome-0a48c27f4946229ac0b1e39af07a39b91b7bca19.tar.zst
freebsd-ports-gnome-0a48c27f4946229ac0b1e39af07a39b91b7bca19.zip
2009-03-22 comms/plp: unmaintained, does not work with current versions of GCC, needs gcc295 which has been failing to build for months
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/plp/Makefile36
-rw-r--r--comms/plp/distinfo3
-rw-r--r--comms/plp/files/patch-aa20
-rw-r--r--comms/plp/files/patch-ab11
-rw-r--r--comms/plp/files/patch-ac15
-rw-r--r--comms/plp/files/patch-ad20
-rw-r--r--comms/plp/files/patch-ae21
-rw-r--r--comms/plp/files/patch-af11
-rw-r--r--comms/plp/files/patch-ag11
-rw-r--r--comms/plp/pkg-descr16
11 files changed, 0 insertions, 165 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 151de7fb4c1b..abcaf253ef06 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -98,7 +98,6 @@
SUBDIR += p5-SMS-Send-TW-ShareSMS
SUBDIR += p5-SMS-Send-TW-emome
SUBDIR += picocom
- SUBDIR += plp
SUBDIR += pr
SUBDIR += predict
SUBDIR += py-bulksms
diff --git a/comms/plp/Makefile b/comms/plp/Makefile
deleted file mode 100644
index 344c972539cf..000000000000
--- a/comms/plp/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: Psion Link Protocol
-# Date created: Tue Nov 30 15:43:27 EST 1999
-# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
-#
-# $FreeBSD$
-#
-
-PORTNAME= plp
-PORTVERSION= 1.8
-PORTREVISION= 1
-CATEGORIES= comms
-MASTER_SITES= http://www.proudman51.freeserve.co.uk/psion/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= kris
-DISTNAME= ${PORTNAME}_1_8
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Transfer data between a Psion Series 5(mx) and Unix
-
-DEPRECATED= unmaintained, does not work with current versions of GCC, needs gcc295 which has been failing to build for months
-EXPIRATION_DATE=2009-03-22
-
-USE_GMAKE= yes
-USE_GCC= 2.95
-
-PLIST_FILES= bin/ncp bin/rfsv
-
-pre-patch:
-.for files in packet.cc socketchan.cc
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/ncp/${files}
-.endfor
-
-do-install:
- cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PLIST_FILES} ${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/comms/plp/distinfo b/comms/plp/distinfo
deleted file mode 100644
index bf022ae56b2d..000000000000
--- a/comms/plp/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (plp_1_8.tar.gz) = 63c0871eb0504c69677c8e16f2d43ea2
-SHA256 (plp_1_8.tar.gz) = dd8524ff34ad9131d319d854f75c07cf4c995675658ad08f7a6123e7cff88785
-SIZE (plp_1_8.tar.gz) = 58424
diff --git a/comms/plp/files/patch-aa b/comms/plp/files/patch-aa
deleted file mode 100644
index 8451acb0fb84..000000000000
--- a/comms/plp/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- ncp/mp_serial.c.orig Tue Nov 2 12:47:06 1999
-+++ ncp/mp_serial.c Wed Jan 26 20:44:56 2000
-@@ -192,7 +192,7 @@
- #if defined(hpux) || defined(_IBMR2)
- ti.c_cflag = CS8 | HUPCL | clocal | CREAD;
- #endif
--#if defined(sun) || defined(linux) || defined(__sgi) || defined(__NetBSD__)
-+#if defined(sun) || defined(linux) || defined(__sgi) || defined(__NetBSD__) || defined(__FreeBSD__)
- ti.c_cflag = CS8 | HUPCL | clocal | CRTSCTS | CREAD;
- ti.c_iflag = IGNBRK | IGNPAR;
- ti.c_cc[VMIN] = 1;
-@@ -223,7 +223,7 @@
- void ser_exit(int fd)
- {
- struct termios ti;
-- if(ioctl(fd, TCGETS, (caddr_t)&ti) < 0) {
-+ if(tcgetattr(fd, &ti) < 0) {
- perror("TCGETSW");
- }
- ti.c_cflag &= ~CRTSCTS;
diff --git a/comms/plp/files/patch-ab b/comms/plp/files/patch-ab
deleted file mode 100644
index da953e579453..000000000000
--- a/comms/plp/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- defaults.h.orig Tue Nov 2 12:51:01 1999
-+++ defaults.h Wed Jan 26 20:44:56 2000
-@@ -19,7 +19,7 @@
-
- // This is the default device driver for the serial link
- // N.B. This was "/dev/cua1" in the previous release
--#define DEFAULT_SERIAL_DEVICE "/dev/ttyS1"
-+#define DEFAULT_SERIAL_DEVICE "/dev/psion"
-
- // This is the default drive to use on the psion
- #define DEFAULT_DRIVE "C:\\"
diff --git a/comms/plp/files/patch-ac b/comms/plp/files/patch-ac
deleted file mode 100644
index 0a9ecdbaf532..000000000000
--- a/comms/plp/files/patch-ac
+++ /dev/null
@@ -1,15 +0,0 @@
---- utils/ppsocket.cc.orig Wed Jan 26 20:45:31 2000
-+++ utils/ppsocket.cc Wed Jan 26 20:45:54 2000
-@@ -198,7 +198,11 @@
-
- ppsocket* ppsocket::accept(char* Peer, int MaxLen)
- {
-- int len;
-+#if __FreeBSD_version >= 400013
-+ socklen_t len;
-+#else
-+ unsigned len;
-+#endif
- ppsocket* accepted;
- char* peer;
-
diff --git a/comms/plp/files/patch-ad b/comms/plp/files/patch-ad
deleted file mode 100644
index c3cbb40d046e..000000000000
--- a/comms/plp/files/patch-ad
+++ /dev/null
@@ -1,20 +0,0 @@
---- rfsv/main.cc.orig Mon Apr 12 14:32:31 1999
-+++ rfsv/main.cc Wed Jan 26 20:44:56 2000
-@@ -107,7 +107,7 @@
-
- skt = new ppsocket();
- skt->startup();
-- res = skt->connect(NULL, sockNum);
-+ res = skt->connect("127.0.0.1", sockNum);
- if (!res) {
- delete skt;
-
-@@ -120,7 +120,7 @@
- usleep(100000);
- skt = new ppsocket();
- skt->startup();
-- res = skt->connect(NULL, sockNum);
-+ res = skt->connect("127.0.0.1", sockNum);
- if (!res) delete skt;
- }
-
diff --git a/comms/plp/files/patch-ae b/comms/plp/files/patch-ae
deleted file mode 100644
index 68e57bb34edc..000000000000
--- a/comms/plp/files/patch-ae
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.orig Wed Jan 26 20:50:25 2000
-+++ Makefile Wed Jan 26 20:53:10 2000
-@@ -16,15 +16,15 @@
-
- # Compiler & flags
- INCLUDE=-I../utils
--CFLAGS= -Wall -g -O2
--CC=g++ $(CFLAGS) $(INCLUDE)
-+CFLAGS+= -Wall
-+CC=${CXX} $(CFLAGS) $(INCLUDE)
-
- # Linker and flags
- LIBDIR=-L../utils
- # Solaris users uncomment this line instead of the next one
- #LIBS=-lutils -lsocket -lnsl
- LIBS=-lutils
--LD=g++ $(LIBDIR)
-+LD=${CXX} $(LIBDIR)
-
- # Archiver
- AR=ar -cr
diff --git a/comms/plp/files/patch-af b/comms/plp/files/patch-af
deleted file mode 100644
index e42b857c7815..000000000000
--- a/comms/plp/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- rfsv/rfsv16.cc.orig Sat Feb 19 21:10:24 2000
-+++ rfsv/rfsv16.cc Sat Feb 19 21:11:09 2000
-@@ -134,7 +134,7 @@
- {
- char dateBuff[100];
- struct tm *t;
-- t = gmtime(&date);
-+ t = gmtime((time_t *)&date);
- strftime(dateBuff, 100, "%d/%m/%y %H:%M:%S", t);
- cout << " " << dateBuff;
- }
diff --git a/comms/plp/files/patch-ag b/comms/plp/files/patch-ag
deleted file mode 100644
index b64ad518f9cf..000000000000
--- a/comms/plp/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- rfsv/rfsv32.cc.orig Sat Feb 19 21:12:22 2000
-+++ rfsv/rfsv32.cc Sat Feb 19 21:12:35 2000
-@@ -186,7 +186,7 @@
- long date = us;
- char dateBuff[100];
- struct tm *t;
-- t = gmtime(&date);
-+ t = gmtime((time_t *)&date);
- strftime(dateBuff, 100, "%d/%m/%y %H:%M:%S", t);
- cout << " " << dateBuff;
- }
diff --git a/comms/plp/pkg-descr b/comms/plp/pkg-descr
deleted file mode 100644
index e922d75bdd23..000000000000
--- a/comms/plp/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-PLP implements the Psion Link Protocol.
-
-This program is used to transfer data between a Psion Series 5mx
-(default) or Psion Series 5 to a Unix server. The ncp daemon is
-started to communicate with the Psion and an ftp like interface is
-provided by rfsv.
-
-Before using this port it is necessary to either
-
- a) create a symbolic link form the serial port the psion is
- connected to /dev/psion eg ln -s /dev/cuaa0 /dev/psion
-
-or
-
- b) start the ncp daemon with the correct serial port eg
- ncp -s 7501 -d /dev/cuaa0 -s5