aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-05-17 01:25:28 +0800
committertcberner <tcberner@FreeBSD.org>2017-05-17 01:25:28 +0800
commit6c21fd96c3fd9f8b94cb628078c2bfea500a610b (patch)
tree33d9bc0b5e605a5d3579fa88f5eeab1581dd936e /comms
parent698d427332dd5b77fdd1e025c59b06397d0c3635 (diff)
downloadfreebsd-ports-gnome-6c21fd96c3fd9f8b94cb628078c2bfea500a610b.tar.gz
freebsd-ports-gnome-6c21fd96c3fd9f8b94cb628078c2bfea500a610b.tar.zst
freebsd-ports-gnome-6c21fd96c3fd9f8b94cb628078c2bfea500a610b.zip
Fix shebangs.
Approved by: rakuco (mentor, implicit)
Diffstat (limited to 'comms')
-rw-r--r--comms/uhd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index ca11547754b2..c610fec6712d 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= uhd
PORTVERSION= 3.9.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= comms hamradio
MASTER_SITES= http://files.ettus.com/binaries/images/
DISTFILES= ${IMAGE_FILE}
@@ -27,13 +27,15 @@ CONFLICTS= usrp-[0-9]*
BROKEN_powerpc64= fails to link: undefined reference to boost function
USES= compiler:c++0x cmake:outsource gmake ncurses pkgconfig \
- dos2unix python:2.7
+ dos2unix python:2.7 shebangfix
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
#MAKE_JOBS_UNSAFE= yes
CXXFLAGS_amd64= -msse2
CXXFLAGS_i386= -msse2
+SHEBANG_GLOB= *.py *.py.in
+
CMAKE_ARGS+= -DPKG_LIB_DIR:STRING="share/uhd" -DUHD_TXRX_DEBUG_PRINTS="yes"
# for excruciating debug use this -db
#CMAKE_ARGS+= --debug-output --trace