aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-04-13 00:30:12 +0800
committerdanfe <danfe@FreeBSD.org>2015-04-13 00:30:12 +0800
commit1ccb105b43efce27be112255aa7e59ecf7cecd30 (patch)
tree33db34ceab76794164904eda9ec32fd66d7f8ff1 /comms
parent6a70efe746066e884c232362c19bc51e8e427b05 (diff)
downloadfreebsd-ports-gnome-1ccb105b43efce27be112255aa7e59ecf7cecd30.tar.gz
freebsd-ports-gnome-1ccb105b43efce27be112255aa7e59ecf7cecd30.tar.zst
freebsd-ports-gnome-1ccb105b43efce27be112255aa7e59ecf7cecd30.zip
- Unbreak (no more CSME sites), switch to sf.net (upstream) at the expense
of losing normal distfile name and having to set WRKSRC; contents remain the same (and so does the checksum) - Define LICENSE (GPLv2); install README file as part of documentation - Unmute building and installation commands while here - Fix one warning revealed by Clang (missing bzero(3) prototype), yet two others remain) - Transfer maintainership to the submitter PR: 199322 Submitted by: Chris Hutchinson
Diffstat (limited to 'comms')
-rw-r--r--comms/serialoverip/Makefile21
-rw-r--r--comms/serialoverip/distinfo4
-rw-r--r--comms/serialoverip/files/patch-serialoverip.c14
3 files changed, 29 insertions, 10 deletions
diff --git a/comms/serialoverip/Makefile b/comms/serialoverip/Makefile
index 79bf607075bc..8e0dc443ae58 100644
--- a/comms/serialoverip/Makefile
+++ b/comms/serialoverip/Makefile
@@ -4,18 +4,29 @@
PORTNAME= serialoverip
PORTVERSION= 1.0
CATEGORIES= comms net
-MASTER_SITES= CSME
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}
+DISTNAME= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@BSDforge.com
COMMENT= Transport of serial interfaces over UDP/IP
-BROKEN= No public distfiles
+LICENSE= GPLv2
+
+USES= tar:tgz
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
PLIST_FILES= sbin/${PORTNAME}
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
do-build:
- @cd ${WRKSRC}; ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME}
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/comms/serialoverip/distinfo b/comms/serialoverip/distinfo
index 9c8bb76fc14c..b7c278a7c2e2 100644
--- a/comms/serialoverip/distinfo
+++ b/comms/serialoverip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (serialoverip-1.0.tar.gz) = cea0a4285416b720f1be607a64af7d513872d7b38a86900c4e015266038490a2
-SIZE (serialoverip-1.0.tar.gz) = 164925
+SHA256 (serialoverip.tgz) = cea0a4285416b720f1be607a64af7d513872d7b38a86900c4e015266038490a2
+SIZE (serialoverip.tgz) = 164925
diff --git a/comms/serialoverip/files/patch-serialoverip.c b/comms/serialoverip/files/patch-serialoverip.c
index 3504a3edd9c5..92e7e4a47b30 100644
--- a/comms/serialoverip/files/patch-serialoverip.c
+++ b/comms/serialoverip/files/patch-serialoverip.c
@@ -1,6 +1,14 @@
---- serialoverip.c Sun Sep 3 16:04:54 2006
-+++ serialoverip.c Sun Sep 3 16:06:34 2006
-@@ -42,20 +42,19 @@
+--- serialoverip.c.orig 2002-03-08 22:37:09 UTC
++++ serialoverip.c
+@@ -34,6 +34,7 @@
+ #include <fcntl.h>
+ #include <termios.h>
+ #include <signal.h>
++#include <strings.h>
+
+ #define MAXMESG 2048
+
+@@ -42,20 +43,19 @@ char*pname;
int s[2],st[2];
void help(){