aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-03-13 16:18:38 +0800
committermiwi <miwi@FreeBSD.org>2014-03-13 16:18:38 +0800
commit3c29dfa081af6f277e55d281adb02e34fe65be67 (patch)
treed842421b657cbd7edad3a3d9ae7fc06f2fe68b48 /comms
parent5e8d1f1323f682685200134176beab7fece385a0 (diff)
downloadfreebsd-ports-gnome-3c29dfa081af6f277e55d281adb02e34fe65be67.tar.gz
freebsd-ports-gnome-3c29dfa081af6f277e55d281adb02e34fe65be67.tar.zst
freebsd-ports-gnome-3c29dfa081af6f277e55d281adb02e34fe65be67.zip
- Convert USE_GMAKE/USE_BZIP2 to USES
Diffstat (limited to 'comms')
-rw-r--r--comms/aldo/Makefile3
-rw-r--r--comms/bforce/Makefile3
-rw-r--r--comms/ems-flasher/Makefile2
-rw-r--r--comms/geoid/Makefile2
-rw-r--r--comms/hf/Makefile2
-rw-r--r--comms/linrad/Makefile3
-rw-r--r--comms/qrq/Makefile2
-rw-r--r--comms/scmxx/Makefile4
-rw-r--r--comms/syncterm/Makefile2
-rw-r--r--comms/unixcw/Makefile2
10 files changed, 10 insertions, 15 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index 816966ec2f26..f0c0ed8665a0 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -13,12 +13,11 @@ COMMENT= Morse code training program
LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao
-USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf automake libtool
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib"
-USE_GMAKE= yes
+USES= gmake tar:bzip2
PLIST_FILES= bin/aldo
MAN1= aldo.1
diff --git a/comms/bforce/Makefile b/comms/bforce/Makefile
index 34663225721b..5b99dd198c9f 100644
--- a/comms/bforce/Makefile
+++ b/comms/bforce/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= ftp://fido.kuzbass.ru/pub/fileecho/DALLAS.SOFT/
MAINTAINER= vk@vk.pp.ru
COMMENT= Simple ifcico like Fidonet technology mailer
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
CFLAGS+= -fno-builtin
diff --git a/comms/ems-flasher/Makefile b/comms/ems-flasher/Makefile
index 245cf199c9b4..0425ada05b29 100644
--- a/comms/ems-flasher/Makefile
+++ b/comms/ems-flasher/Makefile
@@ -14,7 +14,7 @@ COMMENT= Utility to flash ROM images to the EMS USB 64mb flash cart
LICENSE= MIT
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -g -Wall
LDFLAGS+= -lusb
USE_GCC= yes
diff --git a/comms/geoid/Makefile b/comms/geoid/Makefile
index 355a99dfefd5..e17babadbe72 100644
--- a/comms/geoid/Makefile
+++ b/comms/geoid/Makefile
@@ -16,7 +16,7 @@ COMMENT= Geodetic computer for amateur radio use
LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= makefile
post-patch:
diff --git a/comms/hf/Makefile b/comms/hf/Makefile
index 9729f555de95..98005b88bce0 100644
--- a/comms/hf/Makefile
+++ b/comms/hf/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= whiptail:${PORTSDIR}/devel/newt
USE_GNOME= gtk12
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${STAGEDIR}${PREFIX} --sysconfdir=${STAGEDIR}${PREFIX}
MAKE_JOBS_UNSAFE= yes
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index 19b894b804c9..aeec005a3efe 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -21,8 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GMAKE= yes
-USE_BZIP2= yes
+USES= gmake tar:bzip2
ALL_TARGET= xlinrad
USE_XORG= x11
ONLY_FOR_ARCHS= i386
diff --git a/comms/qrq/Makefile b/comms/qrq/Makefile
index f05db561fbec..dc2eda5ca588 100644
--- a/comms/qrq/Makefile
+++ b/comms/qrq/Makefile
@@ -12,7 +12,7 @@ COMMENT= Morse telegraphy trainer similar to the classic DOS version by DL4MM
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${STAGEDIR}${PREFIX}|g' \
diff --git a/comms/scmxx/Makefile b/comms/scmxx/Makefile
index 150137cf62b7..bbf0bcbef332 100644
--- a/comms/scmxx/Makefile
+++ b/comms/scmxx/Makefile
@@ -10,9 +10,7 @@ MASTER_SITES= SF
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Data exchange utility for Siemens mobile phones
-USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext iconv
+USES= gettext iconv gmake tar:bzip2
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/syncterm/Makefile b/comms/syncterm/Makefile
index 4db51f8e0450..75bf3f3a8a1d 100644
--- a/comms/syncterm/Makefile
+++ b/comms/syncterm/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= shurd@sasktel.net
COMMENT= ANSI-BBS terminal which supports telnet, rlogin, and SSH
WRKSRC= ${WRKDIR}/syncterm-${PORTVER}
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= GNUmakefile
PORTVER= 20110320
MAN1= syncterm.1
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
index af10f2bf1d18..cac326781792 100644
--- a/comms/unixcw/Makefile
+++ b/comms/unixcw/Makefile
@@ -26,7 +26,7 @@ PLIST_SUB+= XCWCP="@comment "
CONFIGURE_ARGS+= --disable-xcwcp
.endif
USE_LDCONFIG= yes
-USE_GMAKE= yes
+USES= gmake
USE_CSTD= gnu99
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}