aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-04-30 00:43:05 +0800
committerrene <rene@FreeBSD.org>2013-04-30 00:43:05 +0800
commit4474a0cc08c5d35a6a333ccf61e822717d7440fa (patch)
treea101ccfbdb487a4c9c92a67d6d88ac8775e3362a /comms
parent6d3249226ec6077a65ecc9129a6a4a11b61b2d09 (diff)
downloadfreebsd-ports-gnome-4474a0cc08c5d35a6a333ccf61e822717d7440fa.tar.gz
freebsd-ports-gnome-4474a0cc08c5d35a6a333ccf61e822717d7440fa.tar.zst
freebsd-ports-gnome-4474a0cc08c5d35a6a333ccf61e822717d7440fa.zip
In preparation of removing devel/libusb (expires 2013-04-30), remove it
from these ports. Other changes: - convert Makefile header - convert to optionsNG - remove indefinite article from comment - drop support for FreeBSD < 8.0 - pet portlint (leave library ABI versions in LIB_DEPENDS) - net-mgmt/spectools: change option name from GTK to GTK2 to use default description from bsd.options.desc.mk Approved by: portmgr (bapt)
Diffstat (limited to 'comms')
-rw-r--r--comms/dfu-programmer/Makefile9
-rw-r--r--comms/gnokii/Makefile6
-rw-r--r--comms/gnuradio/Makefile7
-rw-r--r--comms/libticables/Makefile13
4 files changed, 7 insertions, 28 deletions
diff --git a/comms/dfu-programmer/Makefile b/comms/dfu-programmer/Makefile
index ecf484489f9c..a87419358dbd 100644
--- a/comms/dfu-programmer/Makefile
+++ b/comms/dfu-programmer/Makefile
@@ -19,12 +19,7 @@ PLIST_FILES= bin/dfu-programmer
MAN1= dfu-programmer.1
PORTDOCS= *
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
-CONFIGURE_ARGS+=--disable-libusb_1_0
-.endif
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
@@ -34,4 +29,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 30661da03d94..1fe84c8682ae 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -63,12 +63,8 @@ LIB_DEPENDS+= ical:${PORTSDIR}/devel/libical
CONFIGURE_ARGS+= --disable-libical
.endif
-.if ${OSVERSION} < 800069
-. if ${PORT_OPTIONS:MUSB}
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-. else
+. if ! ${PORT_OPTIONS:MUSB}
CONFIGURE_ARGS+= --disable-libusb
-. endif
.endif
.if ${PORT_OPTIONS:MPCSC}
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index a49694bcbdd3..b5ce2cebc93c 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -46,10 +46,7 @@ OPTIONS_DEFAULT= USRP
USRP_DESC= Include USRP support (UHD) from Ettus
TESTING_DESC= Include testing support
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
-.endif
+.include <bsd.port.options.mk>
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -130,4 +127,4 @@ post-install:
@${ECHO} conf files are in ${PREFIX}/etc/gnuradio/conf.d
@${ECHO}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/libticables/Makefile b/comms/libticables/Makefile
index 9f70a457a1ba..0476ac227a46 100644
--- a/comms/libticables/Makefile
+++ b/comms/libticables/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: libticables
-# Date created: 27 August 2003
-# Whom: Tijl Coosemans <tijl@ulyssis.org>
-#
+# Created by: Tijl Coosemans <tijl@ulyssis.org>
# $FreeBSD$
#
@@ -25,12 +22,6 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
-.else
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>