aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-12 04:56:38 +0800
committermat <mat@FreeBSD.org>2016-10-12 04:56:38 +0800
commit822c92ea37f922c000cd3bf79caa9374a6391b4b (patch)
tree897076950a763eed58da59a1d03344c92a3f4861 /comms
parentb1aac047afc1d10fc87dbf7d97fcb82f86c9e4a0 (diff)
downloadfreebsd-ports-gnome-822c92ea37f922c000cd3bf79caa9374a6391b4b.tar.gz
freebsd-ports-gnome-822c92ea37f922c000cd3bf79caa9374a6391b4b.tar.zst
freebsd-ports-gnome-822c92ea37f922c000cd3bf79caa9374a6391b4b.zip
Whatever you do, ${PORTSDIR} always creeps in depends.
Sponsored by: Absolight
Diffstat (limited to 'comms')
-rw-r--r--comms/uhd/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 76eff708742d..d4fd55931ce0 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -17,12 +17,12 @@ GH_TAGNAME= 32951af2f3e7b1ddb56486c9f15b2e1033605bd6
CONFLICTS= usrp-[0-9]*
-LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs \
- cheetah-analyze:${PORTSDIR}/devel/py-cheetah \
- rst2html:${PORTSDIR}/textproc/py-docutils \
- orcc:${PORTSDIR}/devel/orc \
- ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
+LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
+ cheetah-analyze:devel/py-cheetah \
+ rst2html:textproc/py-docutils \
+ orcc:devel/orc \
+ ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako
USES= compiler:c++0x cmake:outsource gmake pkgconfig dos2unix python:2.7 pathfix
USE_LDCONFIG= yes
@@ -44,7 +44,7 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+BUILD_DEPENDS+= doxygen:devel/doxygen
CMAKE_ARGS+= -DENABLE_DOXYGEN:STRING="ON"
HAVEDOCS= YES
.endif